Furthermore, a selection can be every bit as incremental and precise as the image that houses it. Not only can you select each and every pixel inside an image—as a group or independently—you can also specify the degree to which you want to select a pixel—all the way, not at all, or in any of several hundred levels of translucency in between.

This means you can match the subtle transitions between neighboring pixels by creating smooth, soft, or fuzzy selection outlines. In Figure 4-4, I selected the umbrella and the man who holds it and transferred the two to an entirely different backdrop. I was able to not only maintain the subtle edges between the man and his environment, but also make the darkest portions of his coat translucent so they would blend with the backdrop. Selections take work, but they also deliver the goods.

**Selecting Colored Areas with the Magic Wand**

We’ll start things off with one of the most automated tools in all of Photoshop, the magic wand. A fixture of Photoshop since its very first release, the magic wand lets you select an area of color with a single click. It works especially well for removing skies and other relatively solid backgrounds, as the following exercise explains.

1. **Open two images.** Locate the Lesson 04 folder inside Lesson Files-PScs2 1on1 and open two image files, iStock scarecrow.jpg and iStock farmhouse.jpg. Move the images so you can see as much of them as possible, and then click the title bar for iStock scarecrow.jpg to bring it to the front, as illustrated in Figure 4-5. Our goal during this exercise will be to select the scarecrow with the magic wand tool and bring it into the farmhouse image. The fact that the two images were captured nowhere near each other and by two different photographers doesn’t bother Photoshop one bit.

2. **Select the magic wand tool in the toolbox.** Click the magic wand tool in the toolbox (see Figure 4-6) or press the W key,
3. **Confirm the options bar settings.** Pictured in Figure 4-7, the options bar displays a series of settings for the magic wand. Confirm that they are set as follows:

- The **Tolerance** value defines how many colors the wand selects at a time. I discuss this very important option in Step 5. In the meantime, leave it set to its default, 32.

- Turn on the **Anti-alias** check box to soften the selection outline just enough to make it look like an organic, photographic boundary. I talk more about this option in Step 13 on page 106.

- Turn on **Contiguous** to make sure that the magic wand selects uninterrupted regions of color. You'll get a sense of how contiguous selections work in Step 6.

Because this image does not include layers, the Sample All Layers check box has no effect.
4. **Click anywhere in the sky.** For the record, I clicked at the location illustrated by the cursor in Figure 4-8. But unless I missed a spot, you can click just about anywhere and you won’t select the entire sky. Which may seem like an odd thing. Here’s this tool that selects regions of color, and it can’t select what may be the most consistently colored cloudless sky ever photographed. What good is it?

---

**PEARL OF WISDOM**

What looks to you like a field of homogeneous blue that lightens a bit as it travels from top to bottom is in fact a collection of roughly 500,000 independent colors. Given current settings, the wand can select at most half that number, so some pixels are bound to get left out.

---

5. **Raise the Tolerance value.** The Tolerance setting determines how many colors are selected at a time, as measured in luminosity values. By default, Photoshop selects colors that are 32 luminosity values lighter and darker than the click point. After that, the selection drops off. Given that Photoshop did not select the entire sky, the Tolerance must be too low.

I suggest raising it to 50. The easiest way is to press the Enter or Return key to highlight the value, enter 50, and press Enter or Return again. Note that this has no immediate effect on the selection. Tolerance is a static setting, meaning that it affects the next operation you apply, as Step 6 explains.

6. **Expand the selection using the Similar command.** The Select menu provides two commands that let you expand the range of a selection based on the Tolerance setting. They both affect any kind of selection, but they were created with the wand tool in mind:

   - **Select→Grow** reappplies the magic wand, as if we had clicked all the pixels at once inside the selection with the magic wand tool. In other words, it uses the selection as a base for a larger selection. Grow selects only contiguous pixels — pixels that are adjacent to the selected pixels.

   - **Select→Similar** is almost identical to Grow, except it selects both adjacent and nonadjacent pixels. So where Grow would select blue sky pixels up to the point it encounters nonblue pixels, such as the straw that masquerades as the
scarecrow’s hands, Similar selects all blue pixels within the Tolerance range regardless of where they lie, including the blue pixels between his “fingers.”

**PEARL OF WISDOM**

Remember the Contiguous check box in the options bar (Step 3, page 101)? Grow is like using the magic wand with Contiguous turned on; Similar is like using the tool with Contiguous turned off. For example, suppose that you clicked with the wand tool inside a sunflower back in Figure 4-1. The Grow command would expand the selection outline inside that particular sunflower; Similar would expand the selection to include all three sunflowers.

For our purposes, we want to get all the blue pixels, wherever they may reside, so choose Select→Similar as shown in Figure 4-9.

Assuming that you loaded Deke Keys CS2 as I suggested in the Preface (Step 10, page xix), you can invoke Similar by pressing Ctrl+Shift+M (or ⌘-Shift-M). If you didn’t load my shortcuts, this keystroke launches ImageReady. Frankly, it’s worth loading Deke Keys CS2 just to block the ImageReady shortcut.

7. **Fill out the selection.** One application of Similar should be enough to select the entire sky. But if you miss a spot, press the Shift key and click that spot in the image window. Shift-clicking with the magic wand adds to a selection.

8. **Reverse the selection.** You may wonder if this approach makes sense. You want to select the scarecrow, and yet you’ve gone and selected the sky. As it turns out, this is by design. It’s easier to select a solid-colored sky than a spotty-colored scarecrow, and you can always reverse the selection. Choose Select→Inverse or press Ctrl+Shift+I (⌘-Shift-I on the Mac) to select those pixels that are not selected and deselect those that are. In this case, the scarecrow is selected and the sky is not (see Figure 4-10).

9. **Select the move tool in the toolbox.** Click the move tool in the toolbox (see Figure 4-11) or press the V key (as in mooV). The move tool lets you move selected pixels within an image or from one image to another.
10. **Drag the scarecrow into the farmhouse scene.** This operation is a little tricky, so make sure you read the following paragraph before you begin.

Position your cursor inside the scarecrow so it appears as an arrowhead with a little pair of scissors. Then drag the scarecrow from the *iStock scarecrow.jpg* image window into the *iStock farmhouse.jpg* window. Before you release the mouse button, press and hold the Shift key. Finally, release the mouse button and then release the Shift key.

What you just did is called a “drag with a Shift-drop.” By pressing Shift, you instructed Photoshop to register the scarecrow inside its new background. By *register*, I mean that the scarecrow occupies the same horizontal and vertical position in its new home as it did in its old one, as shown in Figure 4-12. Had you not pressed Shift, the scarecrow would have landed wherever you dropped it. (If you don’t get it quite right, press Ctrl+Z or ⇧-Z to undo the operation and try again.)
At this point, you have successfully used the magic wand tool to transfer the scarecrow into a new habitat. The only problem is, it doesn’t look particularly realistic. In fact, it looks like what it is—a Photoshop montage. If that’s good enough for you, skip ahead to the next exercise, “Using the Marquee Tools,” which begins on page 108. But if you want to make this scarecrow look like it’s really at home, we have a few steps to go.

11. **Select the Background layer in the Layers palette.** The Layers palette most likely appears in the bottom-right corner of your screen. If not, choose Window→Layers or press the F7 key to open it. You should see two layers, one for the scarecrow—an imported selection always appears on a new layer—and another for the background. Click the Background layer to make it active, as shown in Figure 4-13.

12. **Apply the Lens Blur filter.** To create a realistic depth-of-field effect, blur the background by choosing Filter→Blur→Lens Blur. The Lens Blur filter is a fairly complex plug-in program. If it takes a few moments to load, don’t worry and be patient. After the Lens Blur dialog box appears, do the following:

- Hold down Alt (or Option) to change the Cancel button to Reset and then click it. This calls up the filter’s default settings.
- Tab down to the Radius value and raise it to 20 pixels. This moves the background well outside the range of focus.
- Confirm that your settings look like those in Figure 4-14 and click the OK button.

Of all Photoshop’s blur filters, Lens Blur does the best job of simulating the image produced by a camera lens when focused on a different portion of a scene—which in our case happens to be the foreground scarecrow.
13. **Zoom in on a few details.** Use the zoom tool to zero in on the right side of the scarecrow (his left) to gauge how well the magic wand selected the image. As you can see in Figure 4-15, the selection has some problems.

- The edges look jagged, meaning that you can see a clear division between one pixel and its neighbor. Fortunately, these "jaggies" are mitigated by a slight softening effect known as **antialiasing**, a function of the Anti-alias check box that you turned on back in Step 3. The check box instructed the magic wand to partially select the thin line of pixels around the perimeter of the selection, thus creating a slight fade between the scarecrow and its new background. Had you turned Anti-alias off, the edges of the straw and other details would look worse.

- The straw also exhibits a problem called **haloing**, where a foreground image is outlined with a fringe of background color, in this case blue.

The jagged edges aren’t perfect, but they look fine when we’re zoomed out and they’re likely to print fine as well. The haloing is another matter. That needs to be fixed.

14. **Select the scarecrow layer in the Layers palette.** Click the Layer 1 item in the Layers palette to make it active.

15. **Choose the Inner Glow style.** Click the symbol in the bottom-left corner of the Layers palette to display a list of layer effects (see Figure 4-16). Then choose **Inner Glow** to display the large Layer Style dialog box.

By default, the Inner Glow style creates a glow along the inside edge of a layer, but you can also use it to override a glow by applying a color that’s more indigenous to the image, as the next step explains.

16. **Adjust the settings to remove the halo.** Here are the settings that I recommend:

- Set the **Blend Mode** to **Color**. This colorizes the fringe pixels rather than making them lighter.

- Reduce the **Opacity** to 50 percent. Because the effect traces the perimeter of the entire scarecrow—not just the straw—you want to keep it subtle.
• Click the color swatch, the one above the Elements section of the dialog box, to display the Color Picker dialog box. Move your cursor into the image window — notice it turns into an eyedropper — and click in a medium-orange part of the scarecrow’s left hand (your right) to lift a matching color. Then click OK.

• In the Elements section, change the Technique to Precise to trace into the corners of the straw and cover up all the blue.

• Set the Size value to 10 pixels to keep the glow small, so it doesn’t bleed too much into appropriately colored portions of the scarecrow such as his kerchief and pants.

The other options are best left set to their defaults (which is to say, Range set to 50 and all others set to 0). Once your setting match those in Figure 4-17, click the OK button.

The Inner Glow ably corrects the blue haloing, as demonstrated in Figure 4-18. (To learn more about layer styles, read Lesson 11, “Layer Styles and Adjustments.”) Save your layered image in the Photoshop (PSD) format and move on to the next exercise.
Using the Marquee Tools

After seeing the magic wand and its ability to select irregular regions of color, you may question the usefulness of a geometric selection tool such as the rectangular or elliptical marquee. After all, how many image elements are precisely rectangular or elliptical? The answer is: plenty. Every image begins life as a rectangle, and ellipses are as common as, well, our own Mother Earth.

But it goes beyond that. Both are great for selecting general regions that you want to use for any of a wide variety of purposes, as the following exercise makes clear:

1. **Open three images.** Open the *PhotoSpin red sky.jpg*, *PhotoSpin road.jpg*, and *PhotoSpin moon.jpg* files, all shown in Figure 4-19. These files are located in the Lesson 04 folder inside Lesson Files-PScs2 1on1. In the following steps, we’ll combine these images into a relatively complex composition using the singularly simple rectangular and elliptical marquee tools. We’ll also use the Match Color command to make the colors of the road and moon conform to those of the vivid red sky.

![Figure 4-19.](image-url)
2. **Select the rectangular marquee tool in the toolbox.** Bring the PhotoSpin road.jpg image to the front and click the rectangular marquee tool in the toolbox (see Figure 4-20) or press the M key. (If you accidentally select the elliptical marquee tool, press the M key again.) The rectangular marquee lets you select rectangular portions of an image.

3. **Confirm the options bar settings.** In the options bar, make sure that the Feather value is set to 0 and the Style is set to Normal. These default settings ensure that the marquee tool draws hard-edged rectangles of unconstrained height and width. In other words, they cause the tool to behave normally.

4. **Select the bottom portion of the image.** Drag with the rectangular marquee tool to select the bottom portion of the PhotoSpin road.jpg image, shown in Figure 4-21. Make sure you select all the way to the edges.

---

If you miss a bit of an edge, press the spacebar to temporarily stop drawing the marquee and instead adjust its position. When the spacebar is down, the marquee moves; release the spacebar to continue drawing.

---

Figure 4-20.

---

Figure 4-21.
5. **Choose the Feather command.** Choose Select→Feather or press Ctrl+Alt+D (Cmd-Option-D on the Mac, assuming that you changed the OS X dock preference, as directed on page xix of the Preface) to display the Feather dialog box, which allows you to blur the boundaries of a selection outline. Enter a relatively enormous Feather Radius value such as 120 pixels, and click OK (see Figure 4-22). This creates a gradual transition between selected and deselected pixels, as you’ll see in the next step.

![Feather Selection](image)

**Figure 4-22.**

---

6. **Drag the selected road into the red sky image.** You can use the move tool, as in Steps 9 and 10 of the preceding exercise (see pages 103 and 104), taking care to press the Shift key during the release. Or you can try a new technique:

Press and hold the Ctrl key (Cmd on the Mac) to get the move tool on-the-fly. With the key down, drag the selected portion of the road from PhotoSpin road.jpg into the PhotoSpin red sky.jpg image window. Before you drop it into place, press and hold the Shift key to center it. Release the mouse button, and then release both keys.

Either way, you should get the result shown in Figure 4-23.

![PhotoSpin red sky.jpg](image)

**Figure 4-23.**

7. **Bring the moon image to the front.** Click the title bar for the PhotoSpin moon.jpg window to bring it to the front.

8. **Select the elliptical marquee tool.** You can click the rectangular marquee icon in the toolbox or choose the elliptical marquee tool from the flyout menu, or just press the M key. (If you skipped Step 10 on page xix of the Preface, your different preference settings require you to press Shift+M to switch tools.)

9. **Select the moon (and then some).** Use the elliptical marquee tool to select an area well outside the moon, as in Figure 4-24.

Here are three keyboard tricks that can help you define your selection: Press the Alt key (Option on the Mac) while dragging with the elliptical marquee tool to draw from the center out. This lets you align the selection outline evenly around the moon. Press the Shift key to constrain the ellipse to a circle. (The moon is not quite circular, but you still may find Shift helpful.) Press the spacebar to move the ellipse on-the-fly.

![PhotoSpin moon.jpg](image)

**Figure 4-24.**
10. **Feather the edges of the selection.** Choose Select→Feather. Enter a Feather Radius value of 12 pixels and click OK. Although you can’t tell yet, this blurs the outline around the moon. Granted, it’s not as blurry as the super-gradual transition we assigned to the road, but it’s blurry nonetheless.

11. **Drag the moon into the red sky image.** Press Ctrl (⌘ on the Mac) and drag the moon into the Photospin red sky.jpg image window. This time, instead of pressing the Shift key to center the moon, just drop it in front of the sun directly over the road, as pictured in Figure 4-25.

To move an image element after you drop it, press the Ctrl key (⌘ on the Mac) and drag it to the desired location. You can also press the Ctrl key and nudge it using the four arrow keys (↑, ↓, ←, →).

12. **Invert the colors in the moon.** Choose Image→Adjustments→Invert or press Ctrl+I (⌘-I on the Mac) to invert the light and dark colors in the moon. The moon turns a deep blue, as shown in Figure 4-26. I like the luminosity values, but I’d prefer to have the colors match the colors of the red sky.
13. **Choose the Match Color command.** Choose **Image → Adjustments → Match Color** to display the **Match Color** dialog box, which lets you bring the colors in one image or layer in line with those in another.

14. **Set the Source option to the red sky.** Photoshop needs a destination and a source for its color modification. The **destination** is the image you want to change; the **source** is the image you want to match. At this point, Photoshop already knows the moon is the destination, because it was active when you chose Match Color. But you have to tell it the source.

   Click the **Source** pop-up menu toward the bottom of the dialog box and choose **PhotoSpin red sky.jpg**, the very image you’re working on. Next, set the **Layer** to **Background**. Right away, the moon turns to red with a yellow halo, as in Figure 4-27. When everything looks good, click **OK**.

15. **Select the road layer.** Make sure the **Layers** palette is up on the screen. Then click the **Layer 1** item to make it active.

16. **Select a thin strip of the road.** Switch to the rectangular marquee tool and draw a selection about half the width of the right side of the road and tall enough to extend into the clouds. The Match Color command will use the area you identify in its next set of calculations.
17. **Choose the Match Color command again.** This time, press the Alt key (or Option) as you choose **Image→Adjustments→Match Color.** This loads your last settings into the dialog box.

18. **Adjust the settings as needed.** The **Match Color** dialog box addresses a selection in a couple of different ways. It can apply its color modifications to just the selected pixels, as most color adjustment commands do. Or if you prefer, it can use the selection to calculate colors in the source or destination. Here's what you should do:

   - Turn on **Ignore Selection when Applying Adjustment**, which applies the color adjustment across the entire image.
   - For the two check boxes below **Image Statistics**, turn off the first and turn on the second. This uses the selection to calculate the destination colors, but not the source colors.
   - Raise the **Luminance** value to 120 percent.
   - Raise the **Color Intensity** (i.e., saturation) even higher, to 150 percent.
   - Finally, raise the **Fade** value to 40 percent. This fades the effect of the Match Color command so the reds of the sky blend a bit with the original road colors.

When your image looks like Figure 4-28, click the OK button.
If you like, you can stop now. After all, you've used the rectangular and elliptical marquee tools to great effect, merging three images from completely different photographs into a seamless whole. But the marquee tools can also be used to paint color into an image. In the remaining steps, I explain how to add a jet of color descending from the moon to the road and how to lift color from an image using the eyedropper tool. If you don't feel like following along, skip to the next exercise, "Selecting an Irregular Image," which begins on the next page. Otherwise, we've just seven more steps.

19. **Draw a new marquee.** This rectangle should connect the moon to the road, be slightly narrower than the moon, and descend slightly into the road, as shown in Figure 4-29.

20. **Feather the selection.** When you choose Select→Feather, note the Feather Radius value is still set to 12 pixels, as you specified back in Step 10. This remains a wonderful setting. To accept it and move on, click OK. The corners of the rectangular marquee will appear to round off slightly.

21. **Select the eyedropper tool.** Click the eyedropper tool in the toolbox (see Figure 4-30) or press the I key, for I-dropper.

22. **Eyedrop some amber.** Armed with the eyedropper, click the brightest, yellowest pixel you can find in the image. The resulting foreground color will most likely fall somewhere in the orange-to-amber range, as in Figure 4-30.

23. **Hide the selection outline.** Choose View→Extras or press Ctrl+H (Cmd-H on the Mac) to hide the animated dotted outline—aka marching ants—around the marquee.

Note that the selection outline is still there; the animated outline is merely hidden so you better see the results of your changes. To redisplay the marching ants, press Ctrl+H or Cmd-H again.

24. **Fill the selection with amber.** Press Alt+Backspace (Option-Delete on the Mac) to fill the selection with the foreground color. Even though the selection is invisible, Photoshop fills it with amber.
25. **Mix the amber fill with the road and sky.** Happily, Photoshop gives you the option to *fade* the most recent operation. Choose **Edit→Fade Fill** or press Ctrl+Shift+F (⌘-Shift-F on the Mac) to display the **Fade** dialog box. Then lower the **Opacity** value to 70 percent and choose **Overlay** from the **Mode** menu. The resulting freaky beam of light appears, as in Figure 4-31. If you were really taking this picture, I’d be urging you to shoot the damn thing and get the heck back in the car (only with different expletives).

The most amazing aspect of this otherworldly composition is that we managed to pull it off using Photoshop’s simplest selection tools, the rectangular and elliptical marquees. Of course, it didn’t hurt to soften the transitions with the **Feather** command. I hope the exercise leaves you with a sense of the many and varied applications for geometric selection outlines in Photoshop. Plus, it serves as a helpful public service reminder not to play in the street.

**Selecting an Irregular Image**

The lasso tools let you select irregular portions of an image. The primary lasso tool invites you to drag around an image to trace it freehand. But like freehand tools in all **graphics** programs, the lasso is haphazard and hard to control. That’s why Photoshop also includes a **polygonal lasso**, which allows you to select straight-edged areas inside an image. Admittedly, the polygonal lasso tool doesn’t suit all images, particularly those that contain rounded or curving objects. But as you’ll see, the tool is easy to control and precise to boot.

In the following exercise, you’ll experiment with both the standard and polygonal lasso tools, and get a feel for why the latter is typically more **useful**. You’ll also get the opportunity to play with a couple of special-effects commands from Photoshop’s **Filter** menu.