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Introduction 
 
This student workbook contains a set of exercises that clarify in a practical way the concepts explained in the Building Information Modeling with Autodesk® Revit® 
Building Lecture Notes by Simon Greenwold. 
 
The exercises cover the basic principles of the Autodesk Revit Building technology and the building information modeling (BIM) approach. For more training 
information, see the official Autodesk Revit Building training manuals, and the tutorials available from the Help menu. This workbook explains the different 
functionalities through various exercises, but the emphasis is on the workflow rather than on the tools themselves. 
 
The difficulty of the exercises increases as you proceed through the units, so it is recommended that you do them in sequence. Most units are independent and 
can be done starting with the provided file, named Unit (#) – Start. Files with the completed exercises are included in the data set folder and can be used to check 
your work. 
 
The workbook is structured in a three-column format (see below):  
 

The first column contains an explanation of all 
steps necessary to complete an exercise. 
 

The middle column contains the images that 
clarify visually the tasks to accomplish. 
 

The third column contains notes on the 
features and tools that are being used and a 
few helpful tips. 
 

 

 

 

 
We have prepared the following data for you: 
 

• Workbook (this document) 
• Workbook data sets (placed in a folder that contains all necessary files, families, and the template prepared for your use) 

 
Before starting the exercises, change the following settings to simplify use of this workbook and provide faster access to the data sets: 
 
 



Data Sets and the Autodesk Revit Building 
Library  

  

1. Copy the provided Workbook Data Sets 
folder onto your desktop. 

You can copy the data sets from the 
provided CD or download to any location 
you choose. 

2. Open Autodesk Revit Building. 
 

 

3. From the Settings menu, choose Options. 
 

 

4. Click the File Locations tab. 
 

5. Click the Add Library button.   

A library is a shortcut that appears in any 
Revit Building dialog box that asks you to 
browse for a file. This includes the Open 
and Saveas commands as well as others. 

6. Rename the newly created New Library 1 to 
Workbook Data Sets.  

 
7. Click in the blank Library Path field next to it, 

and then click the Flash icon at the far right 

of the row.  
       

     

 

8. Browse to the path where you saved the 
data sets and click OK. 

 
9. Click the Workbook Data Sets field and, 

using the upper flash sign , move it up 
to the first row. 

 

 

1 
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10. Now each time you go to the File menu to 
Open or Save, you see the folder in the 
browse window on the left so you can 
access it quickly. 

 

 

 
Note:  
Exercises for some lectures note units are not available here, and in some cases they have been grouped into a single exercise. The reason lies in the workflow 
approach that does not meet specific feature training requirements. For more information, see the Autodesk Official Training Courseware and the help file. 
 
We hope you enjoy learning the principles of Autodesk Revit Building and the BIM approach. 
 
Have fun! 
 



Unit 1 
Theory: CAD Versus BIM 

Autodesk Revit Building: Introduction, Interface, and Sketching 
In this first unit you start a new project, using the Default Imperial template. 
 

1. From the File menu, choose 
New>Project. 

 
 
 
 
 
 
 

 Templates are prepared drawing files that contain data 
according to office or project standards, helping to 
ensure that all team members who are working on the 
same project are using the same objects and 
standards. You can create these templates on your 
own, according to your office or project requirements. 

2. Click the Browse button, and select the 
Revit Workbook library shortcut icon. 

 

 

3. Select Workbook Imperial Template.rte. 
Click Open, and then click OK. 

 

 

In the default folder are templates for commercial and 
residential, as well as other specialized templates you 
can choose to start from. Each of these templates has 
unique families, views, and possibly sheets already 
loaded for you to work with. 



4. A new project file is created. 

 

 
You can set path to the default template used for all 
projects on the Settings menu: Options>File 
Locations>Default template file. This setting 
determines which template is used when you click the 
new project icon on the toolbar. 
 

Add Walls   

5. From the Basics Design Bar on the left of 
your screen, select the Wall tool. 

 

6. Draw four walls. Accept all the default 
values. The rectangle should be about 40’ 
x 30’. 

 
 
 
 
 
 
 

 

After selecting the Wall tool, the Options Bar displays 
the different options for drawing the wall segments. 
Select the rectangular shape to draw the external 
walls. 
 

 
 
Switch to the linear option to draw the interior walls. 
 



7. Without exiting the Wall command, 
change the wall type from the Options Bar 
to Generic- 5”. 

 

8. Draw two interior walls, as shown in the 
image at right. 

 
 

Zooming: Use the mouse wheel to zoom in and out of 
the drawing window. 

Add Doors and Windows   

9. On the Basics Design Bar select Door 
and place two doors Single-Flush: 36” x 
84”, as shown in the image. 

 

As you add these two doors, press the spacebar 
before you select a point to flip the swing before the 
door is placed. 
 

10. With the door tool still active, click the 
Load button on the Options Bar. 

  

Many other door types are installed with the software 
but not available within the general template you 
started with. When you load from library, you are 
bringing in a family of doors and all its types. 
 

 



11. Browse to the Doors folder and select the 
Double Flush door type and click Open. 

 

 

12. Change the door type on the Options Bar 
to Double-Flush: 72” x 84” and position a 
door on the left wall, as shown in the 
image. 

 

 

The horizontal arrows mirror the door along the wall it 
is positioned on. Both vertical and horizontal arrow 
symbols appear in doors, windows, furniture 
components, and in all families that can be mirrored or 
reversed without changing their geometry or their 
function. 
 
 

13. Press the Esc key twice to exit the 
command. 

 

 To end a command in Autodesk Revit Building, either 
press the Esc key two times, or right-click and choose 
Cancel two times. 

14. To change the swing direction, select the 
Single Flush door on the bottom vertical 
wall and click the vertical arrows that 
appear next to it. 

 

 

 

 



15. On the Basics Design Bar click Windows 
and select Fixed: 36” x 48” and position 
some windows on the exterior walls. 

 

 

Windows and doors are tagged automatically if Tag on 
Placement is selected on the Options Bar. To avoid 
automatic tagging, clear the option. 
  
The tags that appear when placing the components 
are set on the Settings menu: Annotations>Loaded 
Tags. 

16. Right-click and choose Cancel twice to 
exit the command. 

 

 Alternatively, you can select the next tool you want to 
use. Select the Modify tool from the top of the design 
bar. Type MD on the keyboard to end most commands 
and return to the basic cursor state. 

Add a Floor  
 

Sketch mode is activated when designing specific 
sketch-based components or geometry. The available 
options vary depending on the component you are 
designing. 
 

17. On the Basics Design Bar click Floor. You 
are now in sketch mode, and the Design 
Bar has changed. The default method for 
creating floors is by selecting existing 
walls (Pick Walls).  

 

 

You can draw the desired shape of your object (floor 
in this case) using the Lines tool, but often it is much 
faster and easier to accept the default proposed 
mode. The Pick Walls function automatically 
recognizes the boundary of the connected walls and 
generates a closed loop of lines that represent the 
shape of the floor. 



18. Select all connected walls at once: 

a. Place the cursor over one of the exterior 
walls (without clicking). 

b. Press the Tab key to highlight all four 
walls. 

    

This method is used frequently in Autodesk Revit 
Building. By holding your cursor over the object, 
pressing the Tab key, and then clicking, you can 
select connected chains of walls or lines. 
 
This screen capture is not from the project but 
illustrates the nature of the highlights on the screen. 
 

 

 

  

The side of the wall your cursor is on when you select 
a wall determines which side of the wall the sketch line 
is placed on.  
 
When you use Pick Walls to define your sketch, Revit 
Building snaps either to the exterior/interior faces of 
the wall or to its structural core layer, as set in the 
Options Bar. 



19. Click with the left mouse button to select 
the highlighted walls as the floor 
boundary. Make sure you click the interior 
side of the walls. 

 

 

When you click with the mouse, the software reads the 
geometry into the command and creates a magenta 
sketch line at each wall. 

20. Click Finish Sketch on the Design Bar to 
accept the floor sketch. 

 

You can reenter sketch mode any time after designing 
the component by selecting the component and 
clicking the Edit button on the Options Bar. 
 
 
 
 

21. Open a 3D view by clicking the 3D view 
icon on the toolbar. 

 

 

 

 



 

3D View Navigation   

22. Rotate the model by:    

• Pressing the Shift key and the middle 
button of the mouse at the same time.  

 
 

The cursor changes to the 3D rotate cursor. 

• Or clicking the icon on the View toolbar to 
open the Dynamic View dialog box. 

 

 

23. Select Spin mode. 

 

 

Model Graphic Style  You can use several different methods to change from 
shade mode to wireframe to hidden mode. 

Model graphic style by keyboard shortcut:  

24. Press the letters “SD” (in sequence) to 
activate a shaded view.  

  

The other keyboard shortcuts for graphic style are as 
follows: 
• WF = Wireframe 
• HL = Hidden line 
• AG = Advanced Model Graphics 
 
You can customize keyboard shortcuts by editing the 
keyboardshortcuts.txt file in the program folder. 



Model graphic style by view properties: 

 

25. Right-click the view and choose View 
Properties. In the Properties dialog box, 
change the Model Graphics Style to 
Wireframe.  

 

Like any wall or door, the view itself has properties. 
The properties page of a view controls many aspects 
of how the model is represented. 

 

Model graphic style by Workspace View 
toolbar:  

 

26. Click the model graphics tool at the 
bottom left of the workspace and choose 
Shaded with Edges from the context-
sensitive menu. 

 

Modify the Position of the 
Components 

Temporary Dimensions  

27. From the Project Browser, open Floor 
Plans Level 1 again by double-clicking 
Floor Plans>Level 1. Select the left 
exterior wall. A temporary dimension 
appears.  

 

The temporary dimension may not have the witness 
lines in the location you want. Drag the middle square 
grip on a temporary dimension line to a new location. 



28. Drag the square middle grip to the outside 
right exterior wall. 

 

29. Click the dimension text, and type 40 to 
change the building width to 40 feet. 

 

The units in Autodesk Revit Building are real-world 
units: you can set them to be metric or imperial. The 
dialog box for setting units is on the Settings menu 
under Units. You can also work in millimeters, 
centimeters, or meters, set in the same menu. 
 

30. Select the interior wall, and use the 
temporary dimensions to set the interior 
vertical wall to 20’ from one of the end 
walls. 

 

Notice that you have just defined a new position for 
the wall, but all other components adjusted 
accordingly. 
 
Temporary dimensions appear whenever you select a 
component. Edit these dimensions on the fly by 
clicking the text and typing the desired value. 
 
You can transform these dimensions into permanent 
dimensions by clicking the icon that appears below the 
dimension line. 

31. Add walls and doors to create a few more 
rooms, always using the image as a 
guide. 

 

By right-clicking a component, you can use the Place 
function, which activates insertion mode for the 
desired component. This command automatically 
inserts an object of the same type as the one selected. 
 



32. Select the double entrance door and 
change its position by changing the value 
of the lower temporary dimension: Type 
10 in the dimension text for 10’ – 0”.  

 
 

 

 

Add Ceilings   

33. Double-click Project Browser>Ceiling 
Plans>Level 1. 

34. On the Modeling Design Bar select 
Ceiling.  

35. On the Options Bar select Compound 
Ceiling: 2’ x 4’ ACT System. Click once 
inside each room to automatically 
generate the ceilings. 

 

Ceilings are also sketch based. The auto-generate 
tool is helpful, but if you need to change the shape, 
you must select the ceiling and select Edit on the 
Options Bar. 
 

36. Hold your cursor over the object, and 
press the Tab key: 

• Sometimes selecting objects that are 
colinear with other objects can be difficult.  

• Hold your cursor over the edge of a ceiling 
(which is also the same location as a wall).  

• Press the Tab key a couple times to cycle 
through the objects that are at the cursor 
location.  

 

 

 
  

 
 
Anything that you select with a left mouse-click is 
available as a tooltip and at the lower-left corner of the 
window at the status bar. 



 

Add a Roof  Roofs can be created by footprint or by extrusion. This 
exercise walks you through creating a roof by 
extrusion. 

37. Open view Floor Plans>Level 2. 

38. On the Modeling Design Bar select 
Roof>By Footprint.  

 

 

If the Pick Walls option is selected, the roof boundary 
follows the walls position and any further changes to 
the wall location are automatically propagated on the 
roof shape. 

 

39. You are in sketch mode. The default 
sketch mode is Pick walls.  

 Pick Walls is equivalent to assigning a constraint to 
maintain design intent or structural sense. 

40. On the Options Bar type 1’ 8” in the 
Overhang box and make sure that 
Defines Slope is selected. 

 

41. Highlight any exterior wall and press Tab 
to highlight all four. Click to create the 
roof footprint.  

 

When clicking, make sure your cursor is positioned on 
the exterior side of the walls or the overhang is on the 
wrong side. 



42. Click Finish Roof on the Design Bar.  

 

Tab selecting is a convenient way to select chains of 
components with a single click. It is widely used in 
sketch mode. 

43. A dialog box asks if you want to attach 
the highlighted walls to the roof. Click 
Yes. 

 

By clicking Yes, you are attaching the walls to the roof 
and thus defining an explicit relationship: if the roof 
changes height, the attached walls follow accordingly. 

44. Open the 3D View by clicking the 3D Icon 
to see the roof. 

 
 

45. Go back to floor plan Level 2. 

 
 
 

 

The 3D view category is automatically created once a 
3D view is opened. You can customize view grouping 
so the Project Browser can display the view groups in 
many different ways. 
 

46. Select the roof.  

 

47. On the Options Bar, click Edit. 

 

 

 



48. Select the left and right roof footprint 
lines. 

49. On the Options Bar, clear Defines Slope.  

 

 

Autodesk Revit Building manages the slopes by 
automatically adjusting most geometrical data. If the 
eaves are not correct, use the Align Eaves tool to 
correct the problem. 
 
To select more than a single item, hold down the Ctrl 
key as you select the objects.  
 
Hold down the Shift key to remove objects from an 
existing selection set. 

50. Select the top magenta line. Text 
displaying an angle value appears. 

51. Click the blue text and change the value 
to 2 1/2”. Repeat for the bottom line.  

52. Click Finish Roof. 
 

Sketch lines are displayed in magenta, which you can 
change to any other color (Settings>Line 
Styles>Lines(Sketch)). 
 
Change the value of the roof slope by selecting the 
slope-defining line and opening its Properties dialog 
box, where you find the angle parameter. 

Add a Camera (Perspective View)   

53. Open Floor Plan: Site.  

54. Go to View Design Bar. 

55. Select the Camera tool. 

56. Select a point at the lower left to place the 
camera. 

57. Select a point at the upper right to 
establish the direction the camera is 
pointing. 

 

The camera creates a perspective view that is 
automatically placed under the 3D group in the Project 
Browser. 
 
Once the camera view is generated, the camera itself 
is no longer displayed in plan views or 
sections/elevations. To display it, right-click the 3D 
perspective view in the Project Browser and choose 
Show Camera from the context-sensitive menu. 



58. Once you have placed a camera, the 
building displays in a 3D view. (Press SD 
to shade the view.) 

 

An easy way to reposition your camera directly in 
perspective view is by opening the Dynamically Modify 
View dialog box and applying the different options 
available for navigating in the 3D workspace. 
 
Note that you can change or modify elements directly 
in 3D perspective views only by selecting the 
component and opening its Properties dialog box. 
 
 

 
 
 



Unit 2 
Theory: Objects 

Autodesk Revit Building: Walls, Floors, and Ceilings 
This unit covers wall, floor, and roof basics. 

Add a New Level   

1. Open file Unit 2 – Start. Open to the 3D 
view. 

  

2. Open Elevation East.   

3. Select the open blue circle at the end of 
one gridline. 

4. Left-click and drag toward the building. 
Repeat with the right side. 

 

 

Autodesk Revit Building allows editing and creation of 
most components in all available views. 
 

5. On the Basics Design Bar select Level.  

6. Draw a level above Level 2 by drawing a 
horizontal line from left to right.  

 

Note how Autodesk Revit Building helps you snap to 
the beginning and end of the other level lines.  
 

7. Click the elevation text of the level mark, 
and type 24’. 

 

Some annotations allow direct editing of their 
properties (in this case: level height). Revit Building 
automatically recognizes the different units used for 
editing if the unit suffix is added after the value. 



8. Modify the roof position.  

9. Select the roof. Right-click and choose 
Properties. 

 

 

 
Levels are managed as any other entity. Levels are a 
data element in Revit Building. Although they look like 
a standard annotation, they are the basis for vertical 
control for most components in the building model. 
 

10. Change the Roof Base Level to Level 3. 

 

Change component constraints at any time during the 
design process. 

11. Open the 3D view. 

 

 

The roof is constrained to the level. As the level 
moves, the roof moves with it. In addition, because 
you attached the walls to the roof, the inherent 
constraint is applied, and they then follow the roof up 
to the third level as well.  

Change Wall Type  The template contains many different wall types. 
Walls, roofs, floors, ceilings, stairs, and railings are 
system families and cannot be loaded from an 
external file except by using the Transfer Project 
standards command on the File menu. 
 
Note that you must have at least two projects open in 
the same session for the tool to be available. 

12. Select the four exterior walls at once (hold 
your cursor over one wall and press the 
Tab key).  

13. On the Options Bar, change the wall type 
to Exterior – Brick on Mtl. Stud. 

 To transfer system families from one project to 
another, it is generally easier to copy an instance of 
that object from one project to another. The system 
family of the instance is then also copied into the 
target project. Just use Ctrl+C to copy and Ctrl+V to 
paste. 
 



14. Zoom in the 3D view to see the different 
finish and material of the wall type. 

 

  

Add a Floor Slab on Level 2   

15. Open Floor Plan Level 2.   

16. Right-click the Floor Plan Level 2 in the 
Project Browser. Right-click in the 
drawing area, and choose View 
Properties to open the View Properties 
window. Change the Detail Level from 
Coarse to Medium. 

17. Change the Underlay field to None. 

 

Views have many different properties that filter the 
information of the underlying data model and define 
how it is displayed. 
 

1 
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18. On the Basics Design Bar, select Floor. 
You are in sketch mode.  

 

 

 

When clicking the wall-defining line for the floor slab, 
make sure that 
• The option Extend to Core is flagged on the 

Options Bar. 
• The green lines that appear while highlighting the 

walls are in the middle of the wall (or slightly off 
center). This is the exterior face of the core of the 
wall - or if the cursor is inside the building, to the 
location between the gypsum finish and the stud. 

19. Hold your cursor over one exterior wall, 
and press Tab. Click to select the four 
exterior walls. 

20. Click Finish Sketch on the Design Bar. 

 

When you created the first floor, Pick Walls created a 
sketch line either inside or outside the wall. Now that 
the wall is of a different type (Brick on Stud), the 
definition has changed. Part of the definition is a core 
(or structural core). For this wall type the stud has 
been defined in the core and the brick defined as a 
finish on the core. 

21. In the two dialog boxes that appear when 
you finish the sketch, click Yes to both 
prompts. 

 
 

 
This prompt is asking if you want to establish a 
relationship between the interior walls and the new 
floor. Click Yes. 
 
This option cleans up the intersections among walls 
and the floor. 

 

 

 
This prompt is asking if you want to cut the geometry 
of the floor from the geometry of the wall. Click Yes. 
 
This option extends the floor into the wall to create a 
bearing condition that you see when you start working 
with the sections. 



22. Constrain walls to a different height. 

 

The interior walls were set to the second-level height 
when they were drawn. When you finished the floor, 
the interior walls were extended to the underside of 
the floor. As the floor level changes, wall height 
remains attached. 
 

23. Open the 3D view. Select the two visible 
exterior walls and the roof, and then click 
the Hide/Isolate icon on the View toolbar. 

 

 

Hide/Isolate is a view-specific tool that is useful when 
working in a 3D view displaying a lot of data. 
 
When the tool is active and a component is hidden or 
isolated, the icon on the View toolbar changes color to 
indicate that the view contains hidden data. 
 

 

 

The interior walls no longer extend all the way to Level 
2 but are attached to the underside of the floor. 



24. Click the Hide/Isolate icon, and on the 
View toolbar click Reset. Close the dialog 
box. 

25. Rotate the 3D view, as shown in image. 

 

 

26. Select the front wall (containing the 
double door). On the Options Bar click 
Detach, and then select the roof. 

 

 
 

27. Right-click the wall and choose 
Properties. 

 

 You can remove explicit relationships at any time. 

28. Change the Top Constraint value from 
Explicit to Level 2 and the Top Offset field 
to 4’. 

 

 



Add a Curtain Wall and Modify Its 
Properties 

 Curtain walls are considered as wall families. Most of 
the Instance parameters are the same as for the basic 
wall families, but the Type parameters are completely 
different. 
 

29. Open Floor Plan Level 2. On the Basics 
Design Bar click Wall, and change the 
wall type from the Options Bar to Curtain 
Wall: Exterior Glazing. 

 

  

30. Before you start drawing, set the height to 
Level 3 on the Options Bar. 

31. Draw a vertical wall, as shown in the 
image. 

 

 

 

32. Open the 3D view. 

 

  



33. Go to Project 
Browser>Families>Walls>Curtain Wall 
and right-click Exterior Glazing. Choose 
Properties. 

 

 

 

34. Change the pattern to the spacing as 
shown. Click OK to close the dialog box 
and see the changes in the model. 

 

 

There are many different ways to access a family’s 
Properties dialog box. 
 
The pattern layout properties refer to the curtain 
gridlines. 
 
The available options allow for flexible editing. 
 

35. Select the curtain wall, and on the 
Options Bar, click Attach, and then select 
the roof. 

 

This curtain wall type contains only the grid divisions. 
Mullions must be placed after positioning the curtain 
wall. 
 
To add mullions, on the Modeling Design Bar, click 
Mullion and click any curtain grid. 



Add a Section   

36. Open the view Floor Plan>Level 1, and on 
the Design Bar click Section and draw a 
building section, as shown in image.   

Like a level, creating a building section also creates a 
view that represents the section. 

37. Open the section by double-clicking the 
Building Section view that was 
automatically created in the Project 
Browser. 

 

Reverse section views by clicking the arrow symbols 
that appear next to the section head. 
 
Section heads and tails can be turned on or off and 
toggled among the available loaded ones by clicking 
the circular arrow symbols next to the section head 
and tail. 
 
Switch to the section view by double-clicking the 
section marker in plan view. This method works only if 
the section mark is deselected, showing a blue section 
bubble. 

38. Select the floor slabs on Level 1 and 
Level 2 (use the Ctrl key), and verify that 
their type is Generic - 12” on the Options 
Bar. 

 

 

 



 

Modify the Curtain Wall Division, 
and Change a Curtain Panel into a 
Door Panel 

  

39. Select the first gridline from the bottom on 
the curtain wall, and on the Options Bar 
click Add or Remove Segments. Click the 
middle segment to remove it. 

 

 

 

40. Using the Tab key, select the newly 
created curtain panel that is twice as big 
as the other ones (position the cursor next 
to the side of the panel and press Tab 
until it is highlighted). Open the Properties 
dialog box by clicking the icon on the 
Options Bar.  

 

 

41. Click Load and navigate to Imperial 
Library>Doors>Curtain Wall Dbl Glass.rfa. 

 

 

Load family components as needed during the design 
process. 
 



42. Click OK to accept and close the 
Properties dialog box. Open the 3D view 
to see the change.  

43. On the Window menu, choose Close 
Hidden Windows. 

 

 
As you work with the different views, they remain open 
until you close them. Close Hidden Windows enables 
you to free computer memory by closing those 
windows that you are not using.  
 

44. Open the view Floor Plan>Level 1, and 
then from the Window menu, choose Tile. 

 

Alternatively, you can press WT on your keyboard to 
tile the windows. 
 
Tiling windows enables you to work in more than one 
view at a time. 
 
This tool is particularly useful for selecting objects that 
may not be available from any one view. 
 

Copy Components from One 
Level to the Other 

  

45. Open Floor Plan Level 1.    

46. In plan view, draw a selection window 
around the building.  

 

 



47. Use the Filter Selection button to filter 
only the windows in the selection set.  

 
 

 

48. Check only the windows category. 

 
 
 

 

 

49. Press the Shift key, and remove the 
windows on the left side (on the vertical 
wall and the first ones from the left on the 
horizontal walls) from the selection set. 

 

 

The default section with the cursor movement is as 
follows: 
 
• Left to right: Include only those objects entirely 

within selection box. 
• Right to left: Include any element that lies within or 

is crossed by the bounds of the selection box. 
 
When selecting individual components: 
 
• Ctrl+click adds to the selection set. 
• Shift+click removes from selection set. 

Remove from selection 



50. From the Edit menu, choose Copy to 
Clipboard. Then from the Edit menu, 
choose Paste Aligned>Select Levels by 
Name>Level 2. 

 

 

You can use Paste Aligned on multiple levels at the 
same time by pressing Ctrl and clicking the level 
names in the dialog box. 

Modify a Wall Profile   

51. Open Floor Plan: Site. 

 

52. From the Basics Design Bar click Wall 
and select wall type (from the Options 
Bar): Generic 8” Height: Unconnected 4’. 

53. Draw four walls using the rectangle 
template from the Options Bar to create 
the wall around the building, as shown in 
image.  

Change wall height as well as any other wall property 
after it has been positioned by opening the Wall 
Properties dialog box. 
 

54. Open the 3D view. 

 

 

 



55. Select the north wall, and click Edit Profile 
from the Options Bar. You are in sketch 
mode. 

 

When editing the wall profile, you are in sketch mode 
and some specific rules are applied: 
 
• All wall constraints are removed while sketching. 
• The line that is constrained (usually the bottom 

and top lines) displays a lock if you select it. 
 

56. Select the top line of the wall and erase it. 
Create a new top profile for the wall using 
lines. Rotate the model for better visibility; 
use image as a guideline. 

 

 

 

57. Repeat the process with the south wall. 

 

You can create rectangular openings in curved walls 
but not edit the profile. To achieve a different profile, 
you must cut the wall with an in-place family. 

 
 
 



Unit 3 
Theory: Families and Nested Families 

Autodesk Revit Building: Editing Types 
In this lesson you work with families and types. You create a new wall type and window type from existing types in the project. For the wall you create a type with a 
sweep for a base and a reveal (cutout) at the top. You also split the brick, adding a new component to the wall base. Wall types are system families. They do not 
exist outside the project environment.  
 
Window families can be defined outside the project as RFA files or family files. For the window you duplicate an existing window type to create a new size window. 
Nested families and the Family Editor are explained in Units 10 and 11. This unit explains how to duplicate, edit, and manage a system family such 
as a wall. 
 
 

1. Open file Unit 3 – Start. Open to the 3D 
view and orient the view as shown. 

 

 

2. Right-click one of the exterior walls, and 
choose Properties. 

 

 

To access a component Properties window, select the 
component and do one of the following: 

• Right-click, and choose Properties 
• Click the Properties icon on the Options Bar  

 



3. Click the Edit/New button. 

 

   

 

4. Click Duplicate and enter Exterior - Brick 
on Mtl. Stud with Base as the new name 
for the wall type. 

 

 

It’s essential to always duplicate an existing type 
instead of editing it directly, which would mean that you 
were actually changing the standard Autodesk Revit 
Building library. You can easily purge excess types 
later. 
 

5. Click the Edit button under the Structure 
field. 

 

 

 

6. Click the Preview button in the bottom left 
of the dialog box. 

  

Every wall component has the following properties: 
layer, function, material, and thickness. Wall 
components can “wrap” around the wall end or at 
inserts. 
 

 

 



7. Default preview is plan structure. Change 
the view from floor plan to section at the 
lower portion of the preview pane. 

 

8. Add a sweep: 

 

9. Click the Sweeps button in the right pane. 
The Wall Sweeps dialog box opens. 

 
 

The layer determines how wall components clean up 
with each other.  
 
The material determines what hatch is shown when the 
wall is cut in section or plan or viewed in elevation along 
with the shading and rendering textures. Materials also 
affect how walls clean up.  
 
Note that the lower part of the structure window 
becomes active only if you switch the preview to 
Section.  
 

10. Click the Add button in the Wall Sweeps 
dialog box. After the sweep is added, the 
list sets the properties as shown at the 
right: 

• Wall Sweep - Brick Soldier Course 1 Brick 

• Material  = Brick Soldier Course 

• The other values should default to the 
values shown. 

 

 
 

 
 

There are two ways you can create sweeps: either 
internally to an object type definition (wall, railing) as in 
these steps, or a singular instance applied directly to an 
object (wall sweep/reveal, roof/slab edge) using the 
Sweep tools on the Design Bar. 
 

11. Use the Reveal button to add a reveal. 

• Reveal - Brick Course 1 Brick 

• Distance = 10’ 6”  

• From = Base 

• Exterior 

 
 



12. Click OK until you are back at the drawing 
window. 

  Reveal   Sweep 

You should see that a reveal notches out of a wall, and 
a sweep adds to the wall. 
 
Sweeps and reveals are profile based. The Sweep and 
Reveal dialog boxes allow for direct profile loading.  
 
A profile is an external family that consists of linear 
geometry. You define a closed line shape (similar to 
sketch mode) and save it as a family. Then you load the 
profile into the project as you would a door or window. 
However, unlike a door or window family, profiles 
cannot be used directly in the project but must be 
assigned to a sweep type definition (applied sweeps, 
roof slab edges), or directly to the object (wall and 
railing type definitions). 

• More on sweeps: 

Walls cannot have vertical sweeps set in 
the type, but they can be added manually 
from Modeling Design Bar>Host 
Sweep>Wall Reveal/Wall Sweep. You can 
also use this tool to create a horizontal 
instance of sweeps or reveals. 

 
Sweeps and reveals clean up correctly at angles 
and at inserts unless the inserted family contains 
specific solid elements in the family itself (that is, 
an exterior or interior door frame) that may 
interfere with the sweep/reveal. 

It is possible to grip-edit sweeps at inserts and corners 
to redefine them. It is also possible to modify the sweep 
return around the corner. Select any sweep and check 
the available options on the Options Bar. 

Split a Component to Add a New 
Material 

  

13. Select the wall you were working with, and 
return to the Structure Edit dialog box. 
Right-click the wall, and choose 
Properties>Type [edit/new]>Structure 
[edit]. 

14. Click the Split Regions button. Hold your 
cursor over the masonry brick exterior 
layer on the preview, and click near the 
bottom of the wall to divide the brick 
structure into two parts. 

 
 

 

 



15. Click the Modify button, and click the line 
dividing the two brick regions. 

16. With the edge selected, use the temporary 
dimension to move the line to 3’ above the 
bottom of the wall. Click the text of the 
temporary dimension and type 3 for 3’-0”. 

 

To select this edge, you probably need to use the hover 
and tab process: 
 
Hold your cursor over the split you made in the brick 
component. Do not select with the left mouse button yet. 
Use the Tab key to cycle through the various faces that 
you can select. Watch the edges highlight with each 
press of the Tab key. As you do this, watch the status 
bar at the lower-left corner of the application window. 
The status bar displays a description of what will be 
selected if you click at that time. 

17. Add a new layer for the split component.   

18. Click the Insert button to add a new 
component with these settings: 

• Function: Finish 2 [5] 

• Material: Concrete cast in place 

• Width: unchanged 

Make sure the layer row with the new 
component is selected. 

19. Click the Assign Layer button. 

20. Click the lower part of the exterior brick 
component in the preview pane to assign 
the new wall component to it. 

21. Click OK twice to close the dialog boxes.  
      
 
 

Once the regions have been divided, it’s not possible to 
edit the width of the component, as the system sets the 
default value to “variable thickness” according to how it 
is used within the wall type. That is, you could assign the 
same layer material to two different regions, laying on 
two different components, each with a different width. 
 



22. Select the remaining three exterior walls, 
and change their type from the Options 
Bar to the newly created type Exterior - 
Brick on Mtl. Stud with Base. 

 

 

You can split wall components into as many regions as 
you want, but creating complex walls should be done 
only when the design idea and the construction method 
are clear. Otherwise, editing the regions can become 
difficult when there are many of them. 

   

The wall you just modified belongs to a system 
family. It cannot exist outside the project (.rvt 
file) as a file you can edit. You create new 
types by duplicating existing types. 

External (Hosted) Families 
When you load from library, you are loading a 
separate file—a family (.rfa) file. These files 
store the basic geometry and parameters for 
components such as doors and windows.  

External families are also termed hosted families. 
Although this makes sense for doors and windows that 
are hosted by a wall, other components may be hosted 
by different components. For example, ceiling light 
fixtures must be placed on a ceiling. You cannot create 
an instance of a ceiling light unless there is a ceiling in 
the project. In general, all components that you load 
from the library are hosted at least by the level you 
place them on. 

Load a Window Family   

23. From the File menu, choose Load from 
Library>Load Family and navigate to the 
default Imperial Library>Windows folder. 

24. Activate the preview in the browsing 
window to see previews of the window 
types. 

25. Select the window family called 
Casement 3x3 with Trim.rfa. 

This is one of many ways to load families. In Unit 2 you 
loaded a family directly from the component’s 
Properties dialog box. You see more ways to load 
families later. 



26. Duplicate a window family to create a 
new window type. 

  

27. Go to Project 
Browser>Families>Windows>Fixed, 
right-click 36” x 48”, and choose Select 
All Instances.  

 

Selecting families from the Project Browser is a 
convenient and easy way to create a selection set for a 
specific family type. Because it is not view specific, it 
selects all types contained in the model. 
 
You can also select all instances by right-clicking one 
of the windows in any view and choosing Select All 
Instances from the context-sensitive menu. 

28. From the Options Bar change the window 
type to Casement 3x3 with Trim 36” x 
48”. 

 

 

 



29. Without deselecting the windows, right-
click and choose Properties. 

30. Click the Edit/New button. 

 

The Edit/New button opens the Type Properties dialog 
box. The parameters that appear in the first dialog box 
are the Instance properties. You can define Type 
parameters and Instance parameters during family 
creation. 

31. Click the Duplicate button. 

 

32. Create a new type named 48” x 48”. 

 
 

Duplicating the window type and modifying the window 
family does not automatically update the family file 
(RFA) stored outside the project file. You export the 
family to your library at the end of this exercise. 
 
It’s a convention to name types using their size so that 
other people using families can easily trace and 
understand them. In a team, conventions are a 
fundamental part of the design process optimization, 
making it easier to share the data consistently. 



33. Change Width value to 48”. 

34. Click OK twice to close all dialog boxes. 

There are many parameters in this dialog box that vary 
in type: length, material, text, and other component-
specific properties. Try changing the materials to see 
what happens. 
 
 

Export the Window Family   

35. From the File menu, choose Save to 
Library. 

 

36. From the Family to Save drop-down 
menu, select the family Casement 3x3 
with Trim. 

 Remember to save in a location that makes sense: 
always keep your personal libraries separate from the 
default installed library. 
 
If you save your libraries in the same folder as the 
Revit Building libraries, you might lose all of them if you 
forget to pull them out before upgrading to the next 
release. So, make it a habit to create your own library 
folder. 

Unit 4 
Theory: Parameters 

Autodesk Revit Building: Dimensions, Doors, and Windows 
This unit explains how to use doors, windows, and dimensioning in Autodesk Revit Building. 
 



1. Open file Unit 4 – Start. 

2. Open Floor Plan Level 2.  

3. Zoom into the east area of the building. 

4. Add the interior walls as shown in this 
image. 

 

 

 
 

As you add these walls, verify that your walls heights 
are set to Level 3. 

5. From the Basic Design Bar, select Door, 
and from the Options Bar, select door type: 
Single-Flush: 34” x 80”. 

6. On the Options Bar, clear Tag on 
Placement. 

 

 

7. Position the cursor over the vertical wall, 
as shown in the image. 

 

 
The door opening side is defined while positioning the 
door by moving the cursor from one side of the wall to 
the other. 

 
Pressing the spacebar while positioning changes the 
swing direction. 
 



8. Click to place the door. Try to place it so 
that the opening is in front of the 
perpendicular wall. 

 

A Warning dialog box displays if there is a conflict 
between the door and the wall. 

 
If you want, you can ignore this warning and resolve the 
problem later.  

9. On the Basic Design Bar, click Modify, and 
select the door.   

 

When you select a door, two symbols appear. Use 
them to invert opening side, swing direction, or both. 

 Invert swing. 

 Invert side. 

10. Click the text of the dimension that is 
attached to the horizontal wall in the 
middle. The value becomes editable. Type 
2’ and press Enter. 

 
 

 

11. On the Basic Design Bar, click Door, and 
from the Options Bar, click door type: 
Single-Flush: 34” x 80”. 

12. On the Options Bar, clear Tag on 
Placement. 

13. Place doors, as shown in the image. Use 
temporary dimension to get an idea of 
location relative to walls. 

 

 

 

You can edit temporary dimensions with the control 
boxes (blue squares) on each witness line. Just click a 
control box, and drag it to a new position. 
 



14. Select door and adjust dimension from 
door center to wall centerline. Type 2’ to 
change location of door.  

 

You can change what the temporary dimension is 
referencing by clicking or dragging the control box (blue 
square) on the witness line. 
 
Click these control boxes to move the witness line to 
another reference point. There is a limited set of points 
the witness lines will find with this method.  
 
By dragging this control box, you can move to entirely 
different objects. 
 

15. With the door still selected, change the 
dimension references so that they 
reference the face of wall and edge of door 
opening. Click the symbol ( ). The 
temporary dimension becomes a 
permanent dimension. 

 

You can use permanent dimensions to annotate your 
design, and they can be useful to place a relationship 
between components. 

16. Press Esc twice and select the permanent 
dimension that you just placed. Click the 
blue lock near the dimension line. 

 
 

When you click to lock the dimension, you are creating 
an explicit relationship. If you move the wall, the door 
retains its position relative to the wall. 
 
If you delete a dimension that establishes a 
relationship, Autodesk Revit Building displays a 
warning asking what you want to do. You can delete 
the dimension and keep the relationship or simply 
delete the dimension and the relationship. 



 

Load a Door Family and Change a 
Type  

 

17. From the File menu, choose Load from 
Library>Load Family. Navigate to the 
Doors folder in the imperial library. Select 
Double-Glass 2.rfa, and click Open. 

18. In the 3D view, rotate the model so that 
you can see the double door. 

 
 

The easiest way to rotate the model is by pressing the 
Shift key and the middle button of the mouse at the 
same time. 
 

19. Select the door, and from the Options Bar 
choose Double-Glass 2 : 68” x 80” in the 
type selector. 

 

 
 

 

20. Change Type and Instance parameters. 
 

 



21. Open Floor Plan Level 2.  

22. On the Basic Design Bar, click Window 
and click Load in the Options Bar. 

23. Navigate to the Imperial library Windows 
folder, select Casement with Trim.rfa, and 
click Open. 

24. On the Options Bar, click Casement with 
Trim: 24” x 24” and clear Tag on 
Placement. Add two windows on the 
vertical wall (east side) using the image as 
a guide. 

 

 

You can load a family in a project in many different 
ways: 
 

• From the File menu, choose Load from 
Library>Load Family 

• Select the corresponding button on the Design 
Bar, and click Load on the Options Bar 

• Drag a family from Windows Explorer and drop 
it into Revit Building 

 
The casement window is like the casement 3x3 
window but without the muntins. Different geometry, 
different family. 

25. Using Temporary dimensions, adjust the 
window’s position at 3’ from the horizontal 
wall. 

 

 

 



26. Go to Elevation East and select the two 
windows. 

27. On the Options Bar, click Properties. 

 

When you change an instance parameter, only the 
selected components are modified. 

28. In the Element Properties dialog box, 
change the Sill Height parameter to 5’. 

 
 

 



29. Click OK in the Element Properties dialog 
box. 

 

 

 



Unit 5 
Theory: Representations 

Autodesk Revit Building: Views, Visibility, and Sheets 
This unit covers the display features and capabilities of Autodesk Revit Building. It also covers some different presentation methods. 
This unit includes five exercises: 

• Exercise 5a leads you through adding a section and detail callout. This exercise also covers adding views to sheets. 
• Exercise 5b adds some material to the roof of the building. 
• Exercise 5c illustrates some fine-tuning control over the visibility and cleanup of walls in plan view. 
• Exercise 5d demonstrates how to create a sun and shadow study for your model. 
• Exercise 5e show you how to import a model created in Autodesk Revit Building to Autodesk® 3ds Max® software for visualization. 

Unit 5, Exercise A: Sections, Views, and Sheets 
In this exercise you add a section to the building. You then adjust the view properties for the section and add a detail callout to the section view. At the end of the 
exercise you create a new sheet and composite the views on the sheet. 
 

1. Open file Unit 5a – Start. Open Floor Plan 
Level 1.  

2. Zoom into the two first rooms on the left side 
of the building. 

 

 

 
 

 

3. Right-click in the view, and choose View 
Properties. 

 

 

You don’t have to open a view to edit the properties. 
You can simply right-click a view in the Project 
Browser and then choose Properties in the context-
sensitive menu. 
Note that in coarse mode the wall structure is not 
displayed. When you set the detail level, the structure 
is displayed. This setting is also accessible from the 
View toolbar. 
Autodesk Revit Building allows three different levels of 
detail (Fine, Medium, and Coarse). Objects in the 
project display correctly for each detail level. 



 

4. In the Element (view) Properties, change the 
detail level parameter to Medium and click 
OK. 

 
 

 

5. Open Floor Plans Level 2. 

6. Right-click in the view and choose View 
Properties. 

7. In the Element Properties dialog box change 
the Underlay parameter to Level 1. 

 

 

Autodesk Revit Building enables you to choose which 
view you want to use as an underlay. The view is 
displayed in gray, but you can use these elements for 
alignments or as a reference for new objects.  
 
Use all the levels in the building, or simply choose 
level below or level above. 

 



8. Open Floor Plans Level 1. 

9. On the Basic Design Bar, click Section, and 
draw a line from left to right. Use the image as 
a guide. 

 

The direction used to draw the section line defines the 
direction of the section. 

10. On the Basic Design Bar, click Modify. 

11. Double-click in the middle of the circle of the 
section bubble in the project. (The section 
bubble should be blue when you do this. In 
other words, it should not be selected.) 

 

You can also right-click the section line, and then 
choose Go to View. 

 
 

12. Change to the model graphics style Shading 
with Edges. 

13. Press WT on the keyboard to tile the 
windows. 

 

 

There are four Model Graphics Style modes: 
• Shading with edges 
• Shading 
• Hidden lines 
• Wireframe 

You have created a new view in the project. This view 
is automatically added to the Project Browser under 
Sections. 

 



14. Go to Floor Plans – Level 1. 

15. Select the section line. Some symbols are 
displayed next to the section line.  

 Flip the section. Cycle through different 
symbols for the section line. Change the symbol at 
each end of the section line. 

16. Click the arrow symbols to flip the section. 

 

 
 

 

17. In Plan Level 1, select the horizontal section 
line. 

18. Drag the blue triangle (in the middle of the 
green dashed line) so that this point is above 
the exterior south wall. 

 
 

When you move this point, you change a view 
parameter value: Far Clip Offset. You can change it in 
the view properties by assigning a value in the field. 
 



19. Make the section view active. 

 

The section view is now cut by the far clipping plane. 
 

Add a Detail Callout   

20. From the Design Bars View tools click Callout.  
 

You can modify the scale later in the callout view 
properties. 

21. On the Options Bar, change the Type to Detail 
Callout. 

22. Check that Scale is set to ½” = 1’-0”. 
 

 

 



23. Draw the detail frame (click and drag) around 
the intersection between the floor and the 
exterior wall on the right side of the building, 
as shown in the image. 

 

 
 

Adjust the size of the frame and replace the bubble by 
dragging the blue grips. 

24. Double-click the bubble that is attached to the 
callout frame. 

 

A callout view can be opened like the section view. 
Right-click the symbol, and then choose Go to View. 

 



25. Select the frame around the view. Use the 
blue grips to resize the view so that you see 
only what you want to show in this callout. 

 
 

Display this frame in any graphical view. It's a view 
parameter named: Crop Region. 

 
In a callout view (as in any other view) you can use 
detail tools. See Unit 14 for a complete description of 
this process. 

 
 

26. From the Project Browser, right-click Floor 
Plans - Level 1, and choose Duplicate.  

27. From the Project Browser, right-click Copy of 
Level 1, and choose Rename in the context-
sensitive menu.  

 

 
 

Duplicate a view with detailing (Duplicate with 
Detailing) or without (Duplicate). If you choose 
Duplicate only, then none of the detail components 
(those that are view specific, such as dimensions, 
tags, annotations) are duplicated. 



28. In the Rename View dialog box enter a new 
name for the view: Level 1 – Area, and click 
OK. 

 

 

29. From the Window menu, choose Close 
Hidden Windows. 

30. In the Project Browser, open Floor Plans 
Level 1. 

31. From the Window menu, choose Tile. 

You can now see the views side by side. 
 

 

32. In any view, move a wall. In all other views, 
that wall moves accordingly.  

 

 
 

Keep in mind that it's the same wall in the same 
building. When you move that wall in any view, all 
other views where that wall is visible automatically 
update. 
 
Even if you copy a view, you can choose to display it 
with a different scale, different detail level, different 
shading mode, and so forth.  

Working with Shade and Shadow  
 
 

Autodesk Revit Building provides the ability to work with 
shade and shadow directly in any view. This is part of 
the view properties called advanced model graphics. 

33. Set the West Elevation current.  

 

  



34. Right-click in the view, and choose View 
Properties. 

 
 

 

  

35. Next to Advanced Model Graphics, click the 
Edit button.  

 
 

  

36. Select Cast Shadow.  

 

  

37. Click the browse arrow for Sun and Shadow 
Settings.  

 
 

  

38. Change the preset to Sunlight from Top Left.  

 
 

The sunlight from top left is in relationship to the plan 
view of the building. 



39. Click OK three times to return to the drawing 
window. 

 
 
 

The shadow is now generated on the elevation. 
 
If the shadows do not show up immediately, change to 
a different view and return to this or try the refresh key 
on your keyboard (F8).  

Creating Sheets In Autodesk Revit Building, a sheet is another 
view of the building model. Sheets are listed in 
the Project Browser in their own category 
directly above the family list.  
 

The overall flow is as follows: 
• Create a sheet. 
• Place any of the views (plans, sections, 

elevations) on the sheet by dragging it onto the 
sheet view. 

• Adjust the properties of the plan view to meet your 
presentation needs. 

40. In the Project Browser, right-click Sheet and 
choose New Sheet from the context-sensitive 
menu. 

 

 

41. In the Select a Titleblock dialog box, click OK 
(use the default E1 30 x 42 Horizontal). 

 

To choose another title block, you have to first load it 
in your project. To load a title block, click the Load 
button in the Select a Titleblock dialog box. 



42. In the Project Browser, drag Floor Plans – 
Level 1 onto the sheet. 

 

Autodesk Revit Building won't let you place the same 
view twice on a sheet—or the same view on two 
separate sheets. Instead, you duplicate the view you 
want place on two separate sheets.  
 
The crop region determines the size of the view on the 
sheet. By default, the view is set to the extents of the 
objects in this view.  
 

43. In the Project Browser, right-click Floor Plans 
– Level 1. Choose Properties, and change 
View scale parameter to 1/4” – 1’-0”. Click 
OK. 

 

 

The view’s scale determines how large an area it takes 
up on the sheet. 

Return the Scale of Floor Plan Level 
1 to 1/8” 

  

44. Open Floor Plans Level 1. 

45. Select the elevation marker by dragging a 
window selection with the cursor. 

46. Drag the elevation marker toward the 
surrounding low wall. 

  

The elevation mark has two pieces: the square and the 
triangle. Select them both. 



47. Open the sheet.  

48. Drag the plan into the center of the sheet. 
Notice that the size of the view is now smaller. 

 

The title of the view also moves with the plan view. 

49. Move the title line at the lower left underneath 
the plan view by dragging it into place. 

50. Hold your cursor over the title mark and press 
the Tab key until you cycle through to 
Viewports: Viewport: Viewport 1: Shape 
Handle. 

 

 

If you cannot get the tooltip to appear with Viewports: 
Viewport: Viewport 1: Shape Handle, watch the status 
bar at the lower left for the same information identifier. 

51. Click the left mouse button, and drag the title 
mark into place. 

 

 



 

Adjust the Crop Region for the View    

52. In the Project Browser, right-click Floor Plans 
– Level 1 and choose Properties. 

53. Turn on the crop region for the view. 

54. Set view Floor Plan>Level 1 current. 

 

 

55. Select the crop region, and drag the blue grips 
in toward the building. 

 

 

The drawing sheet now reflects the smaller bounds 
established by the crop region. 

 

 



56. Open the sheet. 

57. Select the viewport in the sheet. 

58. Click the Properties button. 

 

The properties of the viewport are linked to the 
properties of the view, in this case Floor Plan Level 1. 

59. Change the scale of the viewport to 1/8” = 1’-
0”. 

 

When the view scale changes back to 1/8” = 1’-0”, the 
size on the sheet changes.  
 
If the title mark is selected as part of the viewport, you 
can just drag the ends of the title mark into position. 
You can also use the Shape handle.  

60. Repeat the preceding processes to lay out the 
sheet with the first and second floor plans, 
South and West elevations and sections, 
Section 1 and Section 2. 

61. Make the Section 2 ¼” = 1’-0” to fit on the 
sheet as shown. 

 

Take a look at the symbol of the section line. 
Autodesk Revit Building recognizes what sheet this 
section is positioned on and automatically fills in this 
information in the section bubble. Place the section on 
any other sheet, and the bubble updates automatically. 
Section bubbles are families that you can customize to 
display other information. 
 

 



Unit 5, Exercise B: Display Control of Materials 
This exercise takes you through creating a material for the roof in the project from the last exercise. 

 
 

Exercise Setup   

1. Open the file Unit 5b – Start.  

2. Set Floor Plans : Level 3. 

  

3. Right-click in the view, and choose View 
Properties. 

4. Next to View Range, click the Edit button. 

 

 

5. Set the Top offset to 30’. 

6. Set the Cut Plane offset to 30’. 

7. Click OK to close the dialog boxes.  

 

Create a New Roof Type 
 

  

8. Click the roof, and then click the Properties 
button on the Options Bar. 

  



9. In the Roof’s Element Properties dialog box: 

a. Change the roof type to Steel Truss – 
Insulation on Metal Deck EPDM. 

b. Click the Edit/New button. 

 

 

10. In the Type Properties dialog box: 

a. Click the Duplicate button, and name the 
new roof type Steel Truss – Insulation on 
Sheathing with Metal Roof. 

b. Click the structure’s Edit button. 

  

11. In the Edit Assembly dialog box: 

a. Click the Preview button if you do not see a 
preview by default (a last-used setting). 

b. Click Layer 5’s material, and then click the 
browse arrow that appears. 

 

 

12. Click the Light Gauge Steel Joist material. 

 

13. Repeat for layer 4, changing the material from 
Metal – Deck to Wood – Sheathing – 
Plywood. 

14. Change the thickness of this layer to ½”. 
 

Do not close the Edit Assembly dialog box yet. 

Create a New Material and Assign to 
the Roof Type 
 

In this section you will continue editing the 
assembly but create a new material on the fly. 

All materials defined in the project file can be accessed 
by choosing Materials from the Settings menu.  
 
In this example, you access these material definitions 
directly from the Edit Assembly dialog box. 



15. Click Layer 1’s material, and then click the 
browse arrow that appears. 

  

16. Click the Metal Roofing entry, and then click 
the Duplicate button. 

 

 

17. Enter Metal – Roofing Standing Seam as the 
name of the new material. 

  

18. Click the Color button in the shading portion 
of the Material dialog box, and pick a teal 
green color for the roof. 

 

This color is used in the model only when the view is 
set to shading or shading with edges. 

 

 

There are currently no standing seam materials 
provided with the software. If you have a JPG, you can 
create an AccuRender™ material from the image file. 
Because you are not going to render this building, for 
this exercise leave this setting as you found it. 

 

 

The Surface pattern is empty for this material. There is 
no Standing Seam fill pattern either. You will also 
create these on the fly. 

Create a New Fill Pattern for the 
Material 
 

In this section you create a new fill pattern on 
the fly to use in the material you just created. 

 

19. Click the browse arrow to the right of the 
empty surface pattern field. 

  



20. In the Fill Patterns dialog box: 

a. Click the Drafting radio button. 
b. Click the New button. 

 

 

21. In the Modify Pattern Properties dialog box: 

a. Set Orientation in Host Layers to Align with 
Element. 

b. Click Simple radio button. 
c. Name the pattern Standing Seam. 
d. Set the line angle to 90. 
e. Set the line spacing to ¼”. 
f. Click the Parallel Lines radio button. 
 

 

 



22. Click OK six time to close all dialog boxes 
and return to the drawing window. 

 

Drafting patterns change their scale depending on the 
view scale. Changing the scale of the view to ½” = 1’ – 
0” keeps the plotted distance between the lines 
consistent at ¼”. 

 

Create a Model Fill Pattern and 
Assign to the Material 
 

In this section you modify the material to use a 
new model fill pattern. 

 

23. From the Settings menu, choose Fill Patterns. 

 

 

24. This time click the Model radio button and 
then click the New button. 

  



25. In the Add Surface Pattern dialog box set: 

a. Type = Simple 
b. Name = Standing Seam 
c. Line angle = 90 
d. Line spacing = 24” 
e. Parallel Lines 

26. Click OK to close all dialog boxes. 

 

 

27. From the Settings menu, choose Materials. 

 

 

28. Set the material’s surface pattern to Standing 
Seam (Model). 

 

 



 

 

Model surface pattern dimensions are set by the fill 
pattern definition and do not vary by drawing scale. 

 

Unit 5, Exercise C: Fine-Tuning Wall Cleanup and Display 
This exercise illustrates some of the display and cleanup control you have over walls in your Revit Building project. 

 
 

Exercise Setup   

1. Open file Unit 5c – Start. Open Floor Plan 
Level 1.  

2. Verify that the view’s detail level is set to 
Coarse. 

 

 



Set Fill for Coarse Level Display 

 

Revit Building walls have a separate control for the 
display detail level Coarse. This coarse fill pattern and 
color allow you to poche the entire width of the wall 
regardless of the number of components in the wall. 
 
This setting is a type parameter for the wall. 
 

3. Select any wall and open its properties.   

4. Click the Edit/New button to access the wall’s 
type properties. 

  

5. Verify that Coarse Scale Fill Color is Black. 

 

 

6. Click in the Value field of the Coarse Scale 
Fill Pattern parameter, and click the browse 
arrow that appears in the field. 

 

7. Click Solid Fill for the fill pattern. 

 

 



8. Click OK two times to close all dialog boxes 
and return to the drawing window. 

 

 
 

Because this is a type parameter, you need to repeat 
this process for all wall types used in the project. 

Global Control of Linework Display 
of the Walls: Object Styles 

  

9. Set the View Detail level to Medium. 

 

 

10. From the Settings menu, choose Object 
Styles. 

 
 
 

 

11. On the Model Objects tab in the Object Styles 
dialog box, scroll down the list of objects and 
expand the walls category. 

 

The Object Styles dialog box controls the lineweight, 
color, and linetype. This is also where you can assign 
materials to objects. In all cases if the object is set to 
“By Category” for any of these parameters, these are 
the values referred to. 

12. Change the Walls Cut Line color to Blue and 
Common Edges to Red. 

 

Changes you make in the Object Styles dialog box are 
global and apply to all views. 
 

13. Click OK to return to the drawing window.  The object styles are now applied to all wall types in 
the project. The wall’s Cut (pen 5 and blue) refers to 
the outer edge of the wall. The wall’s subcategory 



 
 

Common refers to the lines common to the layers in 
the wall. 

Override Linework Display of the 
Walls: View Visibility/Graphics by 
Category 

Each view has its own override to the global 
object style settings. A couple of the previous 
exercises have used this control to manipulate 
how objects are displayed in specific views.  
 

The Visibility/Graphics dialog box also has overrides to 
the wall component display graphics. 
 

14. Open the View properties for Floor Plans: 
Level 1. 

15. Next to Visibility, click the Edit button. 

 

 

16. Click the wall’s Cut Line Style, and set the 
override line color to a dark green. 

17. Click OK to close all dialog boxes and return 
to the drawing window. 

 
 
 

These changes are only for the current view. 

 

18. Return to the view’s Visibility/Graphics 
Override dialog box, and on the Model 
Objects tab set the Override Model Patterns 
Cut Pattern Color to dark red. 

19. Click OK to return to the drawing window. 

 

All cut patterns for all layers in the wall type take on 
the override. 

 



Override Linework Display of the 
Walls: View Visibility/Graphics and 
Cut Line Styles 

  

20. Return to the view’s Visibility/Graphics 
Override dialog box. 

a. Select the Cut Line Styles check box. 
b. Click the Edit button. 
c. Set the Structure[1] to linewieght 5. 

21. Click OK to close all dialog boxes and return 
to the drawing window. 

 
 
 

Any layer in the wall type definition assigned to the 
structure layer now has the wider (pen 5) lineweight 
assigned to it. 

 
 

22. Return to the view’s Visibility/Graphics 
Override dialog box. 

a. Click the Cut Line Style’s Edit button. 
b. Set Core Layer Clean-up to Use Function. 

23. Click OK to close all dialog boxes and return 
to the drawing window. 

 

This setting affects only the layers within the core of 
the wall type’s definition. 

 

24. Return to the view’s Visibility/Graphics 
Override dialog box. 

a. Click the Cut Line Style’s Edit button. 
b. Set Core Layer Clean-up to Use Common 

Edge Style. 

25. Click OK to close all dialog boxes and return 
to the drawing window. 

 

This setting affects only the layers within the core of 
the wall type’s definition. Joins between individual 
walls are shown but use the common edge style 
graphic line. 

    

26. Repeat the step and set Core Layer Clean-up 
to No Edge. 

 No edges are shown at the core cleanup condition 
between joins. 

    



Wall Clean Up and Joins Revit Building walls automatically clean up as 
they are added to the project. This section 
guides you through control of some special 
conditions. 

 

27. Zoom into Condition A in the project. 

28. Click the Edit Wall Joins tool on the toolbar. 

 

 

 

29. Hover your cursor over the intersection of the 
walls until you see a square appear around 
the intersection, and then click that area. 

 

Once an intersection has been selected to edit, the 
configuration control appears on the Option Bar. The 
Next and Previous buttons cycle through various ways 
this intersection can be cleaned up. 

30. Click the Square Off radio button and then the 
Next button until you cycle through to the 
solution shown at right. 

 

 
 

 

31. While still in the Edit Wall Joins mode, click 
the intersection of the inverted T at condition 
C. 

 

This illustrates a condition that might happen when 
adding a new wall that abuts an existing wall. In this 
case you do not want the core penetrating through the 
existing (horizontal) wall. 

32. On the Option Bar, use the Display drop-
down to select Don’t Clean Join. 

 

 
 

The join is disallowed, and the wall does not cut 
through the existing brick face. 



 

33. Click the Modify tool to exit the Edit Wall 
Joins function, and zoom into the other 
intersection at condition C. 

 This condition is similar to the last; however, three 
walls make up the intersection. You cannot disallow all 
joins because you still want the two existing walls to 
clean up. 

34. Click the right wall of the three walls at this 
intersection, and right-click the blue end grip 
of this wall. 

35. Choose Disallow Join from the context-
sensitive menu. 

 

 

36. Drag the wall end to the exterior face of the 
existing brick. 

 

 

Wall Wraps You have control over the wrapping behavior 
of each of the components in a wall type 
definition. 

 

37. Zoom into Condition B in the project. 

38. Open the type properties of the horizontal 
wall. 

 

In this case, the exterior finish system does not wrap 
around the end of the wall to provide closure to the 
curtain wall. 



39. Change Wrapping at Ends to Exterior. 

40. Click OK to close all dialog boxes and return 
to the drawing window. 

 

The exterior layers now wrap around the end of the 
wall. 

 
 

 

 

Within the structure of the wall type, you can control 
which layers will wrap. 

 

  

Join Geometry Join Geometry has several uses. In general 
the join geometry will create a relationship 
between two objects. In this case the 
intersection between the walls will then clean 
up. 

 

41. Right-click the wall at condition D, and 
choose Create Similar. 

42. Draw a vertical wall from the number 1 to 2. 

 

As long as the walls do not cross near the end of a 
wall, the walls will clean up. 

 
 



43. Right-click the wall at condition E, and choose 
Create Similar. 

44. Draw a vertical wall from the number 3 to 4. 

 

If crossing walls do not clean up, you can use the Join 
Geometry tool to force the cleanup. 

45. Click the Join Geometry tool on the toolbar. 

 

 

46. Click one of the walls, then the other. 

 

The two walls now clean up with each other. 

 
 

Unit 5, Exercise D: Sun and Shadow Studies 
This exercise leads you through using the sun and shadow features of Autodesk Revit Building. 

 
 

Exercise Setup    



1. Open file Unit 5d – Start.  

2. Set the 3D Views : {3D} current. 

3. Click the Show Mass tool on the toolbar. 
 

 

Duplicate the 3D View Create a new view for the sun studies. Although not required, you could do the sun study in 
the 3D view. Because many of the settings for sun 
studies are view specific, creating a view specifically 
for the sun study is a good idea. 

4. Click the Dynamically Modify View tool. 

 

 

5. In the Dynamic View dialog box: 

a. Click the expansion bar at the right of the 
dialog box. 

b. Click the Orient to a direction, and click 
Southwest Isometric. 

c. Click the Save button. 

  

1      2     3  

6. Name the new view Southwest Isometric Sun 
Study. 

 



Set the Sun Study Parameters The parameters that drive the sun study 
function are held in the advanced model 
graphics for the view.  

You can access the advance model graphics either 
through the view properties or the context-sensitive 
menu of the drawing area window as shown here. 

7. Click the Shadows context-sensitive menu of 
the drawing window. 

8. Choose Advanced Model Graphics. 

 

 

9. In the Advanced Model Graphics dialog box: 

a. Select the Cast Shadows check box. 
b. Click the Sun and Shadows Settings arrow. 

 

 

10. In the Sun and Shadows Settings dialog box: 

a. Click the Single-Day tab. 
b. Change the place settings, and date and 

time intervals to your preferences. 
c. If you do not have a toposurface in the model 

(discussed in Unit 12), leave the ground 
plane selected. 

11. Click OK to close all dialog boxes and return 
to the drawing window. 

 

 
 



Preview the Sun Study in the View With the sun study parameters set, you are 
now ready to view the sun and shadows cast 
on the building model.  

 

12. On the Shadows context-sensitive menu of 
the drawing window, and choose Preview 
Solar Study. 

 

 

 

13. Click the Play button on the Options Bar. 

 

 The Sun Study plays through the day, cycling at the interval specified in the sun and shadow settings.  

 
Click the Next Frame button to manually walk through the study. 

Export the Sun Study to an AVI File With the sun study parameters set and 
previewed, you are ready to export the sun 
study to a movie format file. 

 

14. From the File menu, choose 
Export>Animated Solar Study. 

 

 



15. In the Save As dialog box, set the following: 

a. Name the AVI file. 
b. Change the frames per second to 1, as you 

have left the default at 1 frame per hour. 
Having 15 frames per second would make 
for a very short AVI! 

c. Adjust the format display mode and 
dimensions to your preferences.  

16. Click the Save button. 

 

17. Change the compression codec if you want, 
and click OK. 

 

The compressors available depend on the software 
installed on your machine. Full Frames is the most 
compatible compression method but also produces the 
largest file. 



 

Unit 5, Exercise E: Importing an Autodesk Revit Building Model into Autodesk 3ds Max 
 
The following exercise describes how to import a Revit Building model into Autodesk 3ds Max software for visualization. 
 

Set up Your Model for Export 
  

1. Before exporting your model, find the 
appropriate 3D view. Either use the default 3D 
view, or create your own by placing a camera. 

 

 

 

 

 



 

2. If you prefer to set up a camera, simply go to a 
plan view. From the View menu, choose 
New>Camera. 

 

 

  

 

 

 

3. Place the camera to create the appropriate view. 
 

 

 



4. With the camera in place, your 3D view is now 
ready for export. 

 

 

 

Export Your Model 
 

Autodesk Revit Building exports data in a variety of file formats, 
including DWG™ format. 

 

5. To export your design to the DWG format, from 
the File menu, choose Export>DWG, DXF, DGN, 
SAT. 

 

 

 

6. Choose a location to save your exported model, 
accept the default values, and click OK. When 
exporting a camera view, you see an alert 
indicating that the entire model, including 
everything not seen in the current view, will be 
exported. Click OK. 

 

  

Link Your Model to 3ds Max 
 

You can either import DWG files into a 3ds Max session or link them. 
Linking a DWG file to a 3ds Max session gives you the advantage of 

 



making subsequent changes in Revit Building and reloading them, via 
an exported DWG file, into 3ds Max without any data loss. 
 

7. To link the DWG file, from the File menu, choose 
File Link Manager. 

 

 

 

8. In the File Link Manager dialog box, click the File 
button on the Attach tab and browse to the 
exported DWG file. 

 

 

 



9. Select the DWG file, and click Open. 
 

Make sure that any cameras 
created in Revit Building are also 
available in 3ds Max.  

10. In the File Link Manager dialog box, click the 
Presets tab and modify a Named Preset. 
 

11.  If you do not want to modify an existing preset, 
copy it and then modify it. 

 

 

 



12. There are several options on this tab. To ensure 
that your Revit Building cameras are available in 
3ds Max, make sure the Views check box is 
selected. 

 

 

 

13. Save your modifications and then go back to the 
Attach tab in the File Link Manager dialog box.  

 
14. Click the Attach This File button to load the 

DWG file into 3ds Max. Then click Close. 
 

 

 



15. Your model is now loaded into 3ds Max. 
 

 

 

16. Once the model has been loaded, you can 
change the view to one of the camera views 
created in Revit Building by simply right-clicking 
the view name in the upper-left corner of the 
viewport and choosing Views>Camera: View # 
(where # represents the number of the Revit 
Building camera). 

 

 

Your Autodesk Revit Building 
model is now ready for 
visualization in 3ds Max! 
 

 

Unit 6 
Theory: Design Constraints 

Autodesk Revit Building: Levels, Reference Planes, and Grids 
This unit covers the basics of design constraints. 
 



Create Project File and Add Footing 
Level 
 

 

 

1. From the File menu, choose New>Project.  

2. Use the Workbook Imperial Template.rte in the 
location you placed the workbook data sets. 

 

 

 

3. In the Project Browser, open Elevations South.

  

Double-click the triangle symbol of an elevation 
in the project to automatically open the 
corresponding elevation.  

 

4. Select one of the level lines, and left drag the 
left grip toward the elevation markers, as 
shown in graphic.  

 

 

5. On the Basics Design Bar, click Level and click 
two points below Level 1. It does not matter 
where your two clicks are (use the image as a 
guide).  

6. On the Basics Design Bar, click Modify and 
select the level you just added.  

 

To place a new level, you must be in elevation 
view or in a section view.  
 



7. Drag the blue dot on the left until it is aligned 
with the existing ones. 

8. Do the same for the blue dot on the right.  

 

Autodesk Revit Building helps you here: As 
soon as the points are aligned, Revit Building 
displays a green dashed line along these points. 
You then see a blue padlock, which indicates 
that all the points are locked together. If you 
move one, all the others follow. 

9. With the level still selected, click the text of the 
dimension of this new level. Change the value 
to -2’- 6”. 

 

If you know the absolute elevation of a level, you 
can type it directly by clicking the text that is 
below the level line. 
 

10. On the Design Bar, click the Modify tool, and 
select the new level. 

11. Click the squiggle grip to offset the mark from 
Level 1. 

       
 

Each time you create a level, Revit Building 
automatically creates a view for that level. If you 
don’t want a view for a level, clear Make Plan 
View on the Options Bar. 

 

12. Drag the blue circle grips to adjust the leader 
away from the mark. 

 

You can choose to rename the level in the 
Project Browser by right-clicking this view and 
choosing Rename from the context-sensitive 
menu. 

13. Click the name of the new level (Level 3), and 
change this name to B.O.F. (Bottom of 
Foundations). Revit Building asks if you want 
to rename the corresponding view. Click Yes. 

 

 
 

 



Add Grid Lines 
 

Grids lines and level line marks behave much the same 
way and have similar controls for the marks. 

 

14. In the Project Browser, open Floor Plans Level 
1. 

15. On the Basics Design Bar, click Grid. 

 

The direction used to draw the gridline defines 
the side where the bubble is attached. 

 

16. Click two points to place the first vertical 
gridline. Pick from bottom to top, or south to 
north.  

17. On the Basics Design Bar, click Modify and 
select the gridline in the project. 

  

If you draw it in the wrong direction, you can use 
the check box that appears at the end of the 
gridline when the gridline is selected. 

 

 

 
Note: The same concept applies to level 
markers. 
 

18. On the Edit toolbar, click Array. 

19. On the Options Bar, set the following: 

a. Keep Linear. 
b. Keep Group and Associate selected. 
c. In the Number box, type 5. 
d. Keep Move to 2nd selected. 

20. Click the gridline, move your cursor to the right,
and on your keyboard, type 18’ and press 
Enter. 

  

When you‘ve finished the array, you can easily 
change the number of copies. If necessary, click 
an element in the array to display the number of 
copies. 

Adjust Arrayed Elements 
 

Modifying a dimension between arrayed elements will 
modify all arrayed elements. 

 



21. Click gridline 2, and on the Options Bar, click 
Activate Dimensions.  

 

 

22. Click the dimension that appears, and type 20 
to enter 20 feet for the distance. 

 

The entire grid system adjusts to the new 
dimension. 

23. Select all the vertical gridlines, and on the 
Options Bar click Ungroup. 

24. Press Esc.  

 

 
 

 

Each gridline can now be moved individually. 
 
Now that you've ungrouped the element, the 
number of elements in the array can no longer 
be changed automatically.  
 
The gridlines adjust as if you had used the Copy 
tool to create the five gridlines. 

Add Horizontal Grids  
 



25. On the Basics Design Bar, click Grid.  

a. Click two points to place the first horizontal 
gridline, from right to left. 

b. Press Esc twice. 

 

 

26. Zoom around the bubble of the horizontal 
gridline. 

27. Select the gridline. Click the text in the bubble, 
change the value to A, and press Enter. 

  

 

28. Create an array with this gridline. Clear Group 
and Associate. The distance between two lines 
should be 10’ and the number of copies set to 
4. 

 

 
 

Arrays in Autodesk Revit Building are powerful. 
You can move one element in the array and all 
the others move accordingly. Note, however, 
that this occurs only if you have selected Group 
and Associate on the Options Bar before array 
creation. 
 

Add Foundation Walls Constrained to 
Grids 

When you draw foundation walls, by default they extend 
down from the current level rather than up from it. You can 
change the view range to allow you to see these walls as 
they are drawn. 

 



29. Right-click in the view, and choose View 
Properties. 

30. In the Element Properties dialog box, click Edit 
next to View Range. 

 

 
 

The foundation wall is positioned below the 
current level. If you don’t change view depth, 
you cannot see the new wall that you are going 
to add. 
 

31. From the View Depth drop-down list, select 
Level Below. 

32. In the View Range dialog box, click OK. 

33. In the View Properties dialog box, click OK.  

 

34. On the Basics Design Bar, click Wall. 

35. On the Options Bar: 

a. Set type as Basic Wall: Foundation – 12” 
Concrete. 

b. Set Depth to Level B.O.F. 
c. Check that alignment is set to Wall Centerline.
d. Clear Chain. 

36. Draw a first wall from the intersection between 
lines 1-A and intersection 1-C. Click the lock 
symbol to lock the wall with the gridline. 

 
 

 

 



37. Using the image as a guide, add five walls. All 
of them must be locked with the corresponding 
gridline. Lock each wall section immediately 
after drawing it. 

 
 

If you’ve used the Chain option, you probably 
don’t see the padlock. Use the Align tool to lock 
the relationship between the gridline and the 
wall. 

 

38. Right-click in the view, and choose View 
Properties. 

39. In the Element Properties dialog box, click Edit 
next to View Range. 

40. In the View Depth drop-down list, select 
Associated Level. 

41. In the View Range and View Properties dialog 
boxes, click OK. 

 
 

The foundation walls disappear because they 
are not in the view range.  

42. On the Basics Design Bar, click Wall. 

43. On the Options Bar: 

a. Set type: Basic Wall: Generic- 8”. 
b. Set Height to Level 2. 
c. Check that alignment is set to Wall Centerline.
d. Clear Chain. 

44. For the foundation walls, lock each wall to the 
corresponding gridline. 

 
 

 



Add Structural Members Like foundation walls, structural members are often drawn 
down from the current level to the level below. This setting 
is similar to Walls on the Options Bar. 

If you do not see the Structural tab on the 
Design Bar, you can add it by right-clicking 
anywhere on the Design Bar and selecting it 
from the context-sensitive menu. 

45. Go to Floor Plans Level 2. 

 

 

46. From the Structural Design Bar, click Structural 
Column.  

47. On the Options Bar set: 

a. Type = W-Wide Flange-Column: W10X49 
b. Depth = Level 1 

48. Click the intersection between gridline B and 2.
  

Structural components are automatically locked 
with gridlines. Click precisely at the intersection; 
zoom in if necessary. 
 
Most structural elements, including the 
foundation, are drawn extending down. This 
includes the foundation wall and structural 
columns. 
 

49. On the Options Bar, click Grid Intersection and 
select gridline B, C, 3, 4. 

 
 

To enable multiselect, press the Ctrl key or 
select by frame: click two points that define the 
frame. The direction used to create the frame 
determines selection mode. 

 



50. Click Finish on the Options Bar. 

 
 

 

51. Press Esc twice. 

 

 
 

 

52. Click the dimension tool on the Basic Design 
Bar. 

a. Click gridline 1. 
b. Click gridline 2. 
c. Click a point to place the dimension. 

 

 



53. Click the Modify tool, and select gridline 2.  

54. Change dimension value to 7’. 

 
 

Because the wall between grids C and D along 
grid 2 has been locked or constrained to grid 2, 
it (and the foundation wall below this view) 
moves with the gridline. 

Add an Extruded Roof—Create and 
Set Work Plane 
 

Unit 1 leads you through creating a simple roof by 
footprint. When you create a roof by footprint with the Pick 
Walls option, there is a soft or inherent constraint between 
the roof and the walls that generated them. 

In this part of the exercise, you create a roof by 
extrusion. The extrusion roof is a shape 
generated by lines drawn in a reference plane 
perpendicular to the normal plan working plane. 
Once constructed, the extruded roof is defined 
by the location of its reference plane.   

55. Go to Floor Plans Level 1. 

56. On the Basics Design Bar, click Reference 
Plane. 

57. Add a reference plane on the west and east 
sides of the building. 

58. Press Esc twice. 

 

 

 
 

Drawing a reference is like drawing a line: you 
click two points (start, end). 

59. Add a permanent dimension from the reference
plane to Grid 1. 

60. Select the reference plane, and change the 
value of the dimension to 4’. 

  

To convert a temporary dimension into a 
permanent dimension, simply click the symbol 
below the dimension line. 
  
To lock the dimension, select it and click the 
blue padlock symbol near the dimension line. 
  
 



61. Select and lock the dimension. 

62. Repeat the same operations for the east side. 

 

 

63. Select the east side reference plane, and on 
the Options Bar, click Properties. 

64. In the Element Properties dialog box, type Roof 
Shape in the Name parameter. 

65. In the Element Properties dialog box, click OK.

 

 

 

 

66. Open the 3D view, and click Work Plane 
Visibility on the Tools toolbar.  

 

The blue grid is the work plane on which you 
create the sketch. In most cases Revit Building 
automatically creates a work plane that enables 
you to sketch. If Revit Building can't find a 
solution, it prompts you to select a suitable work 
plane. 

67. On the Basics Design Bar, click Roof>Roof by 
Extrusion. 

 

 
 

 



68. In the Work Plane dialog box, select Roof 
Shape from the Name drop-down list. 

69. Click OK in the Work Plane dialog box. 

 

  

As you can see, if you name a reference plane, 
it automatically creates a work plane. This is a 
useful feature. 
 
Work planes can be defined by a face on an 
object (a wall, for example), a reference plane, 
or a line. 
 
Notice that each of the gridlines is also 
automatically considered to be a work plane. 

70. In the Roof Reference Level and Offset dialog 
box, click OK to accept Level 2 as a reference 
level for the roof. 

 

 

71. Open the 3D view, and click Work Plane 
Visibility in the Tools toolbar. 

 
 

Work plane is aligned with the reference plane 
placed previously.  

 
To sketch the roof, it is easier to have a point of 
view perpendicular to the work plane. 
 

Add an Extruded Roof—Set View to 
Work Plane 
 

You can use one of the existing elevations, or set the view 
to the work plane as shown here. 

 



72. Press F8 on your keyboard. 

73. Expand the Dynamic View dialog box, and click
Orient to a Plane.  

 
 

 

74. In the Select Orientation Plane dialog box, 
select Roof Shape from the Name drop-down 
list. 

75. In the Select Orientation Plane dialog box, click 
OK. 

 

 

 

76. With the Line tool selected in the Design Bar, 
click Arc (Arc passing through three points) in 
the Options Bar. 

77. Draw an arc, using the image as a guide. 

78. Click Finish Sketch on the Design Bar. 

 

  

 



79. From the View menu, choose 
Orient>Northwest. 

80. Highlight an exterior wall, press Tab, and click 
to select the walls. 

81. On the Options Bar, click Attach and select the 
roof. 

 
 

 

82. Go to Floor Plans Level 2. 

83. Click Align on the Tools toolbar. 

84. Click the west reference plane. 

85. Click the edge of the roof. 

 

Introduction to View Templates  
A View template stores all the parameters of a 
view. You can create and apply these as 
needed to quickly adjust the view settings. 

86. In the Project Browser, right-click Floor Plans: 
Level 2 and choose Duplicate.  

 



You should now be working in a view titled Copy of 
Level 2. 

87. From the View menu, choose Apply View 
Template. 

88. Select Structural Framing Plan. 

89. Click Apply. 

The cut plane for a framing plan is much lower, 
so you see less of the roof.  
 
Also, the columns that were gray now show up 
solid. 

90. Select Architectural Plan. 

91. Click Apply, and then click OK. 
 

 

92. Right-click in the view, and choose View 
Properties. 

93. In the View Properties dialog box: 

a. Change the name to Roof Plan. 
b. Click the View Range’s Edit button. 

 

 

 

94. In the View Range dialog box, change the Top 
and Cut plane values to 40’. 

95. Click OK two times to return to the drawing 
window. 

 

 



96. From the View menu, choose Create Template 
from View. 

97. Type Roof Plan View Template for the 
template name. 

98. Click OK two times to return to the drawing 
window.  

 

99. Change to the Level 2 view. 

100. In the Project Browser, right-click floor plan 
Level 2 and choose Apply View Template. 

101. Select Roof Plan View Template from the list, 
and click OK. 

 

 

The View template you made and its parameters 
are applied to the Level 2 view as well. 
 
The next lesson explores View Templates in 
more depth. 

Add a Strip Footing  
 

102. Open the 3D view. Rotate the view to see the 
building in isometric. 

103. Click the Work Plane Visibility tool to turn off 
the grid. 

 

 



104. On the Structural Design Bar tab, click the 
Foundation>Wall tool. 

 

 

105. Click lower wall to add the continuous footing 
to the lower stem walls. 

      

 

 

 

Now that your model is filled out, explore the 
constraints still on the walls and gridlines. 

 



Unit 7 
Theory: Design Information Organization 

Autodesk Revit Building: Components, Categories, and Subcategories 
 
This unit has two exercises. The first exercise provides a quick overview of the organization and structure of Autodesk Revit Building design objects. The second 
exercise explores the user-created organizational system of Revit Building groups. 

Unit 7, Exercise A 
In this exercise you create and apply a view template to explore the categories and subcategories of object styles that are the basis for object organization and 
structure in Revit Building.  
 
 

 

1. Open file Unit 7a – start. The file should 
open with the Floor Plan Level 2 active.  

2. The plan view has a view template 
assigned to it (1/4” Architectural Plan). 

 

 



3. In the Project Browser, right-click Floor 
Plans: Level 2, and choose Duplicate with 
Detailing. 

  

Duplicate with Detailing copies the annotation 
elements that are placed in that view. 
 
The new view has dimensions, tags, and other 
annotation copied from the original view. 
 
Although you could use Duplicate rather than 
Duplicate with Detailing here, you are going to 
take care of these elements with a view template. 

4. Right-click Floor Plans: Copy of Level 2, 
and choose Rename.  

5. Rename this to Level 2 Furniture. 

 

 

Edit the Furniture Plan View 
Template 

  

6. From the Settings menu, choose View 
Templates. 

7. Set the view template to edit to 1/4” 
Furniture Plan. 

8. Under Visibility, click Edit. 

  

9. On the Model tab, note that Plumbing 
Fixtures is set to By Category. 

 

When a view uses the By Category setting, it is 
looking to the Settings>Object Styles for its 
display parameters. There are no overrides set 
for this view. 



10. Expand the Furniture category. 

 

These are the subcategories of Furniture. In 
general, subcategories are established by the 
families as you load them into the project. 

11. Click the Annotation tab. 

a. Clear Dimensions. 
b. Clear Door Tags. 
c. Clear Window Tags. 

12. Verify that Elevations and Sections are 
cleared. 

13. Click OK two times to return to the drawing 
window.  

Clearing these elements tells Revit Building not 
to display them when you apply this view 
template. 

14. In the Project Browser, right-click Level 2 
furniture, and choose Apply View Template. 
Select 1/4” Furniture Plan.  

  

You can save visibility settings in view templates 
and recall them to be assigned at any point to 
any view. The visibility settings define what 
categories and subcategories are visible within a 
view. 

15. Note that the furniture now appears, and 
the door and window tags and dimensions 
disappear per the settings in the view 
template. 

 

To save the active visibility setting that you 
define as a view template, from the View menu, 
choose Save as View Template. 
 
To apply a view template, from the View menu, 
choose Apply View Template, or right-click in the 
Project Browser and choose Apply View 
Template. 
 

Changing Object’s Display Globally The object styles control the linework representation for all 
the objects. Changes you make in this dialog box affect all 
views that do not have an override in place. 

Use Category/Subcategory structure to 
manipulate the settings for lineweight, line 
pattern, and material for the objects. 



16. From the Settings menu, choose Object 
Styles. 

 

The Object Styles dialog box has three tabs: 
Model Objects, Annotation Objects, and Imported 
Objects. 
 
You can control the appearance of model and 
annotation objects from the first two, while on the 
third tab you can control display settings for 
imported objects such as DWG format files (line 
color, weight, style). 

17. Scroll down the window to Plumbing 
Fixtures, and change color to Red. Click 
Apply. 

Because styles are not view specific, changing 
the color of a category affects the display of that 
category in all views. 

18. Scroll and expand the window, and select 
the Furniture category.  

19. Add a subcategory by clicking the New 
button.   

 

20. Name the new subcategory Bedroom 
Closet. 

 

 

21. Click OK, and change the subcategory 
color to Orange by clicking the line color 
column. 

 

Assign the Closet Shelf to the New   



Subcategory 

22. Select the furniture item inside the closet in 
the main bedroom (see image). It’s an in-
place family.  

23. On the Options Bar, click Edit.  

 

 

24. Again, select the shelf in the closet, and on 
the Options Bar, click the Properties button. 

 

 

25. Change the subcategory to Bedroom 
Closet. 

 

 

26. Right-click the symbolic lines defining the 
closet, and choose Properties. Assign the 
subcategory Bedroom Closet. 

  

 



27. Click OK to close window, and click Finish 
Family on the Design Bar. Note the color 
change of the component. 

 

The visibility of the Bedroom Closet subcategory 
can be switched off even if the rest of the 
furniture is visible. Open the Visibility settings for 
this view and expand the Furniture category. The 
Bedroom closet subcategory is now available as 
a parameter that you can control by object style 
for all views, or by visibility graphics for view 
overrides. 

 
 
 
 

Unit 7, Exercise B 
 
This exercise explores the user-created organizational system of groups. 
 
Open the data set Unit 7b - start.rvt. 
 

 

 

Verify that Floor Plans Level 1 is current.   



Create a Group    

1. Zoom into the desk and chair.   

2. Select the shelf, door, window desk, and 
chair. 

 

 

3. Click Group on the toolbar. 

 

 

4. Click Properties on the Options Bar. 

 

The group is created, but is named Group 1. It is 
a good habit to name your groups as you create 
them. 

5. In the Properties dialog box, click Edit/New. 

 

 

6. In the type properties, click Rename.   



7. Name the new group Typical Office, and 
click OK to return to the drawing window. 

 

The group has three grips. The middle grip is the 
insertion point of the group. 

8. Drag the insertion grip to the lower-left 
corner of the space. 

 

 

Array the Office Group   

9. With the group still selected, click the Array 
tool, and on the Options Bar, set: 

a. Array type = linear 
b. Clear Group and Associate 
c. Number = 6 
d. Move to 2nd 
e. Constrain = checked 

 

 
 

 

10. Click anywhere in the drawing window.  

11. Drag to the right. 

12. Type in 9 for 9’. 

13. Press the Enter key. 

 

 
The array is created. You cleared Group and 
Associate because the office parts are already in 
a group. 



Edit the Group  You can modify, add, or subtract from the 
objects in the group. 

14. Click any of the groups. 

 

 

15. On the Options Bar, click the Edit Group 
tool.  

The group is open for editing. Those objects not 
in the group are dimmed and not accessible. 

16. Move the desk, chair, and lamp toward the 
window. 

17. Move the door against the right wall. 

18. Rotate the shelf. 

 

 

19. Click the Finish Group tool on the Design 
Bar. 

 

 
The change is propagated through each of the 
offices. Even objects such as doors and 
windows that have relationships to the other 
elements can belong to and be modified by 
groups. 

Add Objects to the Group  To add objects to the group, the object must 
exist in the project drawing window before you 
edit the group  



20. Use the Component tool to add a Chair-
Corbu to the left office. 

 

 

21. Click any of the groups.   

22. On the Options Bar, click the Edit Group 
tool.  

 

23. Click the Add to Group tool. 

 

 

24. Click the chair you added. 

 

 

25. On the Design Bar, click the Finish Group 
tool. 

 

 
The chair is added to each of the offices. 

Duplicate the Group  Once a group has been defined in the project, it 
acts much like any other Revit Building object. 
You can create types based on the original. 

26. Click the left office group.    



27. On the Options Bar, click Properties. 

 

 

28. Click the Edit/New button. 

 

 

29. Click the Duplicate button. 

 

 

30. Name the new group Vice President Office. 

 

 

31. Click OK to return to the drawing window. 

 

The group selected when you accessed the 
properties takes on the new group definition. 

Modify the New Group   



32. Select the Vice President Office groups. 

 

 

33. On the Options Bar, click the Edit Group 
tool.  

 

34. Copy the Chair – Corbu.   

35. Change the desk type to 72” x 36”. 

 

 

36. Change the chair type to Executive. 
 

 

37. On the Design Bar, click the Finish Group 
tool. 

 

 

Apply Group Type to Another 
Group 

  



38. Click the group on the far right. 

39. On the Options Bar, change the group type 
to Vice President Office. 

 

Groups can be powerful tools for working with 
sets of objects in the Revit Building environment. 

 On your own, further explore the use of groups. Create an 
entry for the building. Can you create groups that you can 
swap out for one another, showing different solutions to 
the entry design? 

You can insert groups using the Design 
Bar>Modeling tab>Model Group tool.  
You can export groups and load groups using 
the File menu: Save to Library and Load from 
Library. These files are stored as RVG files 
outside the project (RVT) environment. 

40. Save and close the project. 

 



Unit 8 
Theory: Domain-Specific Knowledge 

Autodesk Revit Building: Roofs 
 

This exercise takes you through adding more detail to the roof and looks at how to put together multiple roofs to achieve different forms. 
 
 
 

Exercise Setup 
 

  

1. Open the data set Unit 8 – start.rvt. 

  

This data set is the same as the building at the 
end of exercise 7b. The southwest corner has 
been added, and a new level called Upper Roof 
has been created.  

Clip the Extruded Roof 
 

Any extruded roof (as opposed to a roof by footprint) can 
be cut using the Cut Plan Profile tool. 

 



2. Set the Roof Plan view current. 

3. Click the roof in the plan. 

4. On the Options Bar, click the Cut Plan Profile 
tool.  

This initiates sketch mode. Just draw the shape 
you want to remove from the extruded roof. This 
shape must be closed. 

5. Draw a shape that follows the outer edge of the
upper walls. 

 

Notice the linework on the south and west sides 
is outside the roof. Try not to make the lines 
coincident with the edge of the roof.  
 

6. On the Design Bar, click the Finish Sketch 
button.  

 

The shape that was sketched is now removed 
from the extruded roof. 

Roof by Footprint: Pick Walls Versus 
Lines with Offsets 
 

In this section you create an upper roof on the entry walls. 
Although an earlier unit illustrates Roof by Footprint, this 
section covers some of the limitations and workarounds 
using the roof you create here as a basis for a slightly 
more complex (to Revit Building) roof. 

 



7. Set the Upper Roof view current. 

8. Click the Roof>Roof by Footprint tool. 

 

9. On the Sketch Design Bar, click Pick Walls.  

 

 

10. On the Options Bar, set: 

a. Defines slope = selected 
b. Overhang = 2’-0” 
c. Extend to Wall Core = selected 

11. Click the two east walls to create the lines as 
shown at right. 

 

 

12. On the Sketch Design Bar, click Lines.  

 

 

13. On the Options Bar, set: 

a. Draw method = Pick Lines 
b. Defines slope = selected 
c. Offset = 2’-0” 

14. Draw the two lines on the west side, as shown 
in the image. 

 

 



15. Use the Trim tool to clean up the corners of the 
linework. 

 

 

16. On the Sketch Design Bar, click Roof 
Properties.  

17. Set the Rise/12” = 4”. 

18. Click OK to return to the drawing window. 
 

 

19. On the Sketch Design Bar, click Finish Roof. 

 

The roof is created, but it is not symmetrical to 
the entry walls. This is because of the 
differences in the lines created by picking walls 
versus using the Line tool. 

20. Add a section as shown here. 

 

 

21. Open the Section view, and tile the two views; 
Section 1 and Upper Roof.  

The sketch lines drawn with the Line tool 
originate at the edge of the roof at the level the 
roof is constrained to (left side of image). 
The sketch lines drawn with the Pick Walls tool 
establish the facia edge of the roof below the 
level by a distance determined by the slope of 
the roof over the overhang setting, in this case, 
4/12 over 2 feet. 
 



 

 

Notice also that the Pick Walls tool had Extend 
to Core selected. The outside face of the core 
(the metal studs) of the wall is used, and the 
overhang of 2’ is calculated from this point 
rather than the exterior face of the entire wall. 
As such, the overhang on the picked walls is 
slightly less than the overhang of the drawn-line 
segments. 

Align Eaves 
 

Align Eaves is a tool available in sketch mode of a 
footprint-type roof. 

 

22. Set the Upper Roof view current.  
 

23. Click the roof.  
 

24. On the Options Bar, click the Edit button.   
 

25. Click each of the lines, and use the temporary 
dimensions to adjust the distance to the face of 
the wall to 2’-0”. 

    

 

26. On the Sketch Design Bar, click the Align 
Eaves tool.   

 

27. Click the eave to align (the southeast line). 

 

 



28. Click the eave to align (the southwest line). 

 

 

29. Repeat for the northern lines. All the sketch 
lines should now be set to the same value.  

 

30. On the Sketch Design Bar, click Finish Roof.  The roof should now be symmetrical to the underlying 
entry walls. 

 

Multiple Roofs 
 

You sometimes need to create two or more roofs to 
complete the shape you are looking for. Any roof with a 
discontinuity in the form probably needs to be created out 
of two different roof objects. This section guides you 
though creating a simple example of such a roof as shown 
at right. 

 

31. Open the roof sketch for editing. 

a. Set the Upper Roof view current. 
b. Click the roof. 
c. On the Options Bar, click the Edit button. 

 

 

32. On the Sketch Design Bar, click Roof 
Properties.  

33. Set Rise/12” = 6”. 

34. Click OK to return to the drawing window. 

 

 

35. Delete the southwest line.  
 



36. On the Sketch Design Bar, click Lines, and on 
the Options Bar, set: 

a. Draw Method = Draw 
b. Defines Slope = Unchecked 
c. Offset = 0’-0” 

37. Draw the three lines on the west side shown in 
the image. Verify that these lines do not define 
slope.  

 

 

38. On the Sketch Design Bar, click Finish Roof.  

 

 

39. If you want, you can extend the wall to the roof 
by: 

a. Opening a 3D view 
b. Clicking the southwest wall 
c. Clicking Top/Base Attach on the Options Bar 
d. Clicking the roof to attach to 

 

 

Add the second roof to complete the form.  
 

40. Set the Upper Roof view current. 

41. Click the Roof>Roof by Footprint tool. 

42. Use the Line tool to draw the lines shown at 
right. 

 

Note only the outermost line defines a slope. 
The other three do not. 

43. On the Sketch Design Bar, click Finish Roof.  

 

The roof is finished, but like the first roof in the 
exercise, the linework is based at the upper roof 
level rather than the eave of the existing roof. 



44. Open the section view and use the Move tool 
and snaps to move the roof into place using 
the roof beyond as the reference. 

   

 

Add Fascias and Gutters 
 

Revit Building provides the ability to sweep a shape 
around the edge of a roof. This can be any shape stored in
a roof sweep type of profile family. The odd thing about 
many of the sweeps is that although the shape definition is 
stored in a family (RFA) file, the definition is buried (or 
nested) in a system family definition in the project file. 

 

45. Open the 3D view of the project.  
 

46. On the Design Bar, click the Modeling tab and 
then click the Host Sweep>Roof Fascia tool. 

 

47. There is only one type defined in this project. 

 

Note the fascia is a system family (defined only 
in the project, not as an RFA file). There are 
other families you can load and use in the 
project, but you would need to duplicate this 
type and assign the loaded profile into the type 
parameters of the new type. 

 

48. Click the upper edge of the fascia area of a 
roof. 

 
 

49. Continue clicking edges to add the fascia to 
each edge of the roof.   

 



50. On the Design Bar, click the Modeling tab and 
then click the Host Sweep>Roof Gutter. 

 

 

51. Click the fascia edge about the entry door. 

 

Be careful as you select. Because the inside 
face of the fascia, the roof, and the outside face 
of the fascia are all very close together, it is 
easy to add the gutter to the wrong edge. 

Add Soffits 
 

Creating a soffit in Revit Building is much like creating a 
roof. 

 

52. Set the Upper Roof level current.  
 

53. Click Roof>Roof Soffit.  

 

 



54. Draw two sets of lines, as shown in the 
illustration. 

 

Although there are automatic selection tools that 
enable you to select roofs and walls, because 
this is not just a single roof, you may find it 
easier to draw the lines manually. 

55. On the Sketch Design Bar, click Roof Soffit 
Properties, and set the Height Offset From 
Level to -1’-0”. 

 

 

56. On the Sketch Design Bar, click Finish Sketch.

  

57. Click the Join Geometry tool. 

58. Click the soffit, and then click the roof. 

 

The two geometries are joined, and the profile 
line wraps both objects. 



 

Unit 9 
Theory: Delaying Specificity 

Autodesk Revit Building: Massing 
This unit shows how to use the massing tools. 
 
There are two exercises in this unit. This first exercise guides you through the process of adding mass elements to a Revit Building project. The second illustrates 
the software’s ability to import Sketch-up files and how to use them as mass elements. 

Unit 9, Exercise A: Mass Components and Building Maker 
In this exercise you work with Autodesk Revit Building software’s Building Maker. Building Maker is a collection of tools that includes 
• Mass elements composed of solid forms and void forms 
• Walls, floors, roofs, and curtain systems associated with the mass faces 
 
The general workflow in this exercise is to create the mass forms, apply the building elements to the faces, modify the forms, and then update the building 
elements to the new geometry of the changed form. 
 
 

Exercise Setup   

1. Open file: Unit 9a – Start.rvt. 

 

 



2. In site view, right-click the Design Bar and 
choose Massing from the context-sensitive 
menu to show the Massing Design Bar if it is 
not already visible. 

 

Design Bars can be displayed or hidden to 
optimize screen space. 

Add a Mass   

3. On the Massing Design Bar, click Create 
Mass.  

 

Both Additive (Add Mass) and Subtractive (Cut 
Mass) Masses are created in sketch mode. 

4. Click OK in the Show Massing dialog box if 
it appears. 

 

 

5. Give the massing a name. 

 

 

6. The Massing dialog box appears. Click Solid 
Form>Solid Extrusion. 

 

Forms can be created in four ways (Extrusion, 
Blend, Revolve, Sweep) and can be either solid or 
void. Voids are subtractive forms that cut geometry 
from solid forms. 

7. On the Options Bar, enter 70’. Click the pick 
lines (the Arrow symbol) option on the 
Options Bar.  

 

  

Sketch lines can be drawn or selected. When 
selecting, it’s possible to automatically lock the 
lines to the original drawing by clicking the Lock 
option on the Options Bar. 

8. Zoom into the upper-right city block, and   



highlight one of the lines that defines the 
building footprint. 

9. Hover the cursor over one of the lines. 
Press Tab, and then click to select all the 
lines. 

 

Like selecting a chain of walls, you can click 
connected lines to generate sketch lines by using 
the Tab key. 

10. Click Finish Sketch to complete the mass. 

 

Quit Sketch discards the lines that were drawn in 
sketch mode. 

11. Repeat steps 6–10 to create a mass for the 
small building on the same block. 

  

12. Click Finish Mass to complete the mass. 

 

This is a nested series of sketch modes. One 
mode takes you to the mass creation set of Design 
Bar options. When you start a solid or void, you 
drop down one more level and the Design Bar 
changes to a more familiar sketch mode. You must 
click Finish Sketch and Finish Mass to complete 
the command. 



13. Change to the 3D view. 

 

You have drawn two shapes in the mass element 
sketch mode. These will be two parts on a singular 
mass element when selected. 

Add the Remaining Masses   

14. Return to the site view and repeat the 
process with all the building footprints in the 
blocks. 

  

15. Set the mass heights as shown in the image 
on the right.  
 
Note: Because some masses have two 
loops of lines, as in the building in the upper 
left, use Tab to select both of the closed-line
loops. 

 

Change heights (or depths) after creating the 
masses by selecting the mass, opening its 
Properties window, and changing the value in the 
Beginning and End fields. 
 
Note that for some buildings, you may have to 
complete the sketch by drawing lines instead of 
just selecting them. 
 
Create the building at the lower right as two 
different solids within one mass element. Don’t try 
to make it two parts of the same solid extrusion. 

82’ 70’  

34’ 

106’ 

94’ 



16. Open the 3D view. Type SD for a shaded 
view of the massing. 

 

 

17. Resize the southwest mass by dragging the 
blue grips that appear (one grip for each 
face). 

 

Edit masses directly in any view by selecting the 
grips and dragging.  

Edit the SW Mass to Add a Void The process of adding a void—or subtractive solid—is the 
same as creating the original solid. 

 

18. With the lower-left mass still selected, click 
Edit on the Design Bar. 

  



19. Click Void Form>Void Extrusion. 

 

 

20. On the Sketch Design Bar, click Set Work 
Plane.  

  

Setting a work plane allows automatic change of 
the coordinate system in a simple way. 

21. The Work Plane dialog box appears. Select 
Pick a Plane. 

 

Select any face, reference plane, or gridline as an 
active work plane. In the Name drop-down are 
named reference planes, levels, and gridlines. 

22. Click the vertical face of the mass located 
on the lower-left block.  

23. On the Design Bar, click the Work Plane 
Visibility button to see the active work plane.

  

In this case you are selecting a vertical face 
directly in the 3D view. 

 



24. Select the Line tool, and draw a rectangle-
based sketch. Autodesk Revit Building 
automatically changes the relative 
coordinate system to vertical. 

 

Switch to an elevation view, or create a section if 
you prefer not to draw in axonometric view. 

25. On the Options Bar, set the depth of the 
void extrusion to 50’. 

 In this case the depth refers to the horizontal 
plane, as you are drawing on a vertical plane. 

26. Click Finish Sketch. 

 

 



27. Drag the shape handle of the void until it 
snaps to parallel geometry to make the void 
cut completely through the solid. 

 

The void appears as an orange shape. 

 
You do not need to be exact with the void. Once 
you are done with mass sketch mode, the void 
disappears. 

28. Click Finish Mass to complete the mass.   

Create a Gross Floor Area 
Schedule 

Revit Building provides the ability to get information from 
the rough mass model, enabling you to dynamically see 
changes in either the graphical form of the mass, or in the 
tabular form of a schedule. 

For the schedule to work, the floor areas must first 
be assigned to the mass object. 

29. Select the southwest massing (the one you 
have been working with). 

30. On the Options Bar, click the Floor Area 
Faces button. 

 

 



31. Select the check boxes for all the levels. 

 

Each level that intersects the massing is a 
candidate for a floor area face. These faces enable
you to place floors and do quantity takeoffs from 
the massing object. 
 
Planes are drawn at each level.  

 

32. From the View menu, choose the 
Schedule/Quantities tool.  

33. Select the Mass category. 

34. Click OK. 

 

 



35. Add Fields: 

a. Family and Type 
b. Gross Floor Area 
c. Gross Volume 
d. Description  

36. Click OK. 

 

37. Add a description to Building 3—Office 
Building. 

 

A gross building volume and floor area schedule 
can be generated and placed in a sheet. 
Only the building for which you created the floor 
areas shows a value in the Gross Floor Area 
column of the schedule. 

Add the Physical Floor Component The floor areas created previously are simple vertical 
divisions of the mass that have no thickness. Use the Floor 
by Face tool to add floors into the mass. 

You cannot use the Floor by Face tool until you 
have created the floor faces. 

38. Isolate the southwest building.  

a. Open the 3D view. 
b. While pressing the Ctrl key, click each of 

the three building masses without floor 
assignments. 

c. From the drawing window’s View toolbar, 
click Hide Object. 

 

Use Hide Object/Isolate Object to work on one 
object in the project. 

 



39.  Use the View menu to orient the view to the 
southwest.  

 

   

40. Change the height of the lower wing to just 
under one of the floor area faces. 

 

  

41. Add floors to the building.    

42. On the massing tab of the Design Bar, click 
Floor by Face. 

 

 This tool places floors.  

43. On the Options Bar: 
 

  



a. Set floor type to LW Concrete on Metal 
Deck. 

b. Verify that Select Multiple is selected. 
 

44. Drag a selection window around the whole 
building. 

 

   

45. On the Options Bar, click the Create Floors 
button.  

The floors are automatically generated.  

Create Walls The Wall by Face tool enables you to create walls that are 
associated with the massing. 

 

46. Click the Walls by Face tool from the 
massing tab of the Design Bar. 

47. On the Options Bar, set: 

a. Wall Type = Exterior Brick on Mtl. Stud 
b. Draw Type = Pick Face (House Icon) 
c. Height = Automatic 
d. Loc Line = Core Face Exterior 

 

   

       

  



48. Click the walls shown at right. 

 

Spin the model to select these faces. Hold down 
the scroll wheel and move the cursor to spin the 
model. 

 

49. Click the Show Mass tool. 

 

This tool enables you to move back and forth 
between seeing the massing and the floors and 
walls or just the floors and walls. 

 

50. Click the Show Mass tool to show the mass 
again. 

    

51. Adjust the building.    

52. Click the Modify tool. 

53. Select the mass. 

54. Use the triangular face grips to modify the 
lower wing: 

a. Top face down one level.  
b. South face half the distance to the street. 
c. See illustrations at right. 

 

If stray portions of the mass show up as you grip 
the mass faces, use the Edit button to access 
sketch mode and adjust the void extrusion to clean 
up. 

 

55. Click any white area to deselect the 
building. 

 The building elements are now out of sync with the 
mass model. 

 



56. Resynchronize the building elements to the 
new mass form. 

   

57. Select the floor exposed by dropping the top 
face. 

58. On the Options Bar, click the Remake 
button. 

59. Repeat, selecting the south wall of the lower 
wing. 

60. Repeat for the lower three floors. 
 

   

Add a Curtain Wall System The Curtain System by Face tool allows you to create 
curtain walls that are associated with the massing. 

 

61. On the Massing tab of the Design Bar, click 
the Curtain System by Face tool. 

62. Select the remaining exterior faces. 

63. From the Options Bar, click the Create 
System tool. 

  

Adjust Curtain Wall System 
Spacing 

  



64. In the Project Browser, expand 
Families>Curtain Systems>Curtain System.

65. Right-click the 5’ x 10’ type, and choose 
Properties. 

 

 

66. In the Type Parameters, set the Layout 
(Grid 1) (vertical spacing of the horizontal 
grid) to Fixed Distance and 5’  for the 
spacing. 

67. Set the Layout (Grid 2) to Fixed Distance 
and 6’. 

68. Click the Rename Button and enter 5’ x 6’ 
for the name. 

69. Click OK. 

 

Because you are editing the type, the changes you 
make apply to all curtain systems in the project. 

Add Mullions to the Curtain System   

70. From the Modeling tab of the Design Bar, 
click the Mullion tool, and on the Options 
Bar select All Empty Segments.  

 

71. Click a curtain system face of the model.   



72. Repeat for the remaining curtain system 
faces. 

  

Add a Roof   

73. In the Massing tab of the Design Bar, click 
the Roof by Face tool. 

74. On the Options Bar: 

a. Roof type = Steel Truss – Insulation on 
Metal Deck – EPDM 

b. Level = 9 

75. Select the top face. 

76. On the Options Bar, click the Create Roof 
tool. 

77. Repeat, adding a roof at level 3 for the lower 
wing. 

 

The process of adding a roof is the same as that 
for adding the walls or floors. 

78. On the drawing window View toolbar, click 
the Isolate tool and select Reset Temporary 
Hide Isolate. 

  

Note that if you come back to this project later, you 
may have to click the Show Mass tool to see the 
mass elements. Show Mass is not turned on by 
default in a new session. 

 

Unit 9, Exercise B: Importing SketchUp Files 
In this exercise you import a SketchUp file directly into the project as well as import a SketchUp file into a mass family as it is created. 
 
 

Exercise Setup   

1. Open file: Unit 9b – Start.rvt.   



2. Set the view 3D Views: North East Iso 
current. 

3. Click the Show Mass tool on the toolbar. 

 

 

Import a SketchUp Model   

4. From the File menu, choose Import 
Link>CAD Formats. 

 

 

5. In the Import/Link dialog box, set: 

a. Files of type = SketchUp 
b. File to Import = Unit 9b – NW building.SKP 
c. Select Link Instead of Import 
d. Preserve Colors 
e. Automatically place Origin to origin 

 

 



6. Click Open. 

 

The SketchUp model is read into the Revit Building 
project.  

Import a SketchUp Model into  
an In-Place Mass Family 

While the SketchUp model is displayed in the Revit 
Building project, it acts as a solid block. For more 
flexibility with the SketchUp model, you can import it into 
an in-place mass or a Revit mass family (RFA). 

Once the SketchUp file has been nested inside a 
mass, you can use the Building Maker features as 
explained in Unit 9, Exercise A. 

7. Click the Create Mass tool to start the In-
Place Mass routine. 

 

 

8. Name the new mass Building 5.   

9. Repeat the steps in the first part of this 
exercise to import a SketchUp model. Import 
the SketchUp file: Unit 9b – NE building.skp.

 

10. On the Design Bar, click the Finish Mass 
button.  

  



11. Apply walls, floors, and roof of your 
choosing. 

 

If you need assistance with this review, see the 
previous exercise for step-by-step instructions on 
applying walls, floors, and roof to faces of the mass 
(Building Maker functions). 

Turn off the SketchUp Model Like any other imported file, you have control over the 
visibility of the graphics of the linked file 

 

12. Type VV to access the views graphic 
overrides. 

  

13. Clear the Imports in Families.  

 

 

 



Unit 10 
Theory: Component Design 

Autodesk Revit Building: Family Editor 
This workbook unit is to be used with lecture units 10 and 11. Unit 10 builds a shelf unit as a furniture family using solids. This shelf is the basis for the multiple 
exercises in Unit 11. This exercise is long, so give yourself enough time to finish it, or save it in a location that you can access later. 
 
This exercise uses dimensions and align tools extensively. You should be familiar with these tools before you start this exercise. 
  

Creating a Component Family 
 

1. In this unit you create a furniture family, as 
shown in the image. 

 

 

2. From File menu, choose New>Family. 

3. In the dialog box, open the template called 
Furniture.rft. 

 

 

The Family Editor opens: note that the work 
environment is similar to project mode. The 
Design Bar provides just one Family Bar. The 
usual bars are not available (Site, Modeling, 
Structural, and so forth) because they are not 
used for family creation. The Project Browser 
does not differ much: there are plan views, 
elevations (which are named differently), and 
3D views. In the menus, some tools are not 
accessible (dimmed). 



4. From the File menu, choose Save As.  

5. Browse to the data set folder that contains 
the workbook exercise files. 

6. Open the rfa folder in this location. 

7. Save this file as Shelf Unit. 

 Note: The completed rfa files for Units 10 and 
11 are in the Completed rfa folder.  
 
The other shelf units in this folder are starting 
points for Unit 11 exercises. 

Create Overall Reference Planes When you are working with families, you are creating 
reference planes. These reference planes are assigned 
the parameters that drive the geometry. 

 

8. In the Project Browser, open Floor 
Plans>Ref Level. 

9. Right-click the horizontal reference plane 
and choose Properties. 

  

In this view there are two reference planes. The 
intersection of these two planes represents the 
insertion point of the family. In this case, this 
point is the rear (back) and the middle of the 
piece of furniture. Begin by changing the name 
of this reference plane. 

10. In the Properties dialog box, change the 
name to Back and verify that Is Reference: 
Back is selected. Click OK to exit. 

 
 

Reference planes are important in the creation 
of families. It is on these lines that you base the 
parameters of your family; they are references 
for the geometry. Adding reference planes is 
easy. Simply specify a starting point and a final 
point (just like drawing a line). The length of the 
line symbol is not important. If necessary, you 
can resize it using the grips that appear at its 
ends when it is selected. 

11. Click the Reference Plane button on the 
Design Bar and add three planes, as shown 
in image (don’t worry about the distances 
between each plane). 

 

You must be able to vary the width and depth of 
your piece of furniture, so you add two new 
parameters to your family. To create a 
parameter you must add a dimension and 
assign it a label. The depth of the furniture 
family corresponds to the distance between the 
two horizontal reference planes; the width 
corresponds to the distance between the two 
vertical reference planes (right and left). 



12. Click the Dimension button on the Design 
Bar, and add a dimension line between the 
two horizontal reference planes. 

 

 

13. Click the Modify button on the Design Bar, 
and select the dimension. On the Options 
Bar, open the Label list and click Add 
Parameter. 

 

You can also right-click the dimension line and 
choose Edit Label from the context-sensitive 
menu. 
 

14. In the Properties dialog box for the 
parameter, enter Depth as the name. The 
options suggested by default are that this is 
a Type parameter.  

15. Set the Group Parameter Under option to 
Dimensions. 

16. Click OK. 

 

 



17. Click the Dimension button on the Design 
Bar and add a dimension between the three 
vertical reference planes (click each line 
and position the dimension line with a left 
mouse-click). 

18. Click the EQ symbol that appears. 

 

 
 

The vertical reference plane between the two 
other planes is the axis of the furniture. Thus, it 
must be equidistant between the planes on the 
right and left. To achieve this and keep it as a 
constant during the design, you need to add a 
dimension between the three reference planes 
and to activate the equality constraint (EQ 
symbol). 

19. Repeat the earlier steps to add the width 
parameter. 

a. Add a dimension. 
b. Click the dimension, and click Add Label 

on the Options Bar. 
c. Set the label as follows:  

• Name = Width  
• Group Parameter Under = 

Dimensions 
• Type parameter 

 

 

 

20. Click the Family Types button on the 
Design Bar, change the Depth and Width 
values, and then click Apply. 

21. Click OK. 

 

During family design, it is important to test the 
parameters to check that all is working properly. 
You have just added two parameters in your 
family. You can test them by changing some of 
their values. During this test, reposition the 
reference planes. You should not receive any 
error message. 
 
This process is referred to as flexing the family 
parameters. 



 

22. In the Project Browser, click Front View. 

23. Add a horizontal reference plane, add a 
dimension between the reference plane on 
the ground and the one you have just 
added, and transform this dimension into a 
parameter named Height (also a type 
parameter in the Dimension group). 

24. Flex the family by changing parameter 
values in the Family Types dialog box. 

25. Save your project. 

 
 

Remember to save your work regularly. You 
can decide to create a new tree structure of 
files under the main Library folder. It’s a good 
idea to keep your personal libraries separated 
from the installed library. 

Create the Side Supports Now that the reference planes are in place, you create the 
side supports with the Solid Extrusion tool. 

 

26. Activate the view Ref. Level. 

27. On the Design Bar, click the Solid tool, and 
choose Solid Extrusion.  

 

Sketch mode is used for creating forms: the 
Design Bar displays the tools available to 
create the sketch, which must be a closed loop. 

28. On the Design Bar, click the Lines button, 
and on the Options Bar, click Rectangle. 
Trace two rectangles, as in the image (the 
size is not important). 

 
 

 



29. Use the Align tool to lock the left sketch line 
to the left reference plane, as in the image. 

a. Click Align tool. 
b. Click left reference plane. 
c. Click left line of the left rectangle sketch 

line. 
d. Lock this alignment by closing the small 

lock that appears (click the symbol). 

30. Repeat the process for the right rectangle, 
locking the right edge to the right plane. 

 

 

31. Use the Align tool to lock the top sketch 
lines to the upper reference plane, as in the 
image. 

a. Click Align tool. 
b. Click upper reference plane. 
c. Click top line of the left rectangle sketch 

line. 
d. Lock this alignment by clicking the lock 

symbol. 

32. Repeat the process for the right rectangle’s 
top sketch line. 

 

 
 

 

33. Repeat this process for the bottom sketch 
lines, locking them to the lower reference 
plane. 

 

 

 

 

The sketch lines shown here should now be 
aligned/locked with their respective reference 
planes. 



34. On the Design Bar, click Dimension. 

35. Click the left reference plane, then the right 
line (which is not locked), and then position 
the dimension. 

 

 

When you dimension a sketch like this, you 
want to run the dimension to the reference 
plane rather than the sketch line. This allows 
the sketch to flex as you use the dimensioned 
label parameters to drive the geometry. 

36. Click the Modify tool. 

37. Select the sketch line on the right side of 
the rectangle you just dimensioned. 

38. Click the dimension text and change the 
value to 1”. 

39. Lock the dimension by clicking the lock 
symbol.  

40. Repeat the process for the sketch on the 
right side. 

41. Click Finish Sketch. 

 

 

42. In the Project Browser, select Front view. 

43. Select the 3D geometry. Blue grips that can 
be used for dragging the faces appear. 

44. Drag the grip that allows changing of the 
height of the solid element until you reach 
the top reference plane. 

45. Click the lock symbol to lock the alignment. 

 

 
 

You can also use the Align tool to accomplish 
this task. 
 
Because you drew two rectangles in sketch 
mode, you have only one vertical grip that 
controls the height of both side frames. 



46. The vertical sides are finished. Test your 
work by varying the parameters of the 
family (width, height, depth) in the Family 
Types window (flexing the model). The 3D 
geometry must update consequently and no 
error message should appear. To see the 
effect of the parameters well, open a 3D 
view. 

 

 

Add the Shelves Again, like the side supports, draw the reference planes 
and then the solid extrusions. 

 

47. Create the reference planes for the shelves.   

48. Open view Ref. Level in the Project 
Browser. 

49. Add a horizontal reference plane just above 
the one that defines the depth of the 
furniture family. 

 

 

50. Add a new dimension line between the 
bottom reference plane and the one you 
just created. 

51. Select the reference plane and change the 
dimension text to 1”. 

52. Lock the dimension. 

 

 

 



53. Open the front view. 

54. Add two horizontal reference planes, as 
shown in image. 

 
 

 

55. Dimension and lock the upper two 
reference planes to 2”. 

56. Dimension and lock the lower two reference 
planes to 3”. 

 

 



57. Add four more reference planes, as shown 
in image. 

 

 

58. Click Dimension, and then click the four 
reference planes as well as the two created 
in the previous step. 

59. Click the EQ symbol. 

60. Flex the model by changing parameter 
values. 

61. Save the file. 

 
 

A few words to explain these reference planes: 
two of them cannot move. They are constrained 
by locked dimensions (50 and 34). The other 
four are spaced regularly because of the 
dimension line that constrains the distance 
between them. Thus, if the height of a piece of 
furniture is modified, the top and bottom parts 
are fixed, whereas the distance between the 
four other planes is adjusted to satisfy the 
equality constraint. 



Add a Base Trim   

62. Open view Ref. Level. 

63. On the Design Bar, click Solid Form>Solid 
Extrusion.  

64. On the Design Bar, click Lines, and then 
click the rectangle template on the Options 
Bar. 

65. Draw a rectangle, as shown in image. The 
size is not important. 

  

 

66. Click the Align button on the toolbar. 

67. Click the internal face of the upright, and 
then click the nearest line of the rectangle. 

68. Lock this alignment by clicking the lock 
symbol to close it. 

 

69. Repeat the process on the right side. Don’t 
forget to lock the alignment. 

 

 
 

 



70. With the Align tool, click the horizontal 
reference plane on the bottom and then 
click the nearest horizontal line of the 
sketch. 

71. Lock this alignment by clicking the lock 
symbol to close it. 

 
 

72. Add a dimension between the reference 
plane immediately above the one that 
defines the depth, and then click the line 
that you did not lock. 

73. Select the line, and in the dimension text 
change the value to 1 ½”.  

74. Select the dimension and lock it. 

75. Click Finish Sketch. 

 

 

76. Open the front view. 

77. Click Align. 

78. Click the reference plane that is directly 
below the top of the solid you just created, 
and then click the top of the solid. Lock the 
alignment by clicking the lock symbol. 

 

 



79. Flex the model. 

80. Save the family. 

 

 

Add Shelves   

81. Open Ref Level. 

82. Right-click the lowest horizontal reference 
plane, and choose Properties. 

83. Rename the reference plane to Front. 

 

 

84. Open the front view. 

85. On the Design Bar, click Solid Form>Solid 
Extrusion.  

86. On the Design Bar, click the Set Work 
Plane tool. 

87. Set the work plane by Name to Back. 

88. Click OK. 
 

 

89. On the Design Bar, click Extrusion 
Properties. 

90. Set the Extrusion end to 6”. 
 

You could set this to 12” here, but you will align 
and lock this front edge to a reference plane 
when you are finished with this sketch. 



91. Use the Line’s rectangle tool to draw six 
rectangles, as shown in image. The size is 
not important. 

92. Click the Align tool, and on the Options Bar 
select Multiple Alignment. 

 

 

93. Click the interior face of the left upright and 
then click the left vertical lines of the 
rectangles (one at a time).  

94. Lock each alignment (you must lock each 
line individually after aligning it). 

 

95. Repeat the process for the lines on the right 
side. Remember to lock the alignments. 

 

These alignments allow the horizontal racks to 
remain in contact with the vertical uprights if the 
furniture family’s width is resized. You should 
now force the horizontal lines of the rectangles; 
the lines of the bottom of the rectangles must 
be respectively aligned with the reference 
planes that are subjected to the equality 
constraint.  
 
Then you need to place a dimension between 
each reference plane and the top line of the 
rectangles: one adjusts dimension and one 
locks the dimension. Thus, if the height of the 
furniture changes, the racks cannot vary in 
thickness. Thanks to the equality constraint, 
they reposition themselves correctly to divide 
the obtained space. 



96. Click the Align tool, and on the Options Bar, 
clear the Multiple Alignment option. 

97. Click the reference plane right above 
ground level and then on the bottom 
horizontal line of the lowest rectangle. Lock 
the alignment. 

 

98. Repeat the alignment process with the 
horizontal reference planes and the bottom 
lines of the rectangles, as shown in image. 

 

 



99. Add a dimension line between the 
reference plane and the top line of the 
rectangle located on the bottom, as shown 
in image. 

100. Select the line and change the dimension 
text to 1”. 

101. Lock the dimension. 

102. Repeat the process for all horizontal lines 
(located on the top of the rectangles). 
Remember to lock the dimensions. 

103. Click Finish Sketch. 

 

 

104. Save the family. 

105. Open Ref. Level. 

 

 

106. Drag the lower blue grip to the horizontal 
reference plane, as shown in image. Click 
the lock symbol to lock it. If the lock symbol 
does not appear, use the Align tool.  

 

 



107. Flex the model. 

108. Save the family. 

 

 

Add Vertical Supports   

109. Open front view in the Project Browser. 

110. Add two vertical reference planes, as 
shown in image. 

 

 
  



111. Add a dimension line between the two 
reference planes you just added and the 
external ones, as shown in image. 

112. Click the EQ symbol. 

 

 

113. On the Design Bar, click Solid Form>Solid 
Extrusion.  

114. On the Design Bar, click Lines, and then 
click the rectangle template on the Options 
Bar.  

115. Draw six rectangles, as shown in image. 
The size is not important. 

 

 



116. Click Align on the toolbar. On the Options 
Bar, select Multiple Alignments. 

117. Click the left reference plane (see image) 
and align the three rectangle lines, as 
shown in image. 

118. Lock each alignment as you make it. 

 
 

119. Repeat the process with the remaining 
rectangles and the right reference plane. 

 
 

All these alignments are locked to maintain this 
constraint when you change the value of the 
furniture family’s width parameter. 

120. Click Align. On the Options Bar, clear the 
Multiple Alignment option. 

121. Align the bottom line of the bottom 
rectangles, as shown in image.  

122. Lock the alignment. 
 



123. Repeat the process with the top lines (see 
image). 

 
 

124. Repeat the process for all the rectangles. 

 

It is now necessary to manage the thickness of 
vertical separations. You operate in a way 
identical to the preceding stages, namely, a 
dimension locked between the reference plane 
and the unconstrained line of the rectangle. But 
before that you align the sides of the rectangles 
between them (on the left and right). 

125. Click Align on the toolbar. On the Options 
Bar, select Multiple Alignment. 

126. Click the right vertical line of the bottom left 
rectangle and then click the right vertical 
lines of the rectangles on top of it (see 
image). 

127. Lock each alignment as you make it. 

 



 

128. Repeat the process for the rectangles on 
the right side. 

 



129. Place a dimension line between the vertical 
lines of the bottom left rectangle (see 
image). 

130. Select the line, and in the dimension text 
change the value to 1”. 

131. Select the dimension and lock it. 

 

Because the right sides of this set of rectangles 
are locked together, you need to place only one 
dimension to control all rectangles in that set. 

132. Repeat the process for the right rectangle. 

133. Click Finish Sketch. 

  

134. Open Ref. Level view. 

135. If the vertical supports are too narrow, 
select the 3D geometry and use the blue 
grips to align the bottom face, as shown in 
image. 

136. Lock the alignment. 
 

137. Flex the model. 

138. Save the family. 

 



139. Start a new project to insert this family. 

140. From the File menu, choose Load from 
Library>Load Family.  

141. Navigate to where you saved the family and 
open it. 

142. On the Design Bar (Basic), click the 
Component button. You can now place your 
family.  

To test your new family in a project, you load it 
in a project. You can then insert it from the 
Component tool. Do not forget that your family 
is parametric! To find the Width, Height, and 
Depth parameters, open the Type properties of 
the family. 



Unit 11 
Theory: Propagation of Constraints 

Autodesk Revit Building: Alignment, Locking, and Constraints 
 
This unit is to be used with Lecture Units 10 and 11. Unit 11 builds on the family created in Unit 10. This unit has several exercises designed to illustrate various 
capabilities of the family within Autodesk Revit Building.  
 
• Exercise A: Add the symbolic line representation to create the coarse, medium, and fine detail views. In addition, this exercise works with in-place family editing 

from the project environment. 
• Exercise B: Add a material parameter to control the materials assigned to shelf unit. 
• Exercise C: Add a glass door and assign a visibility parameter to control the display of the glass element. 
• Exercise D: Work with nested families to add a drawer unit to the family, using the parent shelf parameters to drive the geometry of the nested family. 
• Exercise E: Fine-tune the family, adding control of family elements through the use of subcategories. 
  
In this unit you complete the furniture family created in the previous unit by adding components to it. See image. 
 
The family that you created in the first part of the exercise requires more work so you can use it properly. You need to generate its 
2D representation, associate all necessary materials, and define the levels of detail. Later in the exercise, you can experiment with 
nested families and formulas—an enormously powerful part of the Family Editor.  
  



Exercise 11a: In-Place Family Editing and Symbolic Line Representation 
In Unit 10 you worked with the Family Editor. In-place family editing provides access to the family definition directly from the project environment. 

Symbolic Lines and View Detail Level 
When you create a family, you need to define how that family behaves in different views (plan, section, elevation, 3D). The first important decision is its 2D 
representations: will the display of the family in plan view simply result from a cut 3D view, or should it be represented with a simple 2D sketch? In this case, it is 
not generated from the 3D model but is represented with a 2D sketch that you create. After you have defined the way your family (object) is displayed in different 
views, you need to define its representation in different scales (coarse, medium, fine) for all views. So, this is our objective: 
 

 Coarse Medium Fine 

Plan View 

   

Section, 
Elevation, 3D 
view 

Display representation is generated from the 3D model 

 
You need to add two new sketch drawings to your family—one for its Coarse-Medium representation and one for the Fine representation. You use the symbolic 
lines for these sketches. You set the visibility of the objects in the family such that only the sketch lines display in the project and not the 3D elements of the shelf.  

Open a Project and Load the Shelf  
 

1. Open Unit 11a – Start.rvt. 

2. Verify that the file opens to the view Floor 
Plans: Level 2. 

3. From the File menu, choose Load from 
Library>Load Family to launch the Browse 
dialog box. 

4. Browse to the Workbook Data Set folder, and 
open the rfa folder within it. 

5. Select the Shelf Unit 11a.rfa. 

6. Click Open.  

 



Place an Instance of the Shelf and 
Create a Cropped 3D View to Make It 
Visible 

 

 

7. Click Component tool on the Basic menu. The 
type should be set to Shelf Unit 11a. By 
default, the last loaded component is set when 
you use the Component tool. 

 

 

8. Place an instance on the north wall of the 
master bedroom. 

 

 

9. Set the 3D view current. 

10. Press the F8 key to bring up the Dynamic View 
dialog box. 

11. Click the disk icon in the Dynamic View dialog 
box. 

12. Enter 2nd Floor 3D for the name. 

13. Click OK.  

This creates a new view in the Project Browser 
under 3D views. 

14. Right-click in the drawing window, and choose 
View Properties.  

15. In the view properties, select Section Box.  

 

 



16. Select the section box that appears in the 
drawing window. 

 

 

17. Use the face grips to cut away the roof, south 
walls, and east walls. 

 

 

18. Select the shelf unit. 

19. On the Options Bar, click Edit Family. 

  

 

20. Click Yes to open the family for editing. 

 

 

Set up Duplicate Views of the 
Reference Level Plan 

To facilitate the creation of the 2D sketch, you are going to 
duplicate this view. Revit Building lets you associate 
different levels of detail to different views: one for Fine and 
another for Coarse-Medium. 

You make only one for both Coarse and 
Medium because the 2D geometry for these two 
representations is the same. 



21. In the Project Browser, under Floor Plans, 
activate the view Ref. Level. 

22. Right-click Ref. Level, and choose Duplicate. 

23. Right-click the newly created Copy of Ref. 
Level, choose Rename, and change the name 
to Ref. Level (Coarse - Medium). Click OK.  

24. Repeat the operation and create a new 
duplicate named Ref. Level (Fine). When you 
click OK, Revit Building asks if you want to 
rename the corresponding view and level. 
Confirm with OK. 

   
 

 
 

25. Set Ref. Level (Fine) current. 

26. Use the Drawing window view toolbar to set 
the Detail Level to Fine. Using the same 
method, assure that Ref. Level (Coarse - 
Medium) has Coarse set as detail level in its 
properties.  

 

27. Make sure that Ref. Level (Coarse - Medium) 
is the active view (if not, double-click it).  

 



28. On the Design Bar, click Symbolic Lines.  

29. On the Options Bar: 

a. Click the Arrow button (Select). 
b. Select the Lock item. 

30. Select the lines by clicking them, as shown in 
the image. 

 

A check in the Lock box means that the 
selected lines automatically lock to the 
geometry from which they have been 
generated.  
 
You need to trim the symbolic lines you have 
just created. But because there is a lot of 
overlapping geometry, this can be a tedious 
task. To simplify it, Autodesk Revit Building 
offers a temporary Hide/Isolate option to hide all 
3D geometry, as well as the reference plane. 
You then have a pure 2D sketch drawing on 
which it is much easier to work. 
 

31. Click the Modify tool, and select the vertical 
separations as shown. 

 

 

32. From the drawing window view toolbar, select 
the Hide/Isolate icon. 

 

 

33. Choose Hide Category from the context-
sensitive menu. 

 

 



34. Select a reference plane and again choose 
Hide Category. 

 

Note the lower-right corner does not return. 

35. On the Tools toolbar, click Trim. Verify that the 
Options Bar mode is set to Trim/Extend to 
Corner. 

36. Trim the lines to close the rectangle. 

 

 

 

 
 

You have just finished defining the 2D sketch for 
the Coarse – Medium level of detail. What 
remains is to tell Revit Building which lines 
should not be associated to the Fine level of 
detail. 
 

37. On the Design Bar, click Modify, and then 
select the line that represents the front of the 
furniture. 

38. On the Options Bar, click the Visibility button. 

39. Clear Fine in the Family Element Visibility 
Settings dialog box. Thus the selected line is 
invisible in views set to this level of detail. 

40. Click OK to confirm. 

 



41. Activate the Ref. Level (Fine).  

42. Right-click in the drawing window and choose 
Zoom Fit. 

43. Use the same methods to:  

44. Hide the Reference Plane category. 

45. Use Symbolic Lines – Pick Lines – Lock. 

46. Hide the solid geometry category. 

47. Clean up the symbolic lines as shown. 

 

Remember to use the Symbolic Lines Pick tool 
with the lock so the symbolic lines are related to 
the solid geometry. The solid geometry is driven 
by the family type parameters. If you just hide 
everything and draw the lines, they do not flex 
with the model. 

48. Set the visibility of the newly created lines to 
Fine. 

49. Click OK. 

 

 

 

Flex the Family 
 

 

50. Tile the screen so you have both views next to 
each other. 

51. Try modifying the Width or Depth parameter. 
Note that the 2D geometry follows the change 
and updates. 

 

 

Use Window>Close Hidden Windows before 
you use Window>Tile. This keeps all the open 
windows (which is often quite a few) from 
cluttering up the view. Leave the project that 
you started open for the next step.  



52. Activate the 3D view, and select the entire 
geometry. 

53. On the Options Bar, click the Visibility button 
and clear the Plan/RCP check box. 

54. Click OK. 

 
 

 

In Plan/RCP views you are going to use the 2D 
geometry you just created as representations. 
For all other ways, the representation is 
generated from the 3D model and in all levels of 
detail. 

Reload the Family into the Project At this point you can either load the family back into the 
project or save the family out and overwrite the original 
.rfa file. Or use Save As and create a new family based on 
these modifications. 

 

55. On the Design Bar, click Load into Projects. 

 

This loads the family into any projects you have 
open. If you have more than one project open, 
you are prompted select a family. 

 

56. Click Yes to overwrite the existing version. 

 

At this point your work has been transferred into 
the current project. You do not need to save the 
family you are working on, but you do need to 
save the project file. 



57. Use the Window menu to change back to the 
shelf project. 

 

 

58. From the File menu, choose Close to close the 
family file. 

59. Do not save changes. They are already 
transferred to the project. 

 

 

60. Save the project. 
 

 

 
 
 
 

Unit 11, Exercise B: Material Parameters 
In this exercise you add materials to the shelf.  
 
Although you could assign material directly to the solid extrusions as part of their properties, this definition would be static, lacking the ability to control the 
materials in the project. Autodesk Revit Building provides a parameter type that enables you to apply materials once the object is in a project. This can be either a 
type or an instance parameter. 
 



1. Open …\ Data \ rfa \ Unit 11b Shelf - Start.rfa. 

 

 

 

2. On the Design Bar, click the Family Types. 

 

 

3. Under Parameters, click Add. 

4. In the Parameter Properties dialog box, set the 
following: 

• Name = Finish 

• Type = Material 

• Group Parameter Under = Materials and 
Finishes 

• Type button 

5. Click OK. 
 

For the moment, your family is fully parametric 
in respect to its dimensions, but you will add a 
new type of a parameter that allows the user to 
parametrically change the material associated 
with the furniture as well. For now, you create 
just one material parameter to apply to the 
entire 3D geometry. 



 

 

 

The Finish parameter is now part of the family 
definition. At this point it is not assigned to any 
particular element. 
If you did not make the Finish parameter, then 
you would not have access to this control once 
the family was in a project. Only those 
parameters appearing in the Family Types 
dialog box are open for editing in a project. 
You need to assign this parameter to the solid 
extrusions.  

Assign the Material to the Solid 
Extrusions of the Shelf  

 

6. Select all 3D geometry, and click Properties. 

 



 
The material parameter is a hard-coded property of a solid extrusion. You need to assign the Finish 
parameters you just created to this property. 

7. In the Element properties, click the small 
button to the right of Material. 

 

8. In the Associate Family Parameters dialog 
box, click the Finish parameter. 

9. Click OK in all open dialog boxes. 

 

 

If you want, you could create a new material 
within the Family Editor and associate it as 
default material of the family. All materials 
created in the family are going to be 
automatically created in every project where this 
family is loaded. If an existing material has the 
same name, the family material is overwritten. 
That is why it is advisable to give your materials 
specific names. 

10. From the File menu, choose Save. 

11. Close the family. 
 

 



12. Start a new project and load your family. Insert 
a few instances of this family in the project and 
try changing the parameters. Note that all 
modifications are propagated in all instances of 
this family. This is because you have defined 
all family parameters as Type parameters. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Unit 11, Exercise C: Visibility Parameters 
In this exercise you add glass doors to the shelf unit. You have now worked with two types of parameters.  
 

Parameter Type Name Assigned to Controls 

Length Width, Depth, Height Dimension Geometry 

Material Finish Solid extrusion properties Material assigned to the solid 
 
In this exercise you create two glass doors for the shelf unit. You create a new parameter in the family that is a Yes/No parameter type. Yes/No parameters have 
several uses. In this exercise you assign the Yes/No parameter to the visibility of the glass doors. This enables you to turn them off in a project if you do not want 
to see them. They are still defined in the family but are not visible. 
 
This exercise continues from the last exercise. If you worked through Exercise 11 B, and were successful in both applying materials and manipulating the 
dimensions parameters, you can continue working on your family in this exercise. 
 
In this exercise you add and constrain new references as well as create solid extrusions and voids. Go back to Unit 10 if you need to review these tasks. 
 

1. Open …\ Data \ rfa \ Unit 11c Shelf - 
Start.rfa. 

2. Activate the front view. 

3. Add the reference planes and dimensions 
shown in the image. 

 

Families recognize logical conditions like Yes/No. 
You use that to control the visibility of the glass 
doors within the shelf unit. The next task is to 
create the geometry of the glass doors. 
 



4. Activate the view Ref. Level (Fine). 

5. If the view shows a red background to the 
Hide/Isolate tool, click the Hide/Isolate button 
and click Reset Temporary Hide/Isolate. 

6. Click Reset to see everything. 

 
 

 

To facilitate the creation of the glass doors, name 
one of the reference planes. The effect is to create 
a work plane on which you can trace your sketch 
of the doors. Just imagine you are inserting a 
sheet of paper on which you are simply drawing a 
sketch. 
 

7. Activate the Ref. Level. 

8. Select the horizontal reference plane that is 
second from the bottom, and click the 
Properties button on the Options Bar. 

9. In the Properties dialog box, change the 
name to Glass, and click OK. 

  

  
 

 



10. Activate the front view. 

11. On the Design Bar, click Solid>Solid 
Extrusion. 

12. On the Design Bar, click Set Work Plane.  

13. In the Work Plane dialog box, select Glass 
from the Name list. 

14. Click OK. 

 
 

 

15. On Design Bar, click Lines. 

16. On the Options Bar, click Select and select 
the Lock check box. 

17. Click the lines that form the first shelf, as 
shown. 

 

 

For a sketch to be valid for an extrusion, it should 
not have T intersections and its lines must be in a 
closed loop. Since this is not the case for your 
sketch, you need to fix it. 

18. On the Tools toolbar, click the Split tool. 

19. On the Options Bar, select Delete Inner 
Segment and select the two middle vertical 
lines as well as the bottom one.  



 

20. Repeat for the line above. 

 

21. Click Trim. 

22. Set the trim mode to Trim/Extend to Corner. 

 

23. Repeat for the other side. 

 

 

24. On the Design Bar, click Extrusion 
Properties. 

25. Set 1/2” for the Extrusion End. 

26. Click the Edit button next to Visibility. 

 

 

The value positive or negative when drawing an 
extrusion from a reference plane depends on the 
direction you first drew the reference plane (right to 
left or left to right).  
 
If you get it wrong here, you can always change it 
after you are finished with the sketch, by looking at 
the extrusion properties. 



27. Clear the Plan/RCP check box, as well as 
Front/Back (this means that these doors are 
not displayed in the plan or elevation view). 

28. Click OK to return to the Element Properties 
dialog box. 

 

 
 

 

29. Click the button next to Material and select 
Glass. 

30. Click OK to return to the Element Properties 
dialog box. 

31. Click OK again to close the Element 
Properties dialog box. 

32. On the Design Bar, click Finish Sketch.  

33. Save the file (File>Save). 

 

 
 

When you assign a material in this way, the 
material is static. You cannot assign a different 
material to the element placed in a project. 

Create Pulls for the Glass Doors 
 

 



34. Select the Solid Form>Solid Extrusion.  

35. On the Design Bar, click Set Work Plane. In 
the dialog box make sure that the active 
work plane is set to Glass.  

36. Select Lines and click the circular shape on 
the Options Bar. Activate the Radius and set 
it to 1/2”. 

37. Add two circles, as shown on the right. Note 
that the center of insertion is the intersection 
point of the reference planes. 

 

38. On the Design Bar, click Extrusion 
Properties and set 0 1” as an extrusion end. 

39. Click the Edit button next to Visibility and 
clear Plan/RCP. Under Detail Levels, select 
only Fine. (This means that knobs are visible 
only in a Fine level of detail.) 

40. Click OK to close all open dialog boxes. 

 

 

 

41. On the Design Bar, click Finish Sketch. Thus 
you are exiting sketch mode, and you have 
finished creating the 3D object. 

  

 



42. Set current Floor Plans: Ref Level. 

43. Select pulls. 

44. Set Depth = -0 1” (negative). 

   

       

The pull switches to the other side of the reference 
plane. 

45. From the File menu, choose Save (make it a 
habit to save your work often). 

46. Flex your family to test it. 

 

47. On the Design Bar, click Family Types. 

48. In the dialog box, under Parameters, click 
Add. 

49. In the Parameter Properties dialog box, set 
the following: 

a. Under Name, enter Glass Door. 
b. Group Parameter Under: Construction. 
c. Under Type, select Yes/No. 
d. Click Instance (This means that this 

parameter can vary from one piece of 

   



furniture to another.) 

50. Click OK to return to the Family Types dialog 
box. 

 

 

  

The glass door parameter appears, ready to be 
assigned to the visibility of an element. 
 
A checked box means show, and a cleared box 
means hide. 

51. Select the glass doors and doorknobs and 
click Properties. 

52. In the Element Properties dialog box, click 
the gray button at the right end of the Visible 
line. This button enables you to link one 
parameter to one property. 

53. In the Associate Family Parameter dialog 
box, select Glass Door. 

54. Click OK twice. 

 

55. To verify functioning of this parameter, load 
the family in a project. 

 

  
 
 



56. Save your work again.  

 

57. Start a new project, load your family, insert a 
few instances of the family in the project, and 
try modifying the parameters. The new, 
added parameter lets you control visibility of 
the glass doors and the doorknobs per 
instance. Try changing to different levels of 
detail in 3D view. The doors and the knobs 
should display only in a Fine level of detail. 
Try also changing the level of detail in plan 
view. There, regardless of the level of detail, 
the doors and the knobs should not display. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Unit 11, Exercise D: Nested Families 
In this exercise you add drawers to the shelf unit. To create the drawers you first create a new furniture family and build a single drawer in it. You load this drawer 
family into the shelf unit family, “nesting” the drawer family in the shelf unit file. 
 
To finalize your family, you add two drawers in the opening between the glass doors. Instead of modeling it in the shelf unit family, you create a new family for the 
drawer and then insert it in this one as a nested family. The width of this interior space is determined by the overall width of the family type—or the width 
parameter. You create formula-type parameters that are based on the depth, width, and height parameters of the shelves and pass these parameters through to 
the nested drawer family. 
 
However, first things first: let’s create the drawer family. 
 
Note that the description for creating the drawer is less detailed than the previous one. If necessary, refer to the initial creation of the shelf unit to review the 
processes. 
 
Roughly, this exercise breaks down into the following sections: 
 
• Create a drawer family: This is a new family you will create. 
• Create a drawer shelf: This takes place in the shelf unit family and is a review of the Unit 10 exercise. 
• Create drawer parameters in shelf unit family. These drive the geometry of the nested drawer family. 
• Create formulas for the drawer parameters within the shelf unit family. The formulas perform arithmetic operations on other family parameters.  
• Load, place, and position a drawer. You can load families to use inside other families as components. 
• Link parameters from the shelf unit family to the drawer family. 
 
 
 

Create a Drawer Family 
 

 

1. From the File menu, choose New>Family. 
Select the Furniture.rft family template and 
click Open. 

2. Activate the Ref. Level view (Project 
Browser, Floor Plans). 

3. Add three reference planes, as shown. 

4. Add dimensions, as shown. 
 

 



5. Set the dimensions to labels (parameters), 
as shown. (You need to create two new 
parameters: Width and Depth.) 

a. Group = Dimensions 
b. Type parameter  

 

6. Select the horizontal reference plane, and in 
its properties select: 

a. Name = Front 
b. Is Reference = Front 

 

 

7. Activate the front view, and add another 
reference plane above the existing one. 
Create a new parameter Height. 

a. Group = Dimensions 
b. Type parameter 

 

 

8. Activate the Ref. Level view.  

9. Add a solid form using the extrusion method. 
The sketch of the solid should be a rectangle 
with sides locked to the reference planes. At 
this stage do not click Finish Sketch. 

 

 

As you hold the cursor over an intersection of 
two reference planes, notice that one or both of 
the reference planes highlight. If only one 
reference plane highlights, move the cursor 
slightly until both reference planes are 
highlighted. Then click the intersection. If you do 
this with both corners of the rectangle, the locks 
automatically appear as shown.  



10. Click Extrusion Properties.  

 

 

11. In the dialog box, click the gray rectangle on 
the Extrusion End line.  

12. Select the Height parameter.  

13. Click OK.  

 

 

You have just constrained the depth of the solid 
to the family’s height parameter.  
 
 
 
The Extrusion End (depth) is now dimmed 
because it is being driven by the height 
parameter. There is an equal (=) symbol here to 
let you know this has been assigned to a 
different parameter. 

14. Click OK to close the dialog boxes. 
 

 

15. Click the Finish Sketch button. 
 

 

16. On the Design Bar, this time select Void 
Form and choose the Extrusion method. 

17. Draw a rectangle on the interior side of the 
existing solid. Using the Dimension tool, lock 
the edges of the void to the reference planes 
(fix the distance to 1/2”). At this stage do not 
click Finish Sketch. 

 

 

It is a good practice to dimension to the 
reference plane rather than the geometry of the 
previous solid form. 



18. Just as in the previous case, in the Extrusion 
Properties dialog box, associate the 
extrusion end to the height parameter and 
set the extrusion start to 1/2”. 

19. This is the thickness of the bottom of your 
drawer. You can see this better in the front 
view. 

20. Finish the sketch. 
 

 

21. Activate the front view. 

22. On the Design Bar, click Void Form>Void 
Extrusion. 

23. Add a new sketch. This time it is a circle 
cutting out the opening spot for the drawer. 
Draw the circle as shown on the right. Don’t 
click Finish Sketch yet.  

You need to assure that this sketch remains 
always aligned to the axis of the drawer width 
and that its vertical position doesn’t change 
either. To facilitate aligning a circle, it is 
recommended you activate the Center Mark 
Visible option and use it as a reference point for 
constraining. 

24. Right-click the circle, choose Properties, and 
select the Center Mark Visible option. 
Confirm with OK. 

 

 

 
 

Note the cross in the middle of the circle. It is 
from this point that you define constraints to the 
reference planes. 

25. Using the Align tool, align and lock the circle 
to the central reference plane. 

 



26. Add a dimension between the reference 
plane that defines the height of the drawer 
and the center of the circle. Set the distance 
to 2” and lock it. 

 

 

27. In the Extrusion Properties dialog box, set 
the Extrusion start to 0. 

28. Click OK, and then click Finish the Sketch. 

 

 

The extrusion is heading the wrong direction. 
You need to fix that little problem. 

29. Open the Ref. Level view and select the 
void. Select the upper blue point and start 
sliding it toward the interior of the drawer. 
Lock that position. Lock the bottom triangular 
grip to the front face of the drawer. 

 
 

If you have difficulty doing this in plan view, try 
the right or left. 

30. Finally, add a new Material parameter. Name 
it Finish.  

31. Associate the entire 3D geometry to it. 

32. Flex the model to test the work you have 
done. Try out different values for width, 
height, depth, and so forth. 

33. From the File menu, choose Save As, and 
save the family as Drawer.rfa. Close this file.

 

 
 

 



 

Note that a nested family can also be a shared 
family. Make a shared family by choosing Family 
Categories and Parameters from the Settings 
menu. 

 

By selecting the Shared box, you change the 
behaviour of the nested family when it is loaded 
into a project. When a nested family is shared, 
 
• You can load the family directly into a 

project to update all families that have that 
nested family. 

 
• You can schedule the nested family even 

though it resides within a different family. 

The drawer family is now ready to be inserted in 
the furniture family, but you need to make a few 
adjustments:  

• You are missing a small shelf that is 
positioned between the two drawers when 
placed in the opening. 

• There are no parameters in the big family 
that define the width, depth, and height of 
the drawer. 

 

The first problem can be resolved using the same 
techniques to create the shelf unit as well as the drawer. 
The second problem requires formulas to help calculate the 
values of the drawer parameters. You create three new 
parameters: 

• Drawer Width = (total width / 3) – (2 x thickness of 
the separation panel) 

• Drawer Height = ((((total height – 5”) / 5) / 2) – 1 x 
shelf thickness) 

• Drawer Depth = total depth -15 
 

 



Create Drawer Shelf in Shelf Unit 
Family  

 

34. Open workbook data set \Unit 11 d Shelf – 
Start.rfa 

The Unit 11 d Shelf – Start.rfa is the end product of Exercise 
11c. Use this as a starting point, or continue with a shelf unit 
you have tested in a project. 

 

35. Now add the separation shelf between the 
two drawers. We won’t explain in detail, as 
by now you have already learned how to do 
that. To review, see Unit 10. 

 

 

36. Activate the front view. 

37. Click Solid From>Extrusion. 

38. Double-check that the active work plane is 
set to Back. 

39. Add a rectangular sketch in the upper part of 
the empty middle shelf, as shown in the 
drawing on the right. 

 

 

40. Align the sketch and lock, as shown. 

 

 



41. Add a dimension for the shelf thickness. 

42. Select the dimension chain, set it to 1/2”, 
and confirm. 

43. Lock this dimension. 

44. Click Finish Sketch. 

 

 

 

45. Open the Ref. Level (Coarse – Medium), 
select the 3D geometry, and using the blue 
arrow in the front, align it to the second 
reference plane from the bottom (see 
image). 

46. Lock it to that position. 

 

 

 

47. In the Properties dialog box of this geometry, 
associate the Finish parameters to Material. 

48. Click the Edit button next to Visible, and 
clear Plan/RCP. 

 

 

 
 

Everything is ready to embrace the new nested 
family. The next step is to load the family you 
want to nest and correctly link its parameters to 
the parameters of the shelf unit. 



Create Drawer Parameters in Shelf 
Unit Family  

 

49. On the Design Bar, click Family Types. 

50. Under Parameters, click Add and set the 
following: 

a. Name = Drawer Width 
b. Group Parameter Under = Dimensions 
c. Type = Length 
d. Select Type radio button 

51. Click OK. 

 

 

 

52. Add Drawer Height parameter. 

a. Name = Drawer Height 
b. Group Parameter Under = Dimensions 
c. Type = Length 
d. Select Type radio button 

 

 

53. Add Drawer Depth parameter. 

a. Name = Drawer Depth 
b. Group Parameter Under = Dimensions 
c. Type = Length 
d. Select Type radio button 

 

 

 

 



Create Formulas for the Drawer 
Parameters  

54. Now, in the Family Types dialog box, in the 
lines of Drawer Depth, Drawer Height, and 
Drawer Width, write the formulas as shown 
in the image. 

55. For Autodesk Revit Building to process the 
formulas you have just entered, it is 
necessary to respect case (for Revit 
Building, width isn’t the same as Width). The 
suffix is automatically added when you 
confirm your formula, so it’s not necessary to 
write it. 

56. Click OK to confirm all. 

 

57. Click Apply to test your formulas as you 
create them.  

 

Type the formula and click the Apply button. If 
everything is correct, the calculated Width 
shows up in the value column. Revit Building 
alerts you to any errors. 

58. Click OK. 

59. Save the family. 
 

 

Load, Place, and Position a Drawer 
 

 

60. From the File menu, choose Load from 
Library/Load Family. 

61. Browse to find the drawer family (you have 
to remember where you saved it), and click 
Open. 

 
 

 



62. Set the Ref Level view current. 

63. On the Design Bar, click Component and 
insert one instance of the drawer family in 
the shelf unit. 

 

 

64. Using the Align tool, do the following: 

a. Click the Center Reference plane. 
b. Click the axis of the drawer and lock this 

alignment. 

 

When you place the cursor in align mode over 
the axis of the drawer, Autodesk Revit Building 
displays a thick black line indicating the 
reference plane of the drawer family. 
 



65. Align the front of the drawer to the second 
reference plane from the bottom (see 
image). 

66. Lock this alignment as well. 

 

 

For a perfect match of the drawer family in the 
shelf unit, you need to link the parameters of 
both families. 
 

Link Parameters from the Shelf Unit 
Family to the Drawer Family  

 

67. On the Design Bar, click Modify and select 
the drawer. 

68. On the Options Bar, click Properties. 
 

 

69. In the Element Properties dialog box, click 
Edit/New to view the type properties of the 
element and thus the drawer parameters. 

 

 

The element properties are the same properties 
you would expect to see if you loaded this family 
into a project. 
 
You use the small gray boxes at the far right 
end of the width, depth, height, and finish 
parameters to make the link between the 
parameters. 
 



70. Click the small gray box in the Depth line 
and select Drawer Depth in the Associate 
Family Parameter dialog box. Click OK. 

 

 
 
 

71. Repeat for all three parameters and 
associate them as follows: 

a. Width  Drawer Width 
b. Height  Drawer Height 
c. Finish  Finish 

72. Click OK. 

 

73. Activate the front view, and using the Align 
tool, align and lock the drawer in the upper 
empty space. 

74. If you have trouble selecting the lower line of 
the drawer, just position your cursor near 
that line and use the Tab key until that line is 
activated, and then click to select it. (The 
Tab key is a great help whenever you have 
overlapping geometry.) 

 
 



75. Switch to the Ref Level view. 

76. Repeat the same method to insert, align, and 
lock the second drawer. 

77. Switch to the front view, and repeat aligning 
and locking vertically. 

78. Test the family by flexing the model. 

 
 

Because all drawer parameters are type 
parameters, you do not need to repeat the same 
for the second drawer. The new drawer instance 
automatically inherits the instance properties of 
the existing one. All you need to do is align it in 
plan view and in elevation. 
 
If you are daring, try copying the drawer in 
elevation instead of reinserting it in plan view. 
Can you get all the alignments in this front 
view? 

79. Select both drawers, and click Visibility on 
the Options Bar. 

80. Clear Plan/RCP. 

81. Click OK. 

 

 
 

 



82. Save your file. 

 

You are almost finished with your family. But 
before you use it in a project, you might want to 
add subcategories. With subcategories, you can 
control the entire display of the family in all 
views (line thickness, line color, line style, 
material, and so forth). 

 
 
 
 
 
 
 
 
 



Exercise E: Subcategories and Families 
 
The family category was defined when you selected the template to make it with. You can change this template later, but it is not advisable to do so. Always make 
sure to select the correct template when you create a new family. Next, you set new subcategories within your family. 
 
 

Create Subcategories of the Furniture 
Category 

This exercise builds on work performed in previous exercises. If you have not completed the previous 
exercises, but want to work through this exercise on subcategories and families, then open Data\rfa\ Unit 
11e Shelf – Start.  

1. From the Options menu, choose Object Styles.

2. Scroll down to the Furniture category. By 
default there are two predefined 
subcategories: Hidden Lines and Overhead 
Lines. You need three new subcategories: 
Glass, Shelf, and Accessories. 

 

 

 

3. Click the New button. 

4. Enter Shelf for Name, and select Furniture 
under Subcategory of. Click OK. 

 
 

 

5. Repeat the operation for Glass and 
Accessories. 

 
For each subcategory, you can set whatever line thickness, color, or material you want. The material is 
assigned to the family subcategories only if under the Finish parameter the value is set to <by category>. 
Here, you simply change the color of one of the subcategories. 



6. In the Object Styles dialog box, in the Shelf 
line, click the Line Color button. 

7. Select any color from the Color dialog box, and 
click OK. 

 

 

8. To see just the symbolic lines, activate the Ref. 
Level (Fine) and using the Hide/Isolate tool, 
hide: 

a. Reference planes  
b. 3D geometry 
c. Nested families  

9. Select all these lines and change their 
subcategory directly to Shelf on the Options 
Bar. 

10. Repeat for the Ref. Level (Coarse – Medium). 
 

In principle, using the same method for both 2D and 
3D, here are the associations you need to define: 

11. For all vertical separations, horizontal shelves, 
and the plinth, associate the Shelf 
subcategory. 

12. For the Glass doors, choose Glass. 

13. For the Door knobs, choose Accessories. 

The easiest way to select the geometry when 
associating the subcategories is to work in a 3D 
view. 

14. Save the family. 

As for the drawers, if you have tried associating 
a subcategory to them, you will have noticed 
that there is no subcategory parameter in their 
properties. The reason is that the drawers are 
nested families. So, go back to the drawer 
family to effectuate this. 



Use In-Place Family Editing to Modify 
the Drawer Family 

Follow the same process you used in an earlier exercise 
to access the drawer family and modify the shelf in the 
project file. 

 

15. Select a drawer, and on the Options Bar, click 
the Edit Family button. 

16. Click Yes to open the family for editing. 

 

In the next step you create a subcategory in the 
drawer family called Shelf (same as the 
subcategory in the family file). All geometry uses
the existing shelf definition once it is loaded 
back into the family file. 
 
Alternatively, you could create a subcategory 
called Bin. In this case, when loaded into the 
shelf family, it would bring this subcategory with 
it and you would then have direct control over 
this subcategory in the shelf unit family file. 
Likewise, when you load the shelf unit into a 
project, it brings all the subcategories, including 
Bin. You would then have access to this 
subcategory in the project file. 

17. From the Settings menu, choose Object 
Styles. 

18. Create a new subcategory Shelf. 

19. Associate the entire geometry to this 
subcategory. 

 

 

20. On the Design Bar, click the Load into Projects 
tool. 

21. Check the current shelf family you are working 
on. 

22. Click OK. 

23. Click Yes to overwrite. 
 

 



24. Use the Window menu to switch back to the 
drawer family. 

25. Close the drawer family. 

26. Click No to the Save Changes prompt. 

 

You can save the changes if you want. If you do 
so, the software tries to locate where the 
original drawer family file came from when it 
was loaded into the family. 
 
You do not need to save because the changes 
have already been loaded into the shelf unit 
family. 

27. You should now be back at the shelf unit 
family. 

28. Save the family. 

 

The drawers assume the properties of the shelf 
subcategory defined in the shelf unit family. 

Create Types 
 

 



 

 

The family is finished and is fully parametric. 
What you still can do is to create types. In other 
words, you can preset different types of this 
family with predefined parameters like width, 
depth, height, and material so the shelf unit can 
automatically be inserted in various standard 
sizes or materials, enabling users to simply 
select the type from a list. Should the type not 
be found on that list, the user can always create 
it on the fly. Let’s see how to do that. 

29. On the Design Bar, click Family Types and 
then click New. 

30. As a name for the new type, enter 4’w x 6’h x 
2’d without Doors, and click OK. 

 
 

31. You can now change the corresponding values 
in the dialog box. 

32. Adjust the parameters to Width (4’), Height 
(6’), Depth (2’), and clear the Glass Door 
check box.  

33. Click OK. 

34. From the File menu, choose Save. 

 

 



35. Start a new project or open an existing one. 
Load the newly saved shelf unit family and 
insert a few instances of it in the project. Note 
that in the unit’s Properties dialog box under 
Type, you see two different predefined types of 
this family. 

 

The family name is displayed along with the 
type name. The family in this case is the name 
of the RFA file you have been working in. 

36. Insert a few instances of each type, and 
change their parameters to see the 
differences. Try to change both the instance 
parameters (Glass Door) as well as the type 
parameters (width, height, and so forth). 

 

37. Activate plan view, and in the Properties of the 
view, click the Visibility Edit button. 

38. Expand the Furniture category. 

 

 
 

39. Click Projection in the Shelf line. 

40. Click Override. 
 

 



41. Change the Line Color and the Line Pattern, 
and click OK. 

 

 

42. Make sure the changes you have just made 
are propagated correctly. 

 

 

43. Activate the 3D view, and in the Properties 
dialog box click Visibility.  

44. Expand the Furniture category. 

45. Clear Accessories, and click OK. 

 

 

Again, thanks to the subcategories, you can 
have an instance of this family in which the 
doorknobs are simply turned off and thus 
invisible. 
 
If you do not see the accessories in the view, 
remember these are set to Fine. 

 



46. Select any instance of the shelf unit, go to its 
Properties dialog box, and click Edit/New. 

47. In the dialog box that opens, select Duplicate. 
Autodesk Revit Building prompts you to enter a 
new name: you are about to create a new type 
of this family. Name this new type 4’w x 6’h x 
2’d – Red Finish. 

48. Click the material Finish. 

49. Create a red paint, and click OK to close all 
dialog boxes. 

50. You have just created a new type of this 
family. 

 
 

 
 
 
 
As you can gather by now, you can create as many types of a family as you want and use them in any project. 
 
 
 
 
 
 
 

Unit 12 
Theory: Interdependencies 

Autodesk Revit Building: Site 
This unit explains Autodesk Revit Building’s Site features and workflow as well as linking files and AutoCAD® drawings. This unit has four exercises: 

• 12a takes you through the process of creating importing an AutoCAD drawing 
• 12b illustrates how to link a Revit Building project into a current project. 
• 12c works with the site tools to develop the model. 
• 12d exports a view and sheet into AutoCAD DWG format.  



Unit 12, Exercise A: Importing AutoCAD Drawings 
In this exercise you start with the workbook template and import an AutoCAD drawing to use as a basis for the site work in the rest of this unit. This AutoCAD site 
drawing has polylines that are placed at elevation. In a later exercise you convert this geometry to a Revit Building toposurface. 
 
Exercise Setup   

1. Start a new project with the workbook template.  Refer to Unit 1 if you need help creating a project 
from the workbook template. 

2. From the File menu, choose Save As and save 
your project as Unit 12.rvt in the Revit Workbook
folder. 

  

3. Set the Site view current.   

Import an AutoCAD Drawing   

4. From the File menu, choose Import/Link>CAD 
Formats. 

 

 

5. Browse to and click once on the drawing file 
Import Site Plan.dwg in the Workbook folder. 

  

6. Match the settings in the Import dialog box to 
the settings shown at right: 

a. Link Instead of Import 
b. Current View Only 
c. All layers 
d. Preserve colors 
e. Automatically place: Origin to Origin 

 

Link Instead of Import: This option maintains a 
live link to the drawing. If the drawing changes, 
you can reload it into the Revit Building project. 
 
Current View Only: It is a good idea to link 
drawings to a specific view. This cuts down on 
the amount of information that must be 
regenerated as you switch from view to view. 
 
Origin to Origin. Although you do not have 
access to the project origin as in AutoCAD, the 
origin is near the intersection of the elevation 
marks. 

7. Click the Open button to proceed with the 
import. 

  



8. Right-click in the drawing area and choose 
Zoom to Fit. 

 

 

Layer Control of Linked Drawing: 
Query 

  

9. Click the imported DWG in the drawing window.   

10. On the Options Bar, click the Query button.  

 

 

11. Click one of the magenta lines in the drawing. 

 

 

12. Click Hide in View. 

 

The Query dialog box is a convenient way to find 
out information about the object you have 
selected in the linked drawing.  

Layer Control of Linked Drawing: 
Visibility Graphics 

In addition to the on-off control afforded by the query tool, 
you have complete control over the linework in the linked 
drawing through the visibility graphics override of the view.

 



13. Type VG to access the view’s visibility graphics 
override. 

  

14. Click the Imported Categories tab.   

15. Click the Line Style for C_CNTR_10 to access 
the override for this layer in the linked drawing. 

 

 

16. Set the line color to a purple or dark red and the 
line pattern to Long Dash. 

 

17. Click OK two times to return to the project’s 
drawing window. 

The linked drawing now has overrides for this 
specific view. 

 



Unit 12, Exercise B: Importing Revit Building Projects 
In this exercise you continue from exercise 12a, but import a Revit Building project with a building in it. You then look at some of the display controls you have over 
the linked Revit Building file. 
 
If you completed the last exercise, you can continue to work in that file. If you choose to work in the provided project file, note for consistency the AutoCAD 
drawing has been inserted rather than linked. 
 
Exercise Setup   

1. Open file Unit 12b – Start. You should be in site 
view. 

  

Link a Revit Building Project into the 
Current Project 

Revit Building files may be linked to one another. Like the 
linked AutoCAD DWG, as the linked Revit Building file 
changes, it may be reloaded to update the current project 
with the new information. Also like the linked DWG file, 
you have control over how the linked Revit Building file is 
displayed in the current view.  

Unlike the AutoCAD drawing file, there is no way 
to insert a Revit Building project into another 
project completely. It will only import as a linked 
file. 

2. From the File menu, choose Import/Link>Revit, 
and browse to the workbook’s data set folder. 
Click one time on Unit 12 Building.rvt. 

 

 

3. Under Positioning, select the Origin to Origin 
option, and click the Open button. 

 

Linked Revit Building Project by View You have several levels of control over the display of the 
linked Revit Building file. You can view the linked file with 
the default visibility of the view, or the default settings of a 

 



view within the linked file, or override any of the linked 
constituent parts. 

4. Duplicate with detailing the Site view and 
rename the new view Site-Concept. 

  

5. Tile the Site and Site-Concept views. 

 

 

6. Set the Site-Concept view current, and type VG 
to access the view’s visibility graphics override. 

  

7. Click the Revit Links tab, and then click the plus 
(+) sign to the left of Unit 12 Building.rvt. 

 

If you have more than one instance of the linked 
file in your project, each instance is listed in this 
tree. You control the display of each instance 
independently. 

8. Click the display settings By Host View button to 
override the default display settings. 

  

9. In the RVT link Display Settings, click the Basics 
tab, and then click the By Linked View radio 
button and set the linked view to Floor Plan: 
Level 1. 

 



10. Click OK two times to return to the drawing 
window. 

 

The linked file now uses the current display 
settings stored by the linked file rather than the 
host file’s current view settings. 

Linked Revit Building Project View 
Display Override 

You can also control each item in the linked file 
independently of the view settings stored in the linked 
project files view. 

 

11. With the Site-Concept view current, type VG to 
access the view’s visibility graphics override. 

  

12. In the RVT Link Display Settings dialog box, 
click the Basics tab then click the Custom radio 
button. 

a. Verify the Linked View is set to Floor 
Plan: Level 1. 

b. Change the Detail Level to Coarse. 

 



13. Click the Model Categories tab: 
a. Set the Model Categories drop-down 

to <Custom>. 
b. Under Walls, clear the Surface 

Pattern check box. 

 

 

 

14. Click the Annotation Categories tab: 
a. Set the Annotation Categories drop-

down to <Custom>. 
b. Clear the Show Annotation 

Categories in This View check box. 

 

15. Click OK two times to return to the drawing 
window. 

 

All of the control you have over the host drawing 
view visibility can also be applied to a linked 
Revit Building project. 



Unit 12, Exercise C: Site Tools 
In this exercise you create a site toposurface based on the geometry of the linked AutoCAD site file. You then develop the site using the Revit Building site tools. 
 
 
 
 
1. Open file Unit 12c – Start. You should be in site 

view. 

 

The site file has an imported DWG instance. The 
DWG data consists of 2D polylines on different 
heights.  

2. Set the 3D view current. 

 

Note that the DWG drawing was imported as 
“Current View Only,” so it displays only in the 
view where it was positioned—the Floor Plans 
Site view. It does not appear in the 3D view. 

3. Set the Floor Plans Site view current.   

4. Right-click the Design Bar and activate the Site 
Design Bar if it’s not already visible. 

 

 

5. On the Design Bar, click Toposurface. You enter 
sketch mode. 

 

 

6. Set the Floor Plans Site view current.   



7. On the Design Bar, click Use Imported>Import 
Instance, and click the imported DWG file.  

 
 
 

  

You can also create toposurfaces directly by 
clicking the Point command and positioning 
points (the height can be set on the Options Bar) 
in the workspace. 
 
Site information is usually imported from DWG 
files. Once the DWG instance is selected, 
Autodesk Revit Building recognizes the layers 
contained within it and lets you pick which ones 
you want to use to create the surface. 

8. Use image on the right to select the layers to 
use for creating the surface. Click OK. 

 

 

9. On the Design Bar, click Properties and change 
the surface material to Site – Grass. Click OK to 
close the dialog box. 

 

You can change surface material later by 
opening its Properties window. 

10. On the Design Bar, click Finish Surface.   

11. Open a 3D view. Note that the building is sunk 
inside the topographic surface. 
 

12. Open site view again. 

 

 
Note that the DWG drawing was imported as 
“Current View Only,” so it displays only in the 
view where it was positioned. 

Create a Pad   

13. On the Design Bar, click Pad. You are once   



again in sketch mode. 

14. Use the Lines tool to draw a rectangle around 
the building, as shown in the image. You can 
follow the property lines for the sketch. 

 

These property lines were sketched, but you can 
enter their coordinates directly in a table and the 
sketch is automatically generated. 

15. On the Design Bar, click Pad Properties, and 
change the Pad Level to Level 1. 

 Change this property at any time. 

16. Click Finish Sketch.   

17. Open the visibility settings for the view, go to the 
DWG/DXF/DGN Categories tab and turn off 
visibility for all the DWG layers except Site 
Layout.  

18. Click OK to exit the Visibility/Graphic Overrides 
dialog box. 

19. Click OK to exit the View Properties dialog box. 

 

 

Turn off the unnecessary DWG data in your 
view. 



20. Open the 3D view to see the pad. Tile windows 
(choose Tile from the Window menu). 

 

Working with side-by-side windows is helpful in 
many situations. 
 
Before you tile the windows, choose Close 
Hidden Windows from the Window menu, and 
then open just the views you want to tile. 
 
If you minimize a view, it does not tile with the 
other open views. 

Adjust the Building Levels to the Site 
Topography 

 

The building pad is well below the average grade 
of the topography. Lock the levels together, and 
then adjust the level heights relative to the 
topography. 

21. In the west elevation view, add a string of 
dimensions from level line to level line. Lock 
each of the dimensions.  

 

 

22. Change the value of Level 1 to 9’. 

 

 



 

 

Because all the building components are 
constrained to the levels, as you move the levels 
the entire building moves accordingly. 

Add Site Components   

23. Set the Floor Plans : Site Plan current.   

24. On the Design Bar, click the Parking 
component, and add a 9’ x 18’ - 70 deg, as 
shown in image. 

 

Parking components, as site components, 
automatically recognize the height of their host 
during positioning. 
 
Use the blue arrows to flip the parking space. 

 

25. Select the parking component and array eight 
instances of it to the left (west). 

 

Parametric arrays are helpful when positioning 
this kind of component. 



26. Click Site component, and add a few tree 
components, as shown in image. 

 

Trees are specific site components that have 
their own editor and can be customized, though 
Autodesk Revit Building comes with an extensive 
tree library. 
 
To navigate through the library, create a new 
planting family and open the Family Types dialog 
box. Clicking the Plant Name parameter opens 
an AccuRender dialog box with the tree library. 
 
The symbol used for plans, elevations, sections, 
and normal 3D is a simple stick symbol. 

27. Change the site settings.   

28. Maximize the site view. From the Settings 
menu, choose Site Settings. 

  

29. Contours are set to show up every 10 feet as 
primary contours, and every foot as secondary 
contours. 

 You can add as many contour lines as you want. 
 
The Poche base elevation setting in the bottom 
left defines how thick the surface displays in 
section views. The Cut material defines what 
type of hatching the poche has.  
 
Once finished, if you zoom into the drawing, you 
see that primary and secondary contours display 
with different lineweights, which are set in the 
Object Styles dialog box under the Topography 
category. 



Add Contour Labels   

30. On the Design Bar, click Label Contours and 
draw a straight horizontal line, approximately as 
shown in image. 

 

You can draw the contour label line in any 
direction. 

31. Zoom in to see the labels. ` 
 
 
 
 
 

 

Add a Site Section   

32. Go to View Design Bar. Click Section, and draw 
a section on the same line as the contour label 
line. 

 

 



33. Open the section. From the View menu, choose 
Apply View Template>Site Section. 

 

34. Shade the view if desired.   
 
 
 
 

Unit 12, Exercise D: Exporting AutoCAD Drawings 
In this exercise you export the site model and a sheet for use with AutoCAD software. 
 
 

Exercise Setup   

1. Open file Unit 12d – Start. You should be in site 
view. 

  

2. Open the Sheet A101 and zoom out to see the 
extents of the views. 

 

The views that were placed on the sheet have 
grown because the site work makes the extents 
of the views much larger than when the views 
were originally placed on the sheet. This is 
typical behavior if a view does not have its crop 
region active.  

3. For each of the views on the sheet: 
a. Open the view properties and select 

the Crop Region check box. 
b. Select and left-drag the crop region in 

to a more sensible boundary for the 
view. 

   
 

You can also access the view properties from 
the sheet by selecting a view on the sheet and 
choosing Activate View from the context-
sensitive menu. 

 



 

The finished sheet is now ready to export to 
AutoCAD software. 

Export a Sheet to AutoCAD Drawing 
Format 

Before you export to AutoCAD, verify that the export 
settings are correct. 

 

4. From the File menu, choose Import/Export 
Settings>Export Layers DWG/DXF. 

 

5. Make any changes needed to the export 
settings. 

Each of the Revit Building objects is assigned a 
layer and color ID for instances where the object 
is cut (such as a wall in plan view) or used as 
projection (a wall in elevation). The layer names 
are created automatically in the new drawing file. 
The color IDs are the standard AutoCAD ACI 
colors that are assigned to the layers as they are 
created. 

6. Click OK to return to the drawing window.   



7. From the File menu, choose Export>CAD 
Formats. 

 

 

8. In the Export dialog box: 
a. Click the Manual radio button under 

File Naming. 
b. Type a file name for the drawing. 
c. Set Save as type to AutoCAD 2004 is 

the format. 
d. Click the Options button. 

 



9. The Export Options dialog box gives you several 
options as to how the drawing will be created. 
Verify that the settings are as shown, and click 
OK to return to the Export dialog box. 

 

 

10. Click the Save button to create the new drawing 
file. 

 

The new drawing is created along with a PCP file 
for the pen settings that AutoCAD can use to plot 
this file. 

 



Unit 14 
Theory: Detail 

Autodesk Revit Building: Drafting and Linework 
This unit explains how to accomplish detailed drawings using Autodesk Revit Building. 
 
1. Open the file Unit 14 – Start.rvt in the training 

files directory. The project should open up to the 
view Floor Plans: Level 2. 

 

 

 

2. On the Basics Design Bar, click Section. 
3. On the Options Bar, set: 
• Section Type = Detail View 
• Scale = 1/2" = 1’-0” 

 

 

You can create as many section types as you 
want by duplicating them. 
 
In the Project Browser, details (including 
sections) appear under the category called Detail 
Views, while other section types have their own 
category.  
 
The scale affects the detail level of the newly 
created view. Normally, all views 1 1/2” = 1’=0” 
and bigger have detail level set to Fine, but it is 
possible to change the settings by choosing 
Detail Level from the Settings menu. 



4. Draw a section mark over the window, as shown 
in image. 

 

 

5. Open the section by double-clicking the section 
bubble or the detail view in the Project Browser.

  

6. If needed, resize section on top to display 
Levels 2 and 3, as shown in image. 

 

           

You may need to resize section views, or maybe 
even turn off the crop region if it disturbs your 
drawing: Right-click, choose View Properties, 
and clear Crop Region Visible. 

7. Right-click in the section detail view , and 
choose View Properties. Under Model 
Categories, turn off visibility of windows.  

8. Click OK to exit dialog box. Click OK again to 
close view properties. 

 

 

 

The keyboard shortcut for displaying the visibility 
settings for the view is VV. It provides a quick 
way to jump directly to the dialog box. 

9. From the File menu, choose Load from 
Library>Load Family. Navigate to the RFA folder 
in the Training Files folder and select the file 
called Window Section.rfa. This detail 
component was generated from a DWG file. 

 

 Detail components can be created by drawing 
directly or by importing a DWG, DXF™, or DGN 
file if you already have the detail in one of these 
file formats. 

10. On the Drafting Design Bar, click Detail 
Component. The loaded Window section detail 
component should be ready to be placed on the 
drawing.  

 



 

11. Place the window detail component as shown in 
image. Use the Align tool to help align it 
correctly to the sill and the wall finish. 

 

 

 

 

Edit Cut Profile   

12. Select the Edit Cut Profile icon on the toolbar. 

 

 

13. Click the hatch or boundary of the 
subcomponent you want to modify.  

 

This takes you into sketch mode, where you 
draw the linework for the new cut profile of the 
component. 

14. Draw the linework where you want the 
component to be cut. 

 

 



15. Click the blue arrow toward the side you want to 
keep. 

16. Click Finish Sketch. 

 

 

17. Repeat for the other three components in the 
wall. 

 

The profile of each material must be edited 
separately because the tool works on one 
boundary or wall layer at a time. 

18. On the Drafting Design Bar, click Repeating 
Detail, and on the Options Bar, click Brick – 
Section. 

 

 Use detail components in arrays to create a 
repeating detail. A simple example is a series of 
bricks in section view. There are various ways to 
assemble the detail component in a repeating 
detail. 

19. Draw a line on the exterior part of the wall, as 
shown in image. Don’t worry about correct 
positioning. Move it into the correct position after 
placing it. 

 

   

 



20. Add another Brick – Section repeating detail 
below the window. 

 

 

Note that this brick detail component contains an 
invisible line that defines the width of the mortar. 
You could add a hatch in the detail component 
so it displays the mortar in the repeating detail. 

21. If the brick repeating detail is in front of the 
window detail, select the former and click the 
Bring to Front icon on the Options Bar. 

 

  

Annotations and detail components are view 
specific: they are visible only in the view they 
were created in. 
 
It is possible to define the order of their 
appearance by using the toolbar displayed on 
the left. This toolbar appears on the Options Bar 
when a detail component is selected. 

  

 

 



22. On the Drafting Design Bar, click Insulation, and 
set the size in the Options Bar to 5 ½”. 

 
23. Draw the insulation in the exterior wall, as 

shown in image, both above and below the 
window detail. 

 

    

Change the insulation width after designing it by 
right-clicking and choosing Properties>Width 
Field, or by simply changing the Width value on 
the Options Bar. 



Unit 16 
Theory: Is Architecture Engineering? 

Autodesk Revit Building: Formulas 
This exercise starts with a data set that is a window family. The window family is already complete; you add some formulas to control the geometry and visibility of 
some of the solid elements that compose the window family. In particular, you create 
 
• Formulas that control the relative height of the frames (and the glass), depending on the sill thickness  
• A formula that controls visibility of the crown, to be displayed only if the window width is equal to or larger than 5’ 
 
Parameter values should always be changed in the Family Types window to verify if the model flexes correctly. 
 
In Unit 11 you added formula parameters to control the width of the drawer of the shelf unit. You also added a visibility parameter.  
In this exercise you create formulas and tie the display of the crown or lintel of the window to the result of the formula. 
 
This exercise assumes you have worked through the exercises in Units 10 and 11. If you have questions about terminology or processes, you can go back to 
those exercises for review. 
  
 
1. Open file Unit 16 – Start.  
2. Set Current 3D Views:{3D}. 

 

Families are created using family template files 
that contain different parameters according to 
the category. In this window family a crown 
subcategory was added in the Object Styles 
dialog box (Settings menu, Object Styles 
command). 
 
The window family is already complete, but you 
will add formulas to control the geometry and 
visibility of some of the solid elements that 
compose the window family. In particular, you 
create formulas that control the relative height of 
the frames (and the glass), depending on the sill 
thickness and whether it is visible. Another 
formula controls visibility of the crown, to be 
displayed only if the window width is equal to or 
larger than 5 feet. 

3. Click the window in the view.   



4. Note that there are already a few types in the 
family. Select them from the drop-down menu. 
Return to the type named 4’-0” x 4’-0”. 

5. On the Design Bar, click the Family Types 
button. 

 

As you flex the types in the project, note that for 
the different heights the relationship between the 
sill and the window frame remains constant. 
 

6. Open the type parameters for the 4’ – 0” x 4’ – 
0” window type. 

7. Change the sill thickness to 4”. 
8. Click OK to return to the drawing window. 

 

Note that when you do this, the H parameter 
changes as well. The current definition of the H 
parameter is height (of the window opening) less 
the sill thickness.  

 

 

The relationship between the sill and the window 
frame is constant. 

 

9. Return to the window type properties and clear 
Sill Visible. 

10. Click OK to return to the drawing window. 

 
 
 

 

 
The window has a gap where the sill is still taken 
into consideration, but is not displayed. 



Edit the Window Family   

11. Click the window. 
12. On the Options Bar, click Edit Family. 
13. Click Yes to edit the family. 

  

14. You add a formula to control the relative frame 
height according the sill visibility.  

  

Formulate the H Parameter 

 

The H parameter was specifically created and 
assigned to the frame height. To see how it is 
defined, select the outer frame and click Edit on 
the Options Bar. On the Design Bar, click Sketch 
2D Path, and go to the exterior elevation view. 
 
Note the gap from the bottom of the sketch line 
to allow for the sill. 
 
If you see a parameter in a family definition that 
is not immediately evident when the family is 
opened, there is a good chance that it is nested 
into a solid part of the family. 
 
If you have opened this solid for editing, quit 
back to the standard family editor window. 

15. In the Family Types properties dialog box, click 
the H parameter row, and under the Formulas 
column write the IF formula:  if (Sill Visible, 
Height - Sill Thickness, Height). 

 
The formula syntax is: 
IF (<condition>, <result-if-true>, <result-if-false>) 
Because Sill Visible is a Yes/No parameter, you only need 
to type the condition by itself. 
Formulas and parameters are case sensitive. 

To put this into English: 
 
If the sill is visible (condition is true), then Height 
- Sill Thickness (raise the frame for the sill). 
 
If the sill is not visible (condition false), then use 
the value held by the height parameter as the 
height of the window, filling in the space that 
would otherwise be occupied by the sill. 

16. Click Apply. Change the sill thickness parameter 
to different values, and click Apply each time 
you change the value. Note how the height of 
the window frame now changes correctly. 

 Always flex your family from the Family Types 
dialog box to check if the model responds 
correctly. 

17. Clear the Sill Visible parameter, and click Apply. 
Note how the frame resizes accordingly to fit 
precisely in the opening. 

 Note that the sill is still visible in the model but is 
dimmed. In the Family Editor even if visibility of a 
specific component is turned off, you still see it 
for editing purposes. In the normal project 
environment, the sill would not be visible. 



Create a Crown Visibility Parameter  In the last section you controlled a length 
parameter by the visibility Yes/No parameter. In 
this section you do the opposite and control a 
visibility parameter based on a length. If the 
window width is greater than a specified width, 
show the Crown/Header. If it is less than the 
specified width, do not show it. 

18. You next create a visibility parameter to control 
the crown visibility. Click the Add button under 
the Parameters category in the Family Types 
dialog box. 

  

19. Create a new Yes/No parameter called Crown 
Visible (see image on the right). Click OK to 
return to the Family Types dialog box, and click 
OK again to close the dialog box. 

You can create different types of parameters by 
opening the Type drop-down menu to see them 
all. 

20. Select the solid that acts as the crown and open 
its Properties dialog box by right-clicking and 
choosing Properties or by clicking the Properties 
icon on the Options Bar. 

  

 

21. Click the gray icon displaying an ellipsis (…) 
under the Visible row of its properties. 

  

Clicking the button enables you to assign control 
of that element parameter to an equivalent family 
parameter that can then be either used in 
formulas or changed directly in the project. 

22. Assign it the Crown Visibility parameter, which 
you created in the previous step. 

23. Click OK twice to close the dialog boxes. 

  

The family parameters displayed are only those 
of the same type: length parameter if you are 
setting a distance, yes/no if you are selecting a 
visibility parameter, material if you are assigning 
a material parameter, and so on. 



24. Open the Family Types dialog box, and under 
the Crown Visible parameter row, write the 
formula: 
 
or(Width>5', Width = 5') 

 

Remember that formulas are case sensitive. 
 
It’s a good idea to type the unit suffix in formulas 
directly to avoid confusion. 
 
 
 

25. Change the window type from the active one to 
4’ x 4’.  

  

 

 

26. On the Design Bar, click Load into Project.  
27. Click the Unit 16 project you started the exercise 

with. 
28. Click OK. 
29. Click Yes to override the parameters in the 

project. 

 

30. Flex the family in the project. 
31. Turn off the sill in type properties. 

 

The frame now fills in the full height when the sill 
is turned off. 



32. Change the window to different types. 

   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Unit 17 
Theory: Databases 

Autodesk Revit Building: Databases and Interoperability 
In this exercise you export a Revit Building project to an ODBC-compliant database. 
 
 

Export a Database There is no data set provided for this exercise.   

1. Open a project. If you are not working on your 
own project, open one of the projects 
provided with the workbook.  

2. From the File menu, choose Export ODBC 
Database. 

ODBC stands for Open DataBase Connectivity. The 
purpose of this is to create a database that any 
database management system can use. Part of an 
ODBC-compliant database is a data source name 
file. This file is like a translator to the database and 
provides a link between the database and the 
software used to interpret the data. 
 
This example proceeds with creating both an access 
database (MDB) file and the data source name file. 

3. In the Select Data Source dialog box, click 
the New button. 

  



4. Click the Microsoft Access Driver and then 
click the Next button. 

 

5. In the Create New Data Source dialog box: 

a. Click the Browse button.  
b. Browse to the workbook’s data set folder. 
c. Name the file. 
d. Click the Save button. 
e. Click the Next button. 

 

 

 
 

 
 

 



6. Click the Finish button.  

7. In the ODBC Microsoft Access Setup dialog 
box, click the Create button. 

 

8. Enter a name for the database. Also in this 
dialog box you can verify the location where 
you want to create the database.  

9. Click OK. 

 

 

10. Click OK again.  



11. Click OK again.  

12. Click OK again. The database has been created in the folder you 
specified. This sample is provided in the Completed 
folder of the workbook data sets. 

 



13. Click OK again. 

 

 



Unit 18 
Theory: Schedules, Tables, and Legends 
Schedules are just another view of the building model, but instead of representing the data in a graphical format, the information in the building database is 
presented in tabular format. 

Autodesk Revit Building: Tags and Schedules 
 
The seven exercises in this unit cover the scheduling capabilities of Autodesk Revit Building. Each covers a different aspect of schedules in the Revit Building 
environment. 

• Exercise 18a – Door schedules 
• Exercise 18b –Room objects schedule and tags 
• Exercise 18c – Calculated values in a room schedule 
• Exercise 18d – Room finish keys 
• Exercise 18e – Color fill legends 
• Exercise 18f – Symbol legends 
• Exercise 18g – Material takeoff schedules 

 
 

Unit 18, Exercise A – Door Schedules 
In this exercise you create a door schedule, modify its properties, and place it on a sheet. 
 
 

1. From the File menu, choose Open. Browse to 
find the file Unit 18a – Start delivered with the 
workbook and open it.  

 

 
 

The file opens with a 3D view of the building. The 
active view doesn’t have an effect on the creation of 
the schedule table. You can make a schedule table of 
any object having any view of the model. There are 
two ways to make a schedule table: using either the 
Schedule button on the View Design Bar or the View 
menu: New>Schedule Table. 
 

Create a Schedule   



2. On the Design Bar, click Views and then 
Schedules. 

3. From the Category list, select Doors and click 
OK. 

 

 

4. In the Schedule Properties dialog box under 
Available Fields, click Family and Type, and 
then click Add. 

 

 

The Available Fields list contains all information that 
can be extracted from the door object. On the right is 
an empty list in which you add the information that 
you want to see displayed in the schedule table.  
 
The schedule table is displayed in table form. The 
order of the fields that you have selected determines 
the order of the columns in the schedule table. You 
can easily modify this order using the Move Up and 
Move Down buttons. 

5. The Family and Type field is now moved to 
the right, under Scheduled Fields. This will 
now be one of the columns in the schedule. 
Repeat for two other fields: Width and Height. 

 

 



6. Click OK to close the Schedule dialog box. 

 

You can change the appearance of your schedule 
table by adjusting the width of the columns. The 
principle is simple: select the separation line between 
two columns in the title and drag it to the desired 
width.  

 
 

7. Right-click over the schedule table, and 
choose View Properties. 

 

 

8. In the Element Properties dialog box, click the 
Edit button next to Sorting/Grouping. 

 



9. In the newly opened dialog box, under Sort 
By, select Family and Type. 

10. Click OK to close the dialog box. 

 

The schedule table displays correctly according to the 
sorting criteria you have defined. Autodesk Revit 
Building allows four levels of sorting. 
 
Every line in the schedule table represents a door 
within the project. You might think this is an odd way 
to represent a door, but Revit Building can represent 
an object in a textual manner, showing all important 
information about that object. 

Before you continue working on your door 
schedule, you need to analyze the possibilities that 
Autodesk Revit Building proposes at this stage.  
Let’s have a look at the Options Bar. 

 

11. Click in any schedule table field, and then 
click the Show button. 

12. You can achieve the same by right-clicking 
the schedule field, and choosing Show. 

13. Revit Building opens a view in which you can 
see a graphical representation of the selected 
door. 

 

14. Click Show several times. 

15. Click Yes in the search prompt. 

 

Autodesk Revit Building enables you to search for 
other views in which this door is displayed. To do 
that, click the Show button. Should you not want to 
continue, simply click the Close button. 



16. Click again in any schedule table field, and 
click Delete on the Options Bar. 

  

Autodesk Revit Building double-checks that you 
really want to delete that instance. 
 
Again, you can find the same command by right-
clicking and using the context-sensitive menu. 

 You have surely noticed that the schedule table cells 
are editable. You can change any value in the 
schedule table (for example, the width of the door). 

You should be careful doing that, however, because 
the door width is a type parameter. This changes the 
width of all instances of this type in the project.  

 

 

Finally, you can change the family and type simply by 
clicking the family and type field. This field contains a 
pull-down list from which you can select the desired 
door family or type. 
 

17. What is important to understand here is that 
no matter what changes you undertake in the 
schedule table, they are populated 
everywhere in the project.  

 

The opposite works as well. If, for example, you 
delete or add a door in the project, the door is 
automatically deleted or added in the schedule 
table. In the Revit Building BIM model, the schedule 
tables are always directionally synchronized with the 
project. 

You are now going to work further on your schedule 
table, refine it, add new fields, sort it, modify its 
parameters, and finally place it on a layout sheet. 

18. Right-click over the schedule table. 

19. From the context-sensitive menu, choose 
View Properties. 

20. In the Element Properties dialog box, click 
Edit next to Fields. 

 

 



21. Add the fields Count and Level, and 
reorganize them as shown in the image using 
the Move Up and Move Down buttons. 

 

 
You have now set all necessary fields. Next is to sort 
your schedule table to make it more usable. Revit 
Building lets you sort with four different criteria 
simultaneously. Here, you want to sort by level and 
then by family and type. 
 

22. Click the Sorting/Grouping tab. 

 

  

On the Sorting/Grouping tab you find the criteria set 
previously. You need to change them. You want to 
sort this time by level and then family and type. 
Because there are two criteria for sorting, you need to 
intervene on the Header and Footer. 
 

23. On the Sorting/Grouping tab, set the 
following: 

24. Under Sort By, select Level. 

25. Select the Header and Footer check boxes, 
and in the list next to Footer, select Count 
and Totals. Also select the Blank Line check 
box. 

 

26. In the Then By field, select Family and Type. 

27. Select the Header and Blank Line check 
boxes. 

28. Click OK to close all dialog boxes. 

 



29. Right-click over the schedule table. 

30. Choose View Properties. 

31. In the Element Properties dialog box, click 
Edit in the Formatting field. 

 

 

32. Verify that the selected field is Family and 
Type. 

33. Select the Hidden Field check box at the 
bottom of the dialog box.  

34. Click OK to close all dialog boxes. 
 

As you can see, the Family and Type field is not 
displayed.  
 
However, notice that the schedule table displays 
every instance of your doors, but you need to know 
the total number of doors of the same type. So, you 
need to fix that final problem. 

35. Right-click anywhere over the schedule table 
again. 

36. Choose View Properties. 

37. In the Element Properties dialog box, click the 
Edit button next to Sorting/Grouping. 

38. Clear the Itemize Every Instance check box. 

39. Click OK to close all dialog boxes. 

 

Should you need it, you can also display the total 
number of doors in your building. To make that 
visible, you need to select the Grand Totals check 
box on the Sorting/Grouping tab. 

Duplicate the View For the moment, you can consider your schedule 
table ready. However, you haven’t yet learned about 
schedule filters. The filters allow you to filter through 
the data in the schedule tables. As for sorting/ 
grouping, there are four levels of filtering. You can 
filter only fields that are already present on the 
Fields tab. 

Next, you duplicate the schedule table view and apply 
a filter to the duplicated view. The goal is to have a 
schedule table that shows only the doors on Level 2. 
You reuse the schedule table in the second part of 
the exercise (Create a room schedule table). 



40. In the Project Browser, scroll to the door 
schedule and right-click it. From the context-
sensitive menu, choose Duplicate. 

 

 

41. Right-click the Copy of Door Schedule, and 
choose Rename. 

42. Change the Name to Door Schedule (Level 
2), and click OK. 

 

 

43. Right-click the Door Schedule (Level 2) 
schedule table, and go to the properties. 

44. In the Element Properties dialog box, click the 
Edit button next to Fields. 

 



45. Using the Remove button, delete the Count 
field. 

46. Using the Select Available Fields from drop-
down menu, click From Room. 

47. Under Available Fields, click From Room 
Name. 

48. Click the Add button. 

49. Repeat to add To Room: Name.  

 

50. Again, arrange the list of fields as shown on 
the right using the Move Up and Move Down 
buttons. 

 

You can just as easily insert or delete fields from 
the schedule table by double-clicking the desired 
field. 
 

51. In the Schedule Properties dialog box, click 
the Filter tab. 

52. In the Filter By list, select Level. 

53. In the next field, select Equals and set Level 2 
in the field below Filter By. 

 

 

54. Click the Sorting/Grouping tab. 

55. Change Sort By back to Family and Type. 

56. Verify that Header, Footer, and Count and 
Totals are set. 

57. Set the Then By sorting line to (none). 

 
 



58. Select Blank Line and also Itemize Every 
Instance. 

 

59. Click the Formatting tab. 

60. Verify that the Family and Type field is a 
Hidden field. 

 

 

61. Click OK twice to close all dialog boxes. Here, the schedule table displays the criteria you just 
defined. 
 

Create New Sheet for Door Schedule Certain parameters of the schedule tables are only 
visible once a schedule table has been placed on a 
sheet. That’s the case with the parameters on the 
Appearance tab of the schedule table properties. 
 
You are now going to study the placement 
possibilities of a schedule table on a sheet. For that 
purpose you use the entire schedule table of all 
doors in this building. 

 



62. On the View tab of the Design Bar, click 
Sheet. 

63. Click OK to accept the default title block that 
appears. 

 

 

64. Rename the sheet Schedules. Accept the 
number assigned. 

 

 

65. From the Project Browser, drag the door 
schedule table to the sheet you just created. 

  

 

66. Click the schedule. You see a series of 
controls. Each of the blue grips does 
something different. 

 Allows dimensioning of the column width (select, 
hold, move, and release at the desired position). 
Note that when you change the width of a column on 
one part of the split table, it changes in all other 
parts. 

 Allows moving of the table (click, hold, move, 
release). 
 

  Allows horizontal splitting of the table. Click the 
symbol and it’s done. To reunite the split parts, 
select the one part and move it over the other. Revit 
Building automatically reconnects the parts. 

 Allows you to change the height of a split part of a 
table (click, hold, move, release). The allowed moves 
are up and down. Obviously, changing the height of 
one schedule part means changing the height of the 
other. Try it out! 
 

67. Save and close the project. If you are going to work through the next exercise, 
you can keep this project open. 

 



Unit 18, Exercise B: Room Schedules, Rooms, and Tags 
In this exercise you work with the room schedule and tags.  
 
In the last exercise, we did not address the issue of tags. To work with or create a door schedule, all you need are the doors in a project. The tags just present 
information already associated with the door or in the schedule. The same is true for room schedules. A room does not appear in a schedule unless you place a 
room object.  
 
This exercise uses the same data set as the previous exercise but does not build on the information created in that exercise. 
 

Exercise Setup   

1. From the File menu, choose Open>Browse to 
find the file Unit 18b – Start delivered with the 
workbook. 

2. From the Project Browser, select Level 2. 

 

There are two ways to make a schedule table: either 
using the Schedule button on the View Design Bar or 
the View menu (New>Schedule Table). 
 

3. Hover your cursor near a room tag. 

 

The “X” is the room object in Revit Building. The room 
object contains the information for the room schedule 
about that space in the building. 



4. Click the room object, and open its properties 
dialog box: 

a. Verify the level is set to Level 2. 
b. Change the name to Bath 2. 
c. Add Tile as the floor finish. 

5. Click OK to close the dialog box. 
 

 

Just like a door or window, the values here can be 
reported in a schedule.  

Create a Duplicate View of the 2nd 
Floor 

 When creating a schedule view, it can be useful to 
duplicate the plan view in question so you have one 
plan view free of tags and colors, or to use a different 
type of tag. 

6. Right-click the Level 2 view, and choose 
Duplicate. 

7. Right-click the created Copy of Level 2 view, 
and choose Rename. 

8. Change the name to Level 2- Room Areas. 

9. Click OK. 

 

The duplicated view automatically becomes the 
active view. 
 

10. On the Design Bar, Drafting tab, click Room 
Tag. 

 Note that the rooms know their name, even though 
this view has no tags. The information displayed by 
the tag is stored by the room object. This allows you 
to make multiple views of the same level but use 
different tagging and annotation styles. 



11. Set the Room Tag type to Room Tag with 
Area. 

 

This is an annotation type. Like windows and doors, 
annotation such as text and tags are also based on 
family and type. Room Tag with Area is an external 
family file that you can load and use in any project. 

12. Start clicking in each room on this floor. Don’t 
worry about the name or number of the rooms 
you are tagging at the moment. Tag the 
rooms as shown in the illustrations at right. 

 
 

Create a Room Schedule Autodesk Revit Building also allows modification of 
the names of the rooms from within the schedule 
table itself. For this, however, you need to have 
created the room schedule—something you have 
not yet done. Although the room names appear in 
your door schedule table, you cannot modify them 
from here.  
 
When the room schedule is created before the 
actual room and with the condition that the room 
names exist in that table, you can select that room 
as it is inserted using the Options Bar. 

 

The most effective solution is to select the room tag 
itself and change its properties on the fly: click the 
room tag text, and the text becomes an editable 
zone. Type the desired text, and press Enter or 
simply click anywhere in the workspace with the left 
mouse button. 
 

13. On the View tab of the Design Bar, select 
Schedule Tables. 

14. Select Rooms as a category, and click OK. 

 

 



15. In the Schedule Table Properties dialog box 
add the fields Number, Name, Area, 
Perimeter, and Level. 

 

16. Click the Sorting/Grouping tab. 

17. Under Sort By, select Number. 

 

18. Click the Formatting tab. 

19. Select Level and select the Hidden Field 
check box. 

 
 

20. Select Area, and click Field Format. 

 

 
 
 



21. Clear the Use Project Settings option, and 
then set Square Feet as Units, 1 Decimal 
Place as rounding, and SF as Unit Suffix. 

 

 

22. Repeat for the Perimeter field (set units feet 
and fractional inches, rounding nearest 1/2”). 

23. Click OK. 

 
Notice how even though there are rooms on the level 
1, they do not show up in the schedule because no 
rooms have been placed on this level. 
Also even though you duplicated Level 2, only one 
row shows up in the schedule for each room. 

Putting Rooms and Tagging 
Together with the Room Schedule 

In this section you open the first floor plan and tile 
the views before you add the rooms to the first floor. 

You also use the area separation lines to define 
rooms not enclosed by walls. 

24. Close Hidden Windows, and tile the Room 
Schedule and Floor Plans: Level 1. 

 

 



25. Use the Room tool from the basics tab of the 
Design Bar to add a room tag to the powder 
room at the middle right of the plan. 

 
A room is added to the schedule, and a tag is added to the room. 
The room shows up in the schedule with its area and perimeter. 

26. Click in the Tag Room Name field, and set 
the room name to Powder. 

  

 
You can modify either the tag or the schedule. 

27. Make the schedule the current view, and click 
the Rows: New button. 

 

 

28. In the schedule, type Living Room for the new 
room name.  

Because this room does not exist as a room object in 
the project yet, the area and perimeter cannot be 
calculated. 

29. Click the Room tool, and on the Options Bar, 
set the following: 

a. Tag type = Room Tag With Area 
b. Upper Limit = Level 1 
c. Offset = 8’-0” 
d. Room = 8 Living Room 

 

 

The room you added to the room schedule is 
available as a room to add. 
 



30. Use the Room tool to add a room and tag to 
the living room. 

 

Before you place the tag, the assumed perimeter is 
highlighted. 
 

31. In the schedule, change the name from Living 
Room to Living on the last line. 

 
 

The tag updated. 

 

 

The living room extends through the entire floor 
where there are no room bounding elements to 
constrain it. Room bounding elements can be 
columns, curtain walls, walls, or room separation 
lines. 

Separating Rooms In this section you add room separation lines 
between the stair and living room areas. These lines 
enable rooms to exist side by side when there is no 
wall between the rooms. 

 

32. Tile both the room schedule and the view 
Level 2- Room Areas. 

33. Click the Living room in the schedule, and 
then click the Show button on the Option Bar. 

 

The plan view zooms to the room selected in the 
schedule. This shows the living room extending into 
the stair area. 



34. On the Design Bar, click the Room and Area 
tab. 

35. Click the Room Separation tool. 

 

 
 

36. Click the wall at the bottom of the stairs. 

37. Click the wall at the powder room. 

 

The tag is now associated with the area of the living 
room up to the room separation line. The tag updates 
to show the smaller size. 

 

38. Add two more room separation lines to 
separate the stair: 

• Add this to both the first and second 
floors. 

 First Floor Second Floor 

39. Add a room to the north side of Level 1 and 
name it Kitchen. 

 

 



Add a Multifloor Spanning Room Stairs and how their areas are calculated vary from 
region to region. Often stairs, atriums, or other 
spaces that span multiple floors are only calculated 
once. To do this, the room must have parameters 
that tell it to extend up to these upper levels. 

 

40. Set the Level 1 plan current.   

41. Click the Room tool, and set the Upper limit to 
Level 2 with Offset of 8’.  

 

42. Add this room to the stairs area on Level 1. 
Rename this room Stair. 

 

 

43. Set the view Level 2 – Room Areas current 
and tag the stair. 

 

The tag takes on the value of the space you just 
added because the volume of the space extends up 
8’ past the 2nd floor level. 

Add a Volume Column to the Room 
Schedule 

If you turn on volume in the room and area settings, 
you can then add the volume column to the room 
schedule. 

 

44. On the Design Bar, click the Room and 
Area>Settings tool. 

 

 



45. Select Compute Room Volumes. 

 

This dialog box also give you control over how the 
room areas are calculated. 

 

46. Set the Room Schedule current, and open its 
view properties. 

  

47. Edit the fields to add Volume to the schedule. 

 

 

48. Click OK to return to the schedule. The Schedule now reports volume for each of the 
rooms in the project. 

 
 
 
 
 
 



Unit 18, Exercise C: Calculated Values for Rooms 
In this exercise you duplicate a room schedule to create a schedule that shows each room as a percentage of the whole project. 
 
 
 

Create a Calculated Values Table for 
the 2nd Level 

 Using the room schedule table created in the 
previous exercise, you can easily create another one 
in which you directly read the total of each room 
(Kitchen, Living Room, Room) as well as the 
percentage of that room type according to the total 
area of the building. 

1. Open data set: Unit 18c – Start.rvt. Verify the 
Room Schedule is the current view. In the 
Project Browser duplicate the Room 
Schedule and name it Room Schedule 
(Level2 – Surfaces). 

 

  
All these commands are also available when you 
right-click the schedule in the Project Browser. 
 

2. Right-click the newly created schedule, and 
choose Properties. 

 

3. Click the Edit button next to the Filter. 

4. Add a new filter condition under Filter By: 
Level equals Level 2. 

 

5. On the Fields tab, select the Number and 
click the Calculated Value button. 

 

 



6. In this dialog box, set the following: 

• Next to Name, enter % (Total). 

• Click Percentage. 

• Next to Of, select Area. 

• Next to By, select Grand Total. 

7. Click OK. 

 

 

 

8. Click the Sorting/Grouping tab.  

9. Change the sorting condition to Name. 

10. Select Header and Footer (keep Title, Count, 
and Totals). 

11. Select Blank Line. 

12. Select Grand Total (keep the Title, Count, 
and Totals). 

 

 

 

13. Click the Formatting tab. 

14. Select the calculated field that you created 
previously (%Total). 

15. Select Calculate Totals. 

16. Click Format. 

17. Next to Units, select Percentage, Rounding 1 
Decimal Place. 

18. Click OK to return to the schedule. 

 
 



19. Save the project.   

 

Unit 18, Exercise D: Room Schedule Keys 
In this exercise you add room finish keys to the schedule. 
 
 

Add Room Finish Keys to Schedule To finish your schedule table, you are going to 
create a schedule key. The idea is to be able to 
associate to each room a finish for the walls, floor, 
and ceilings. 

Instead of tediously copying and pasting these 
values to each room, you prepare a new schedule in 
which all those finishes are listed and then link it to 
your room schedule. 
 

1. On the Views Design Bar, click 
Schedule/Quantities. 

2. From the Category list, select Rooms. 

3. Select Schedule Keys. 

4. You can change the name of the schedule if 
you want to. 

5. Click OK. 

 

 

 

6. From the Available Fields, select Floor Finish, 
Wall Finish, and Ceiling Finish. 

 

The Key Name field is automatically generated. It is 
this field that creates the link between the two 
schedules. So, do not delete it!  
 



7. Click OK. 
 

The schedule key tables are usually empty when 
created. Your next task is to fill it with all the 
necessary information. 
 

8. On the Options Bar, click New. 

 

9. In principle you should now fill out all the 
information you have about all possible 
finishes. The first column is automatically 
generated as a numeric column in which the 
number increments with every new added 
line. You can change the numbers but you 
cannot duplicate numbers.  

10. Next, you link this schedule to the room 
schedule so that you can use these values 
within it. 

 

11. In the Project Browser, right-click the room 
schedule, and choose Properties. 

12. Click the Edit button next to Fields. 

13. Under Fields, you can now add the following 
fields: Room Style, Floor Finish, Wall Finish, 
and Ceiling Finish.  

14. Click OK. 

 

 

 



15. The principle is simple: you click the Room 
Style fields and select the key corresponding 
to the finishes in that room. The Floor Finish, 
Wall Finish, and Ceiling Finish columns are 
automatically filled. 

 

 
 

 

Unit 18, Exercise E: Color Fills 
In this exercise you create a color fill legend to give a visual indicator to the information held in the room objects. 
 

Add a Color Fill  To finalize your plan, you add a color fill of the areas. 

1. From the Project Browser, activate the Level 
2- Room Areas.  

2. From the Room and Area tab, click Color Fill 
and place the legend next to the floor plan. 

 

 

3. Click OK in the information dialog box that 
appears. 

 

 

4. Select the Color Fill object, and click the Edit 
Color Scheme button on the Options Bar. 

 

 



5. Change the Color value to Name. 

6. Colors are automatically assigned to each 
room name in the view. 

7. Click OK. 

8. Repeat editing the color scheme. Try color by 
Floor Finish, color by Area.  

9. Change colors by selecting a color button to 
the right of a name. 

10. Return the color scheme to Name, and return 
to the drawing window. 

 

11. Select the legend. 

 

 Allows dimensioning of the width of the legend. If 
the legend has more than one column, you can 
change their widths independently. 

 Allows dimensioning of the height of the legend. 
Should the height you are setting not be sufficient for 
the entire legend, Revit Building automatically splits 
the legend in various columns. 
 



 
Unit 18, Exercise F: Legends 
In this exercise you create a window legend. A legend is a chart of symbols in the project. You can create legends of any Autodesk Revit Building objects, such as 
walls, windows, furniture, and so forth. 
 
The exercise uses the same data set as the previous exercise but does not build on the information created in that exercise. 
 

Create a Legend   

1. From the File menu, choose Open>Browse to 
find the file Unit 18f – start delivered with the 
workbook. 

 

 

2. On the Design Bar, click Views, and then click 
the Legend tool. 

  

This creates and opens a new view. The new view is 
created in its own category in the Project Browser. 
 

3. Rename the legend to Window Legend. 

 

The legend view appears blank with no views of the 
building model. Think of a legend as a piece of paper 
on which you place symbols that represent the 
objects in the building model. 



4. Click the Design Bar Modeling tab.  Notice that all the tools are unavailable. There is a 
special tool you use to add the objects in symbol 
mode to the legend. 

5. Click the Design Bar Drafting tab. 

6. Click the Legend Component tool. 

 

 

7. Use the Options Bar drop-down to select the 
following: 

a. Family = Windows:Slider with Trim 6’ – 4’ 
b. View = Elevation Front  

8. Click in the legend to place the window.  The symbol of the window is shown in the legend. 

9. Repeat, adding the window types shown 
here. 

 

 

10. Change the scale of the legend to 1/2” = 1’-
0”. 

 

 



11. On the Design Bar, Basic tab use the 
dimension tool to dimension the windows. 

 

Because this is a window type, the window legend is 
a convenient location to place common information 
about this window that occurs in multiple locations in 
the project. 

12. On the Design Bar, Basic tab use the Text 
tool to add notes to the legend. 

 

13. Open the schedules sheet, and drag the 
legend onto it from the Project Browser. 

 

14. Save and close the project.   



Unit 18, Exercise G: Material Takeoffs 
A material takeoff is just a specialized form of schedule. This exercise leads you through creating a material takeoff view for the walls. 
 
The exercise uses the same data set as the previous exercise but does not build on the information created in that exercise. 
 

Create a Material Takeoff List   

1. From the File menu, choose Open>Browse to 
find the file Unit 18g – start delivered with the 
workbook. 

  

2. From the View menu, choose New>Material 
Takeoff. 

 



3. In the New Material Takeoff dialog box: 

a. Click Category: Walls. 
b. Click OK. 

 

4. On the Field tab, add the fields shown in the 
illustration at right. 

 

 

5. Leave the Filter set to None.  

6. On the Sorting/Grouping tab: 

a. Set Sort By to Material Name. 
b. Check Footer and set to Title Count and 

totals. 
c. Check Blank Line for this sort criteria. 
d. Clear Itemize Every Instance check box. 

 



7. On the Formatting tab: 

a. Select Material:Area. 
b. Select Calculate Totals. 

 

 

8. Click OK. The materials schedule is now part of the project. On 
your own add the cost field and add a calculated 
parameter that multiplies the area field times the cost 
field. 

 
 
 
 
 
 
 



Unit 19 
Theory: Time 

Autodesk Revit Building: Phasing 
This unit explains how the time parameter is managed in Autodesk Revit Building. 
 
1. Open File Unit 19 – Start.  

2. In the Project Browse, right-click Floor Plan 
Level 2. 

3. Duplicate the view. 
4. Rename the new view Level 2 – Demolition. 

  

 

5. Open the view properties for Level 2 – 
Demolition and change the following: 

a. Phase to New Construction 
b. Phase Filter to Show All 

 

To open View Properties you can right-click the 
view in the Project Browser and choose 
Properties, or right-click anywhere in the view 
and choose View Properties from the context-
sensitive menu. 
 



6. Click OK to close the dialog box. 

 

Note how the appearance of the existing 
components changes when the phase of the 
view is changed. 
 
The first thing you should notice is that views 
have a parameter called phase. Depending on 
the value of this parameter, all components 
created (or demolished) in this view, have their 
Created Phase set as the one the view belongs 
to. In this case, the walls and doors you 
demolish were created in the Existing Phase and 
will be demolished in the New Construction 
Phase. 

7. Click one of the walls in the plan. Open its 
properties. 

8. Verify the wall’s Phase Created is set to Existing 
and Phase Demolished is set to None.  

For every object in the building model there is 
also a phasing property. For each object, 
Autodesk Revit Building tracks the phase 
created and the phase demolished. As noted 
earlier, the phase created is read from the phase 
property of the view in which it is created. 

Demolish Walls and Doors 
 

 

9. Click the Demolish icon on the toolbar, and then 
click the walls in the middle of the building (see 
image). 

 
 
 
10. Click the wall dividing the bathroom area on the 

bottom left (see image). 

 

When you demolish a component, its display 
changes according to the phase filter assigned to 
the view. 
 
Phase filters are found in the view properties. 
 
The override of the display of the components is 
defined in the phase settings: Settings>Phases> 
Graphic Overrides tab. 



11. Add new walls and doors as shown in image. 
You don’t need to be exact about positioning the 
components, but you should design a plan that 
makes sense. 

 

As you add the walls, verify that the height is set 
to Level 3. 

12. Duplicate the Level 2 Demolitions plan view 
from the Project Browser and rename it to Level 
2 – Complete. 

  

13. Open the View Properties and change the 
Phase Filter parameter to Show Complete. 

14. Click OK to exit the dialog box.  

 



15. On the Room and Area Design Bar, click Room 
and create (and rename) the rooms as shown in 
the image. 

 

16. In the Project Browser>Schedules/Quantities, 
right-click the Schedule table: Room Schedule –
Existing and duplicate it. 

17. Rename it to Room Schedule – New 
Construction. 

 

 

18. In the Project Browser, right-click the newly 
created schedule, and choose Properties from 
the context-sensitive menu. 

 

 



19. Change the Phase parameter to New 
Construction. 

20. Click OK to close the window. 

 

21. In the Project Browser duplicate the 3D view: 3D 
Existing Cropped and rename the new view 3D 
Demo Cropped. 

22. Open the newly created 3D View properties and 
change the Phase to New Construction. 

 
23. Click OK to close the dialog box. 

 

24. Duplicate this 3D view and name the new view 
3D Complete Cropped. 

25. Open the newly created view’s properties and 
change the Phase filter to Show Complete, and 
Phase to New Construction. 

26. Click OK to close the dialog box. 

 

 

27. Set the existing sheet A101 Unnamed current. 
 

 

This sheet already has the original views placed 
on it: 

• 3D Existing Cropped 
• Existing Room Schedule 
• Level 2 (Floor Plan) 



28. Drag the view: Level 2 - Demolition on the sheet 
and position it in the middle, as shown in image.

 

 

 

29. Drag on the sheet the views:  
• Level 2 – Complete 
• 3D Demolition Cropped  
• 3D Complete Cropped 
• Room Schedule – New Construction 
30. Position them as shown in image. 

 

 



Unit 20 
Theory: Variation 

Autodesk Revit Building: Options 
 
This unit guides you through the powerful Design Options feature. You start using a file that already contains a couple of design options. 
 
 
1. Open File Unit 20 – Start. This file contains an 

option set with two different design options.  
2. Open Floor Plan Level 2 – Option 1. 

 

 

3. Close hidden windows. Open Floor Plan Level 2 
– Option 2 and tile windows to display both 
options. 

 

Note how tiling windows lets you visualize both—
or more—options in different views. 
 
Both views represent the 2nd floor of the 
building. All components are held in the building 
model. However, the interior walls of the floor, 
along with the stair and east wall,are held in 
design options. 



4. In Plan: Level 2 – Option 1, try to click the door 
of Office 212. 

 

When the project contains Design Options, the 
Options Bar displays a check box to allow 
selection of components that are part of the 
option set: 

 
This is just a check to keep you from 
inadvertently changing objects that are in a 
design option. 

View the Options   

5. Right-click the toolbars, and select the Design 
Options toolbar. 

 

In this file you have only one option set, but you 
can have as many as you want. Normally, an 
option set is a specific part of a building where 
you want to try different design alternatives. An 
option set can contain as many options as you 
want. 

6. Click the Design Options tool to open the 
Design Options dialog box. 

 

 

7. Select Option 1 – Standard, and click Edit 
Selected. 

The Now Editing window displays the active 
edited option. 
 
When you edit an option, all components that are 
not part of the option are displayed in gray. 



8. Do not dismiss the Design Options dialog box 
yet. 

 

9. In Design Options dialog box: 
a. Click Finish Editing. 
b. Click Curtain Wall. 
c. Click Edit Selected. 

 

With two options as in this case, you have three 
sets of objects: 

• Those in the main model 
• Those in sets unique to each of the 

options 
When you are editing an option, you can see and 
refer to objects in the main model, but by default 
you cannot edit them. 

10. While still in Edit Curtain Wall option mode, click 
Close in the Design Options dialog box. 

 The Options Bar displays a check box that 
allows selection of components that belong to 
the main model (not to an option set).  

 

11. Click the Edit Options Tool button to end editing 
the curtain wall option. 

 You are returned to standard editing mode with 
neither option open. 



12. Click the Edit Options Tool button, and from the 
drop-down menu, select Options Set 1: 
Standard (Primary). 

 

This shortcut bypasses the Design Options 
dialog box.  
 
This tool is cyclical. If you click it again, you exit 
the edit option mode (don’t do this yet). 

13. Select the stairway on the east end of the 
building. From the Edit menu, choose Copy to 
Clipboard. 

  

Copy to Clipboard and Paste Aligned (Same 
Place) constitute an easy way to replicate a 
situation among different options. 
 
You can also duplicate an option within an option 
set by selecting it in the Design Options dialog 
box and clicking Duplicate. 

14. On the Design Options toolbar click the Edit 
Option button to finish editing the option.  

The Design Options toolbar allows for quick 
selection of the available design options. 

15. Click Edit Option button again and from the 
drop-down list, select Option Set 1: Curtain 
Wall. 

 

 

16. From the Edit menu, choose Paste 
Aligned>Current View. 

  

 



17. In the Level 2 Option 2 window, select the stair, 
and click Edit on the Options Bar. 

 

When editing stairs, you enter sketch mode. 

18. Reshape the landing boundary of the stair as 
shown in image. On the Design Bar, click Finish 
Sketch. 

  

19. Add walls and doors to complete the design, as 
shown in image. 

  

When working in the stair sketch mode, click the 
Boundary button on the Design Bar to draw the 
boundary using lines. Select the arc line 
template. Draw the line and click Finish Sketch. 



20. On the Basics Design Bar, click Room Tag. Tag 
all the existing rooms in the option. After placing 
the tags, rename the rooms as shown in image.

   

21. Add rooms with tags to the new rooms you 
created by modifying the walls. 

 

If you want the rooms to be part of the option, 
make sure you are still editing the option before 
adding the rooms. 

22. On the Design Options toolbar, click the Edit 
Option button to finish editing the option.  

 

Assign an Option to a View  You have been working in two views that are 
both views of the 2nd level. The only difference 
between these is a setting in the view properties 
assigning one option or the other. 

23. Open 3D View – Option 1.  

 

By default, a view shows the option marked 
(Primary), in this case the standard option. 



24. In the Project Browser, right-click the 3D view 1 
and choose Duplicate. 

25. Rename the view 3D View - Option 2. 

 

 

26. Open the View Properties dialog box by right-
clicking the view in the Project Browser and 
choosing Properties. Click the Edit button next 
to the Visibility parameter. 

  

When there are design options in the project file, 
Autodesk Revit Building adds a new tab in the 
visibility settings of the views.  
 
You can display any option in any desired view: 
plans, elevations, sections, and so forth. 

27. On the Design Options tab, select Curtain Wall 
from the drop-down menu under Option Set 1. 

 

The drop-down menu displays the available 
options for the option set. 
 
When the value is set to Automatic, the view 
displays the primary option but switches to show 
the one you are modifying when in edit mode. 



28. Click OK twice to close the dialog boxes and 
see the changes. 

 

Assign an Option to a Schedule   

29. In the Project Browser, duplicate the 
Schedules/Quantities: Room Schedule. 

30. Rename the new schedule view to Room 
Schedule - Curtain Wall Option. 

31. Right-click the newly renamed schedule and 
choose Properties. 

 

Schedules are views as plans and sections. 
They can display the desired design option to 
evaluate the different quantities or costs 
according to the option displayed. 

32. Click the Edit button in the Visibility row. 

  

 



33. From the drop-down menu select Curtain Wall. 
Click OK to close the dialog box. 

  
 
 

Although access to this component is a bit 
different for the schedule than for the 3D view, 
the theory is the same. A schedule is just a text 
view of the building model. 

 

 
Predesign options set shows the entire model along with 
the standard option (primary) rooms. 

 
After you assign the option, it lists only those 
rooms that have been tagged in that option. 
 
This is essential because one option may call a 
room an office, and in another office a similar 
area may be a storage closet.  

Place Views of the Options on a Sheet   

34. In the Project Browser, double-click the sheet 
A101 – Options Compared. 

  

35. In the Project Browser, drag Floor Plan – Level 
2 Option 2 onto the sheet as shown in the 
image. 

  



36. Place the following views on the sheet, as 
shown in the image: 3D view Option 2, Door 
Schedule Curtain Wall Option, and Room 
Schedule – Curtain Wall Option. 

 

You have to turn on the crop region of the 3D 
view Option 2 and adjust the boundaries of the 
crop region to fit on the sheet.  
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